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Chapter 1: About Job Scheduler
1.1 What is Job Scheduler?
Definition
The Job Scheduler allows you to define and maintain a set of jobs that need to be automatically executed
either at a given point in time, at a specified frequency or when a specific event occurs in IGSS. You can
use it to execute an program or to just display a message to remind you of something.

Use
The list below shows you examples of what you can use Job Scheduler for:
l

Print a daily report at 7:00 AM every day

l

Print a weekly report every Monday at 7:00 AM

l

Print a monthly report on the 1st day of every month

l

Display a "Remember to back up files" message at 4:30 PM every day

l

Print a snapshot report when a pump stops

The job list
One or more scheduled jobs make a job list. You can save a job list on the hard disk (<filename>.jch)
and have Job Scheduler load this list and execute the list of jobs whenever you want. Note that only one
job list can be active at a time. The figure below shows an example of a job list.

Note: By default, the active job list is the one that corresponds to the active IGSS configuration, <MyConfig>.jch.

Job Scheduler in Startup group
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Since Job Scheduler needs to be running for scheduling and running the jobs, you would like to include Job
Scheduler in the Startup group of programs. Then, whenever you switch on the system and log on, Job
Scheduler will ensure that the jobs in the active job list are executed at the scheduled time.

One job at a time
Job Scheduler will launch only one program or display one message at a time although you may have
added a number of jobs to be executed at the same time. Thus, it is not possible to launch a second program when another program is running through Job Scheduler even if the second program’s scheduled time
is overdue.
l

It is thus required that the jobs will finish automatically, otherwise they will prevent all other jobs
from being executed.
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Chapter 2: The User Interface
2.1 Main window
The main window consists of four elements:
l

The menu bar

l

The toolbar area

l

The job list area

l

The status bar

Click on any part of the figure below for further information.

2.2 Menus
The following menus are available. To get a detailed description of each menu item, click one of the menus
below.

File menu
Job menu
View menu
Options menu
Help menu

2.3 Toolbar
To see what a button does, click it in the following illustration.
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2.4 System tray icon
You can always verify that Job Scheduler is running by looking at the system tray in the task bar. The
small alarm clock is shown here when it is running.

You can double-click this icon to restore the Job Scheduler window when
minimized.
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Chapter 3: Overview of Features
3.1 The job list
Definition
A job list is a set of scheduled jobs which can be automatically activated by Job Scheduler . You can have
several job lists for a given configuration, but only one list can be active at a time. Each job list is saved in
a Job Scheduler file (*.jch).

Note: When you launch the Job Scheduler program, it will automatically open a file with the same name as
the active configuration, <MyConfig>.jch. The file will be created if it does not exist.
Example
The example below shows a job list with a number of scheduled jobs. The first three ones automatically
print standard reports from IGSS (daily, weekly and monthly). The fourth one displays a "Back up files
on harddisk" message. The fifth one prints a snapshot report when p1 changes from OFF to ON.
For details about the individual columns, click here.

3.2 Scheduling jobs
Introduction
This topic gives you an overview of how you define jobs and the possibilities you have. To illustrate the
functionality, a number of examples are included.

Creating a job
The flowchart below shows the steps involved in creating a job. Click on each box for further details.
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3.3 The Event Log
Introduction
The event log shows a complete log of all launched jobs indicating the exact time and status of each job.
You can view the log by selecting View → Event Log.

Example
Here is the event log for the examples used in this Help file.

By default, WordPad is used as the log viewer and the filename is set to
Event.txt. You can change this by selecting Options → System
Options.
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3.4 Using Job Schedulerwith Server Switch
When setting up operator stations in the System Configuration form, it’s possible to enable a server
switch parameter. The feature is found on the operator station tab called Server & Backup and is enabled
with a check box at the bottom of the dialog box. It allows the operator station to switch back and forth
between two or more IGSS servers in the network.
If the Job Scheduler functionality is used in the IGSS application together with the server switch function,
problems will arise if Job Scheduler is run from an operator station configured with server switch.

When using server switch, make sure that Job Scheduler is running on the IGSS server or on an operator station not configured with server switch.
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Chapter 4: Managing Job Lists
4.1 Create a new job list

1. Select Create a new job listt File → New or click

.

Result: An Untitled list appears.

2. Select File → Save or click

and give the list a descriptive name.

3. Create the jobs in the list.

How?

When you open Job Scheduler, the job list file corresponding to the active configuration, <MyConfig>.jch, will automatically open. If the file does not exist, it is automatically created.
Thus, if you create or open a file with another name for the same configuration, you must manually
open it each time you launch Job Scheduler. Alternatively, you can specify the filename in the program shortcut by typing: Jobsch.exe <filename>.jch.

4.2 Open a job list

1. Select File → Open or click

and find the Job Scheduler file (*.jch) and click Open.

When you open Job Scheduler, the job list file corresponding to the active configuration, <MyConfig>.jch, will automatically open. If the file does not exist, it is automatically created.
Thus, if you create or open a file with another name for the same configuration, you must manually
open it each time you launch Job Scheduler. Alternatively, you can specify the filename in the program shortcut by typing: Jobsch.exe <filename>.jch.
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4.3 Save a job list

1. Select File → Save or click

.

2. Give the list a descriptive name.

When you open Job Scheduler, the job list file corresponding to the active configuration, <MyConfig>.jch, will automatically open. If the file does not exist, it is automatically created.
Thus, if you create or open a file with another name for the same configuration, you must manually
open it each time you launch Job Scheduler. Alternatively, you can specify the filename in the program shortcut by typing: Jobsch.exe <filename>.jch.

4.4 Delete a job list
1. Find Delete a job list the Job Scheduler file (*.jch) using Windows Explorer.
2. Delete the file.
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Chapter 5: Creating and Launching Jobs
5.1 Create a new job

1. Select Job → Add or click

. The Job Properties dialogue appears.

2. On the Action tab, define what you want the job to do. You can run a program or display a message.
3. On the Start Condition tab, define when you want the job to be launched. You can define a
fixed interval (Periodic) or launch the job when a certain event occurs in the active configuration (IGSS Event Occurrence).
4. On the Options tab, you can limit the lifetime of the job and specify that you want the operator
to confirm job execution.
5. Click OK. The job appears in the job list.

For details about a property in the Job Properties dialogue, click

, then click the item.

5.2 Edit job properties
To edit job properties, do one of the following:
l

Double-click the job

l

Select the job and click

l

Right-click the job and select Edit

For details about a property in the Job Properties dialogue, click

, then click the item.

5.3 Enable or disable jobs
Each job in the list can be enabled or disabled as follows:

1. Select the job in the list.
2. Select Job → Enable to toggle between the two states or right-click the job and select Enable.

5.4 Launch jobs manually
Once you have completed the definition of a job, it is recommended to launch it manually to test that it
works as planned.
Do one of the following:

l

Select the job and click

l

Select the job and select Job → Launch.
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l

Right-click the job and select Launch

A manual launch will not reschedule the job.

5.5 Suspend all jobs
To temporarily suspend the scheduling of all jobs in the list, do as follows:
l

Select Options → Suspend Scheduling.

The title bar shows Suspended. No jobs will be launched in this mode.

Selecting the option again, returns Job Scheduler to normal mode. The title bar shows Active.
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Chapter 6: Viewing the Event Log
6.1 View the event log
If you want to take a closer look at all View the event log the jobs which have been activated, use the
event log.

Do as follows:
l

Select View → Event Log.

By default, WordPad is used as the viewer and the filename is set to
Event.txt. To change these settings, select Options → System
Options.
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Chapter 7: Command Line Interface

7.1 Overview: Command line interface
Job Scheduler allows you to manipulate some IGSS programs via their command line interface. The jobs
you create can be activated at periodic intervals or based on IGSS events.
The command line parameters are inserted in the Parameters field on the Action tab of the Job Properties dialogue. Note that theJob Scheduler program has its own set of parameters that you can use in
conjunction with these command line interfaces.
Here are some examples of what you can do:
l

Print a daily report

l

Print alarm information when an alarm occurs

The following programs have a command line interface:
l

Alarm

l

Job Scheduler

l

Reports

l

Supervise

7.2 Job Scheduler: Command line interface
The Job Scheduler program offers a number of parameters that you can include in any command line used
by an IGSS program.

If you are running a command line from a command prompt, these parameters cannot be used.

Command line parameters
Some IGSS programs offer a $ parameter in their command line interface to define an offset in time. In Job
Scheduler, you can freely choose between that "native" $ parameter or use the ones below.

Parameter

$(year)

Examples
$(year-1) inserts the launch time of the job minus one year.

If the job is launched on 01-01-2000, Job Scheduler inserts 01-01-1999.

$(month)

$(month-1) inserts the launch time of the job minus one month.

If the job is launched on 01-01-2000, Job Scheduler inserts 01-12-1999.

$(date)

$(date-1) inserts the launch time of the job minus one day.

If the job is launched on 01-01-2000, Job Scheduler inserts 31-12-1999.
For the $(Date) parameter, you can specify which unit (Days or Hours) is to be added to or
subtracted from the present date and time. Days do not need specification and $(Date-2)
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Parameter

Examples

will subtract two days from the present date. Hours must be specified by the "h" suffix.
$Date-2h) will subtract 2 hours from the present date.
If you want the $(Date) parameter to adjust the date as well as the time when using the
$(Time) parameter, you must specify the same hour offset in the $(Date) parameter as the
hour offset used in the $(Time) parameter.

$(time)

$(time-1) inserts the launch time of the job minus one hour.

If the job is launched at 10:00:00, Job Scheduler inserts 09:00:00.
The $(Time) parameter will only update the hours and not the date . Specifying a time offset which will place the time in the previous or next day will only adjust the time and not
the date.
For example: Specifying $(Time-4) for the date 2014-05-15 and time 22:00 will result in
the following date 014-05-15 and time 02:00.
If you want the date to move 4 hours back, use the following parameters: $(Date-4h) and
$(Time-4)
The date 2014-05-15 and time 22:00 will result in the following date 014-05-14 and time
02:00.

Rules
When using the parameters, the following rules must be observed:
l

l

You can add (+) or subtract (-) a time unit from the launch time defined for the job.
If you only write the parameter, it will be inserted as is. $(year) will insert the current year,
$(month) the current month, $(date) the current day and $(time) the current time.

l

You can combine the $(time) parameter with $(year), $(month) and $(date).

l

You cannot combine $(year), $(month), $(week) and $(date).

Examples
Date format used in the examples: yyyy-mm-dd. Time format used is 24-hours.
Example 1 Daily report one day back

This example shows you how to use the Job Scheduler $(date) parameter to define a date offset for a periodical report. The command line will generate a daily report based on the Periodical_Report report
format for the date one day before the launch time for the job $(date-1). The output will be sent to the
default printer. Local time will determine the launch time of the report.

RMSCMD STD FMT=Periodical_Report $(date-1) TYPE=DAY -LOCAL -PRINT
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Example 2 Time offset

Based on example 1, this command line will generate the Periodical_Report daily report with the report
format 5 hours back from the launch time.
Local time will determine the launch time of the report.
If the launch time is 2017-04-05 12:00, the start date of the report format will be 2017-04-05 07:00.
If the launch time is 2017-04-05 02:00, the start date of the report format will be 2017-04-05 21:00.

RMSCMD STD FMT=Periodical_Report SD=$(DATE) ST=$(Time-5) TYPE=DAY LOCAL
Example 3 Date and time offset

Based on example 1, this command line will generate the Periodical_Report daily report with the report
format 5 hours back from the launch time, going one day back if the 5 hour offset in the $(Date) parameter
ends in a time for the previous day.
Local time will determine the launch time of the report.
If the launch time is 2017-04-05 12:00, the start date of the report format will be 2017-04-05 07:00.
If the launch time is 2017-04-05 02:00, the start date of the report format will be 2017-04-04 02:00.

RMSCMD STD FMT=Periodical_Report SD=$(DATE-5h) ST=$(Time-5) TYPE=DAY LOCAL
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Chapter 8: Reference
8.1 Getting Help in IGSS
IGSS comes with a comprehensive help system designed to help both system designers and operators to
get started with IGSS as quickly as possible.

Documentation overview
The IGSS documentation includes the following items:

Documentation item

Description

Getting Started

An introduction to IGSS and its most fundamental terms and features.
Getting Started is intended to get you up and running as fast as possible. The manual provides a system and architecture overview followed by a number of real-life use cases you can go through before
building your first real IGSS project. The manual is available in Adobe
Acrobat format (.pdf).
For each module there is a help file with the same name as the module
itself, for example, Def.chm for the Definition module.

Module help

The help file is invoked by clicking the
in the upper right corner of
the module. The Table of Contents will then allow you to browse
through the topics.
For each Form or dialog there is a help topic with the following standard information:

Form and Dialog help̓

l

Overview

l

Preconditions

l

Where do I find it?

l

Field help

Form help is invoked by clicking the help button
in the upper right
hand corner of the dialog box or located in the Table of Contents of the
individual help file.

Thematic help

IGSS also provides thematic help. When there is a special theme that
requires special attention from the user, a dedicated help file is
provided. Examples include "Driver-Specific Help" and "Database
Administration Help".

Where are the help files located?
The IGSS help files are located in the appropriate language folder in the installation path of IGSS, by
default C:\Program Files\Schneider Electric\IGSS32\V13.0. The help files are available in English at
release time.
The paths to the help files are:
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Language

Path

English

[IGSS InstallPath]\ENG

Danish

[IGSS InstallPath]\DAN

German

[IGSS InstallPath]\DEU

Translated help files
Selected help files have been translated into Danish. If you require help files in your language, please contact Schneider Electric.

Help updates
The help files are continuously updated and improved. Check regularly with the IGSS Update in the IGSS
Master.

8.2 Conventions in this Manual
The following typographical conventions are used:

Convention

Description

Example

User interface element

When referring to labels and names
in the user interface.

User input

When the user has to type specific
data in IGSS

The Data Management tab.

Type the following description:

Incoming flow in Tank 2

Module
name

When referring to a module in IGSS

Note

A note emphasizes or supplements
important points of the main text. A
note provides information that may
apply only in special cases.

Tip

A tip suggests alternative methods
that may not be obvious in the user
interface. A tip also helps the user in
working more effectively with IGSS.
A tip is not essential to the basic
understanding of the text.

Alternative to this simple
find function, you can also filter on text in the messages
in Driver Log Filters dialog
box.

Warning

A warning is an important note that is
essential for the completion of a

If you disregard the System

Open the Definition module.

By default, the timestamp is in universal
time format, UTC1. This can be changed in
the Driver Log Filters dialog box.

1 Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating time in

most parts of the world. IGSS uses this time format internally in the database. You can switch between UTC
and local time by enabling or disabling the "UTC" field in various dialog boxes in the system.
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Convention

Description

Example

task. In some cases, disregarding a
warning may result in undesirable
functionality or loss of data.

alarm, you may risk loss of
data in the LOG and BCL
files.

8.3 Version Information (IGSS Help System)
© Schneider Electric, IGSS Version 13.0
The IGSS help files are based on software build number 10305 (initial release)

English help files
To update the help files, click the Update IGSS Software button on the Information and Support tab
in the IGSS Master . There must be a connection from the PC to the Internet. Every time IGSS Update is
run, IGSS help files as well as IGSS system files will automatically be updated on the PC from the web
server at Schneider Electric.
You select the languages you want to update in the Tools menu of the IGSS Update form.
If you are not able to update the IGSS system directly via the Internet, the alternative is to download the
updates from the Schneider Electric website as zip files. These can then be transferred onto a CD or USB
memory stick, which is then the medium used to update on site.

After updating your IGSS installation , the build numbers in various IGSS modules may change to a
higher number. This signifies that the module in question has been updated with newer files. Build
numbers consist of four digits, where the first digit represents the year and the last three represent
the day number in the year in question. The build number can be seen in the About dialog box which
can be activated from the Help menu.
An example:

Build number = 10305
18 = the year 2018
305 = The 305th day of the year
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Chapter 9: Glossary
A
Application menu
The Application menu is the first ribbon in the IGSS Master module. Click the icon to drop down
the menu. The menu contains items that were typically found in the File menu in previous versions of IGSS. In most modules, an "Options" item allows the user to define global module settings. The Application menu was introduced in the Microsoft Office 2010 package. It replaces the
Application button (nicknamed Doughnut) which was introduced in IGSS V7 and V8.

D
descriptor
A descriptor is the graphical display of an object. IGSS includes many types of descriptors including: - Built-in standard symbols - Animated symbols (Symbol Factory library) - Graphics and
animation - Drawing symbols - Windows controls - ActiveX controls An IGSS object can be represented with different descriptors on different diagrams.

R
Ribbon
The Ribbon is a new term/element in the Microsoft universe. The Ribbon replaces the well-known
toolbars in applications. The Ribbon provides quick access to the most commonly used functions
in the application. The Ribbon is divided into logical groups (the tabs) and each tab is divided into
sections (the blocks in the tab). The Ribbon is context-sensitive which means that only relevant
functions are accessible dependent on the current user action.

S
SCADA
Supervisory Control & Data Acquisition

U
UTC
Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating
time in most parts of the world. IGSS uses this time format internally in the database. You can
switch between UTC and local time by enabling or disabling the "UTC" field in various dialog boxes
in the system.
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