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Chapter 1: About Converting IGSS projects

1.1 Converting IGSS Projects

When you are upgrading from an earlier version of IGSS, there are a few things you have to do before you
can start using your older projects in the newest version.

Most importantly, the format of the old projects must be converted to the newest version. As a rule, you
will convert an existing project one version at a time.

Schneider Electric always recommends that you take a backup of your existing version before you
convert up to a newer version.

Important

The IGSS Support Team can analyze the project for any potential conflicts as well as clean the project to
reduce upgrade errors and optimize upgrade performance. This service is available to all customers with a
Support-and-Upgrade subscription and is limited to upgrades from IGSS version 6 and later.

Please be advised that pricing and scope of this service is subject to change and you should contact IGSS
for details regarding pricing and a time estimate for the project analysis and cleaning prior to upgrading
your project.

If you intend to take advantage of this service, it is recommended you contact the IGSS Support Team in
good time before an upgrade is expected to be deployed on the live installation. For complex and/or larger
projects, you should expect a longer processing time, depending on the size, complexity and age of the pro-
ject to be analyzed.
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Chapter 2: Converting from IGSS32 Versions 4 to 13

2.1 How to convert from version 4 to the newest version

These procedures will show you how to convert your IGSS project from versions 4 to 10 to IGSS 13.0

Convert from IGSS version 4 to 11 to IGSS13.0

1. Open the IGSS Master.
If you are in Runtime mode, click the Application Menu drop down and select Designmode.

2. Select the Design and Setup tab and click the Open Project button.

3. In the browser window, select the project file (.elm) that you wish to convert to IGSS 13.0 and
click Open. The following message is displayed:

4. Click Yes to start the conversion.

5. Click Yes if you want to reuse your previous ALM files in the new version 11. You will be promp-
ted for a destination to the report folder, where the converted ALM files will be created.

This step may be postponed. If so, you can later manually convert alarm files by running the
CnvTo10.exeprogram and opening the alarm files from the File menu. You should then remem-
ber to convert both the online alarms in the configuration folder and the alarm history in the
report folder.

If files are not converted, these files will be discarded when the IGSS Data Collector starts.
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6. Click Yes if you want to keep a copy of your existing ALM files.

7. If the conversion is successful, an information box will be displayed and the new project is auto-
matically opened. You will be prompted to install the project but you may postpone until you
want to run the converted project in the Supervise module.

Dynamic graphs

User-created Dynamic graphs are converted automatically when you upgrade your IGSS installation.

Changing SQL/MSDE version

If you are storing HDM, LOG and/or maintenance data in MSDE or a full SQL Server, it is recommended
that you continue to use these versions of MSDE/SQL and avoid installing the SQL Server 2005 Express.
IGSS will still work with the existing data.

If you anyway want to change to SQL server 2005, you should refer to the Microsoft user documentation.

Layers Feature

All converted descriptors will automatically be added to the default descriptor1 layer.

1A descriptor is the graphical display of an object. IGSS includes many types of descriptors including: -
Built-in standard symbols - Animated symbols (Symbol Factory library) - Graphics and animation - Drawing
symbols - Windows controls - ActiveX controls An IGSS object can be represented with different descriptors
on different diagrams.
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IGSS Mobile App

The mobile application for IGSS was introduced in IGSS version 11. When converting a project to
IGSS 13.0, all Areas and Diagrams that are displayed in the menu1 will automatically be set to be dis-
played in the IGSS Mobile App. Areas and Diagrams that are not displayed in the menu must manually be
set to be displayed in the IGSS Mobile App after the conversion process.

All objects in Areas and Diagrams that are displayed in the menu will also be displayed in the IGSS Mobile
App. Any other objects can be manually configured after the conversion to be displayed in the IGSS Mobile
App.

All alarm filters will be automatically be selected to be displayed in the IGSS Mobile App.

1An Area or Diagram with the Name to menu check box selected in the Area or Diagram properties.

Automatic Back up

The original project to be converted will be copied to the Backup folder of the current IGSS installation
prior to the conversion.

The folder used to contain the copy of the original project will be named using the following naming con-
vention YYYY-MM-DD HH-mm, where

l YYYY is the year

l MM is the Month

l DD is the Day

l HH is the hour

l mm is the minute

The backup folder of a project is converted on the 6th June, 2016 at 14:35 will therefore be named: 2016-
06-06 14-35.

Although the IGSS system copies the configuration prior to converting, it is still advisable to make
your own separate backup of the configuration, including all support files and data files prior to con-
verting.

See Also

"How to convert VBA code from version 5/6" on page 9

How to manually convert Dynamic Graphs
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2.2 How to convert VBA code from version 5/6

If you are using VBA and want to convert the VBA code from IGSS version 5 or 6 to IGSS 13.0, do the fol-
lowing to convert your VBA code:

1. If your VBA code is password protected, remove the protection in the existing version and save
the configuration. Protection may be reapplied once the configuration has been converted.

2. Run the CnvTo10.exe program as described in the procedure, "How to convert from version 4
to the newest version" on page 6

3. After converting your configuration, open the Definitionmodule.

4. If your VBA code has references to non-IGSS components, these references may need to be rees-
tablished in the VBA editor menu Tools/References.

5. Save your configuration - even if you have not made any changes.

2.3 How to convert RMS reports from version 7/8

This procedure will explain how to convert existing RMS reports into a version 10 report format.

1. Open the existing RMS report .xls file in Excel.

If IGSS version 8 is installed on the computer, the RMS version 8 will start as normal

If IGSS version 8 is not installed on the computer an error message will be displayed saying that
RMS.dll does not exist.

2. Click the Office button (donut), select Prepare and select Properties.

3. Under Document Properties, select Advanced Properties.

4. Click the Custom tab.

5. Remove the three properties:

l Solution ID

l _AssemblyName

l _AssemblyLocation

Not all properties will necessarily exist.

6. Save the file as an .xlsx file

7. At the Windows command prompt, navigate to the \gss folder and run the following command:

RMScmd.exe DB -REGISTER FILE=<file path + file name>

For example: RMScmd DB -REGISTER FILE=C:\myRMSfile.xlsx
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8. Open the Master module and create a new report. In Template name, use the same name as
the existing RMS report.

9. Click Check Out, to create a copy of the template in your working folder.

10. From Windows, overwrite the report in the working folder, with the converted RMS report.

11. Click Check In.

12. Click Edit, to open the report.

13. In the Document Actions window, select Options and click Select sheets to output.

14. Select the appropriate sheets, click OK and save the document.

You have now successfully converted the RMS report.
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Chapter 3: Converting from IGSS32 Version 2 or 3

3.1 How to convert version 2 or 3 to version 4

This topic describes the procedure necessary for converting version 2 or 3 configurations into version 4.

We strongly recommend that you follow the procedural steps in the exact order listed below.

The following procedure is divided into six main steps corresponding to the various IGSS programs you
must use to convert the version 2 or 3 configuration.

STEP 1: Convert the v2 configuration (c2to3.exe)

STEP 2: Convert the v3 configuration (c3to4.exe)

STEP 3: Make the converted configuration active (Setup)

STEP 4: Convert driver settings from v2 to v4 (Driver Setup)

STEP 5: Install the converted configuration (Definition)

STEP 6: Start the converted configuration ()

The last step is only necessary if the version 2 or 3 configuration was using theWinpager program.

STEP 7 (Winpager only): Convert settings to IGSS version 6.0 format (.xml file)

3.2 Step 1 - Convert the v2 configuration (c2to3.exe)

If you are converting from version 3, please skip this step and continue directly to "Step 2 - Convert the v3
configuration (c3to4.exe)" on page 14.

If you are converting from version 2, please continue with this procedure.

We recommend that you backup the v2 configuration before converting it to v4. If you're running Win-
dows NT, both IGSS 2.0 and IGSS 4.0 can be installed and run on the same machine.
If you're running Windows 2000 or XP, only IGSS 4.0 can be installed. In that case, you will have to
export the IGSS 2.0 configuration and driver settings.

1. Find the c2to3.exe program in the \gss sub-folder of the IGSS installation and double-click on
it to open the program window.

winpager.chm::/main_95_Step_1_Import_Settings_from_Older_Version.htm


- 12 -

IGSS V13, User Guide

2. Select File → Open and select the v2 configuration file (<MyConfig>.elm) you want to convert.

3. Click Open. The v2 configuration is now converted to the v3 format. A message appears inform-
ing you that the v2 driver configuration must be converted separately. This is described later in
this procedure. Click OK.

l The program window shows you a detailed status of the conversion. Notice that the three core
files of the v2 configuration are backed up: <MyConfig>.elm, <MyConfig>.dsc and <MyCon-
fig>.mdb.

The status information displayed below is saved in the file, c2to3.log, located in the current folder.

Towards the end of the conversion process, you are asked whether you want to reuse the alarm and log
files from v2.
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4. Click Yes to reuse your v2 alarm and log files. The Browse for Folder dialogue appears.
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5. Select the report folder where the v2 alarm and log files are located and click OK.
A message appears telling you how to integrate the above files when you install the converted
configuration in version 3.

6. Click OK. A message appears telling you that you need to convert your v2 driver settings.

7. Click OK and close the c2to3.exe program.

3.3 Step 2 - Convert the v3 configuration (c3to4.exe)

We recommend that you back up the v3.0 configuration before converting it to v4.0. Make sure that
all configuration files are writable (remove the Read Only attribute, if necessary), before you carry
out this procedure.

1. Open Windows Explorer and double-click the c3to4.exe program located in the \Gss subfolder
of the installation path. The program window appears.

2. Select File→ Open and select the v3.0 configuration file (<MyConfig>.elm) that you want to con-
vert.
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3. Click Open. The v3.0 configuration is now converted to the new v4.0 format.

l The program window shows you a detailed status of the conversion. Notice that the three core
files of the v3.0 configuration are backed up as <MyConfig>.el3, <MyConfig>.ds3 and
<MyConfig>.md3. If the conversion fails for some reason, you can roll back by renaming
these files back to their original names.

4. Towards the end of the conversion process, you are asked whether you want to reuse the alarm
and log files from v3.0.

5. Click Yes to reuse the v3.0 alarm and log files. A new message appears asking you whether you
want to convert your v3.0 report formats and maintenance jobs.

6. Click Yes to convert the report formats and maintenance jobs. The Browse for Folder dia-
logue appears.
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7. Select the report folder for the converted configuration and click OK

l The report formats functionality has been moved into the Definition program in v4.0. This
means that all information about report formats is now saved in the configuration database,
<MyConfig>.mdb.
The report format related databases from v3.0: <MyReportFormat>.mdb, Rformat.mdb and
Rstatus.mdb in the report folder are thus obsolete in v4.0.

8. A message appears asking you whether you want to preserve the old v3.0 .log and .alm files. Do
one of the following:

o Click Yes to preserve the files in the report folder. The v3.0 files will be renamed to .lo3 and
.al3.

o Click No to delete the v3.0 .log and .alm files from the report folder.

9. When the conversion process is completed, close the c3to4.exe program.

10. Click the Next button to continue with STEP 2 of the conversion procedure.

If you have used manual report objects in the configuratin, we recommend that you review the report
formats containing those objects. The conversion program imports all objects from the database con-
taining hourly, daily and monthly values, Genhdm.mdb. Objects that are not found in the
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configuration itself are marked as manual report objects. However, they may be objects that have
been removed from the configuration and thus have no relevance any longer in the reports.

The status information displayed below is saved in the file, c3to4.log, located in the current folder.

3.4 Step 3 - Make the converted configuration active (Setup)

1. Open the Setup program.

2. On the Folders tab, do the following:

l Under Configuration file, type the path to the converted configuration file, <MyConfig>.elm
or click Browse to find it.

l Under Report folder, type the path to the configuration’s report folder or click Browse to
find it.

l Under Symbol file, type the path to the configuration’s symbol file or click Browse to find it.

3. Click OK to close the program.

3.5 Step 4 - Convert driver settings from v2 to v4 (Driver Setup)

If you are converting from version 3, please skip this step and continue to "Step 5 - Install the converted
configuration (Definition)" on page 21.

If you are converting from version 2, please continue with this procedure.

In v2, driver settings were stored in the Windows Registry. Therefore, these settings must first be exported
from the Registry to a v4 file format. Then they are imported into a v4 driver profile whose settings are now
saved in the configuration’s database, <MyConfig>.mdb.

1. Open the v2 Driver Setup program and verify that the v2 driver profile associated with the con-
verted v2 configuration is set active.

This step is necessary, because the v4 Driver Setup program exports the active driver profile
from v2. If you need to copy the v2 driver profile to another PC, refer to the help file for v2
Driver Setup. Search for "managing driver profiles". The procedure is described towards the
end of the topic.

2. Open the v4 Driver Setup program.

At this point, there is no driver profile associated with the converted configuration. Therefore,
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this message appears.

3. Click OK. The Save Profile As dialogue appears.

4. Type the name of the new v4 driver profile. Typically, this will be the same name as you gave
the configuration. Click OK. By default, the new driver profile is set active.

The main window of Driver Setup appears. Make sure that the title bar shows the path and
name of the converted v2 configuration and the name of the driver profile you’ve just created. In
this example, Carlsberg is the name of the active driver profile.

5. Select Tools → Export IGSS V2 Driver Settings. The Save As dialogue appears.
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Driver Setup will now export the driver settings from the v2 driver profile you set active in
step 1.

6. Type a descriptive name for the export file and we recommend that you save it in the root folder
for the v4 configuration and click Save.

7. Select Tools → Import IGSS Driver Settings. The Open dialogue appears.

8. Choose the export file created in step 5 and click Open.

The following message appears. If you are importing the v2 settings into an empty v4 driver pro-
file, you can ignore this message.

But if you’re importing into a v4 driver profile with existing station names and drivers, please
read the message carefully.
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9. Click Yes to continue or click No to go back and make changes.

10. The Driver Import dialogue appears. Type the exact station name as you assigned to this sta-
tion in the Setup program (Station name field on the Type tab).

Station names are case sensitive.

11. Click OK to continue. The driver settings are now imported into the v4 driver profile.

12. Click on the station name defined in the previous step. Under Station type, make sure that the
correct station type is selected. For an IGSS server, select Server or single user.
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13. Review the imported driver settings. If satisfactory, select File →Save Profile and exit the pro-
gram.

3.6 Step 5 - Install the converted configuration (Definition)

Open the Definition program. The converted configuration will appear, because we chose it as the active
configuration in the Setup program.

1. Select File → Install Configuration. If there are unsaved changes, the following message
appears. Click Yes to save changes.

2. The Installation Options dialogue appears. Change the settings as required and click OK.
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3. If the installation is successful, a message similar to the one below appears.

4. If the installation is not successful, review the error report and make the required changes to the
configuration. Click the Help button in the Installation Options dialogue for further details.

5. When the installation is complete, close the Definition program.

3.7 Step 6 - Start the converted configuration

1. Open the IGSS Master.

2. Click the Start button in the Home Tab > Data Collection group.

3. Click theSupervise button to start the Supervise module.

4. Review the converted configuration.
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The conversion procedure is now complete.
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Chapter 4: Converting from IGSS16 Version 8

4.1 How to convert IGSS16 version 8.x to IGSS32 version 2

This topic describes how you convert IGSS16 v8.x configurations to the IGSS32 v2 format.

It is recommended to back up the version 8.x configuration before converting it.

1. Open a command prompt.

2. Change the current folder to the one holding the version 8.x configuration you want to convert.

3. Type <Installation Path>\Gss\c8to32 -d # <MyConfig>.elm
where:

l <Installation Path> is your installation path, the default is: C:\Igss32\

l <MyConfig>.elm is the name of the version 8.x configuration.

l # is the driver ID for the version 8.x configuration.

To find the driver ID of your version 8.x configuration, click here.

4. Press ENTER.

The version 8.x configuration is stored in the configuration root folder as <config. name>.el8
and <config. name>.dsr. The new configuration is stored in the configuration root folder as <con-
fig. name>.elm and <config. name>.dsc.

Activate and install the configuration

1. Open the Setupprogram to activate the converted configuration.

Do the following:

l In the Configuration file field, type the path to the converted configuration,
<MyConfig>.elm.

l In the Report folder field, type the path to the configuration's report folder. If you want to
imitate the IGSS default for new configurations, the report folder is a subfolder to the con-
figuration root folder and its name is <MyConfig>.R.

sysconfig.chm::/Drv_BCK_Drivers_currently_supported.htm
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2. Open the configuration in the Definition program.

3. In the File menu, select Install Configuration. The Installation Options dialogue appears.

4. Click OK. If the installation is successful, the message below appears. If errors exist in the con-
figuration, the <MyConfig>.err file appears specifying the exact errors in the configuration. In
the latter case, go back to the configuration and correct the errors.
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5. Click No to the message.

6. Open the IGSS Starter program. Dependent on your settings on the Data Collection tab in
the System Configurationprogram, do the following:

l Manual - Click Start IGSS and then click Supervise.

l Auto- Click the Supervise button.

l Supervise- The configuration is automatically launched in the Supervise program.

7. Review the converted configuration.

Once you have converted your version 8.x configuration, you can also convert the old base class
files (*.bcl), report format files (*.txt) and maintenance jobs (<config. name>.mnt).

4.2 How to convert version 8.x report format files

This topic describes how you convert IGSS 8.x report formats into the IGSS v2.0 format.

The configuration itself must be converted using the C8to32 program, before you can convert report
format files.

1. Make sure that the relevant report folder for the converted configuration is defined on the
Folders tab in the Setup program.

2. Open a command prompt.

3. Change the current folder to the one holding the report format files. This is typically the \R sub-
folder of the configuration root folder.

4. Type <InstallPath>\Gss\rep8to32<MyConfig>.elm<report format file>.txt<IGSSreport format> -dand press
ENTER.Example:<InstallPath>\Gss\rep8to32MyPlant.elmelm.txtMyReportFormat-d

Where:
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l <MyConfig> - is the full path to the converted configuration.

l <report format file> - is the full path and name of the version 8.x report format file, for example,
elm.txt.

l <IGSSreport format> - is the name of the resulting IGSS report format that you can later view and
edit in the Report Formats program.

l -d - is an optional parameter that sets this report format as the default format.

4.3 How to convert version 8.x base class files

This topic describes how you convert IGSS 8.x base class files (.bcl) into the IGSS v2.0 format.

The configuration itself must be converted using the c8to32.exe program, before you can convert
base class files.

1. Make sure that the relevant report folder for the converted configuration is defined on the
Folders tab in the Setup program.

2. Open a command prompt.

3. Change the current folder to the one holding the base class files you want to convert. This is typ-
ically the \R subfolder of the configuration root folder.

4. Type <InstallPath>\Gss\bcl8to32 *.bcl to convert all base class files and press ENTER.

The new *.bcl files are saved and the version 8.x files are saved as *.bc8.

To convert a single base class file, type bcl8to32<filename>.bcl.

4.4 How to convert version 8.x maintenance jobs

This topic describes how you convert IGSS8.x maintenance jobs into the IGSS v2.0 format.

The configuration itself must be converted using the C8to32 program, before you can convert main-
tenance jobs.

1. Make sure that the relevant report folder for the converted configuration is defined on the
Folders tab in the Setup program.

2. Open a command prompt.
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3. Change the current folder to the one holding the version 8.x maintenance jobs.

4. Type <InstallPath>\Gss\mnt8to32 <Myv4Config>.elm <Myv4Re-
portFolder>\ to convert the maintenance jobs to the IGSS format.

where:

l <Myv4Config>.elm is the full path and name of the IGSS configuration.

l <Myv4ReportFolder>\ is the full path to the report folder of the IGSS configuration.

If any errors occur during the conversion, diagnostic messages are written into the file, Mnt8to32.log,
located in the configuration folder.

The maintenance jobs included in the version 8.x file, <MyConfig>.mnt, are converted into entries in
the maintenance database, Mnt.db, which is located in the report folder.

To view the full syntax for the conversion program, type mnt8to32 without
any parameters.

The version 8.x maintenance notes are not converted, because they are
separate files placed in the report folder. To use these notes with the new
Maintenance module, simply open the relevant maintenance job, click
the Note tab, specify the filename of the note and click Refresh from File.
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Chapter 5: Converting from Older Versions

5.1 How to convert configurations older than version 8.x

The conversion programs

For your convenience, the required conversion programs are included on the installation CD. Normally you
convert configurations one version at a time with the exception of v 4.4.5 to v 6.5.0. The table below shows
you which programs to use for the individual conversions.

Convert your configuration

It is recommended to back up the old configuration before converting it.

1. Insert the installation disc in the CD drive.

2. Before running the conversion program, you must set the following environment variable: Set
Igsslng=D:\Convert\Gss\ (where D: is your CD-ROM drive)

3. Run the first required conversion. Click the program name for details. If there is no link, run the
conversion program without arguments for an explanation of the parameters.

Conversion Program

v 4.4.3 to v 4.4.5 D:\Convert\Gss\To445.exe

v 4.4.5 to v 6.5.0 D:\Convert\Gss\Fm4to6.bat

v 5.1.0 to v 6.5.0 D:\Convert\Gss\Fm5to6.bat

v 6.5.0 to v 7.x D:\Convert\Gss\Conv6to7.exe

v 7.x to v 8.x D:\Convert\Gss\Conv7to8.exe

4. Run any additional conversions required until the configuration is converted to v 8.x format.

5.2 How to convert from version 7 to 8

It is recommended to back up the old configuration before converting it.

1. Insert the installation disc in the CD drive.

2. Open Windows in DOS mode.

3. Type D:\Convert\Gss\conv7to8 <MyConfig> for example
D:\Convert\Gss\conv7to8 C:\v7to8\MyV8Config.elm

4. Load the new configuration.



- 30 -

IGSS V13, User Guide

5. Install the configuration.

6. Start and test the configuration.

5.3 How to convert from IGSS version 6 to 7

Version 7 was the first Windows version of IGSS , so before running the conversion program, the symbol file
must be converted from GEM to Windows.

It is recommended to back up the old configuration before converting it.

1. Insert the installation disc in the CD drive.

2. Open Symbol Editor (D:\Convert\Gss\Symedit.exe) where D: is your CD-ROM drive.

3. Choose File → Import GEM SYMEDIT table.

4. Choose the version 6 symbol file (typically *.v01 or *.v02).

5. Choose File → Table → Save As.

6. Save the symbol table as a *.v12 file (typically Symbols.v12).

7. Open a DOS prompt under Windows and run the Conv6to7.exe program.

8. Once completed, load the new symbols file, typically Symbols.v12 and load the new con-
figuration, <MyConfig>.elm.

9. Save the new configuration.

10. Open a DOS prompt and run the Convert.bat program with the following syntax:

convert <config dir> <report dir> <MyConfig> for example

convert C:\v6to7\MyConfig C:\v6to7\MyConfig\Report MyV7Config

l The program converts all text files from DOS to Windows format. The program also converts
maintenance jobs, IGAL scripts, Alarm Statistics files (*.ast), base class files (*.bcl), etc.

11. Save and install the configuration.

12. Start and test the configuration.

5.4 How to convert from version 4.4.5 to 6.5.0

Important notices

l Run the conversion in DOS mode. The DOS environment variables must be set. The default vari-
ables for v8 can be used without changes.
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l If there is an existing v6 configuration with the same name and no target area is defined, the v6 con-
figuration will be overwritten with the converted v4 configuration. Otherwise, it will be merged into
the v6 configuration.

Procedure

It is recommended to back up the old configuration before converting it.

1. Insert the installation disc in the CD drive.

2. Open Windows in DOS mode.

3. Run the conversion program located under D:\Convert\Gss\Fm4to6.bat (where D: is your CD-
ROM drive) using the syntax below.

4. Once the conversion is complete, load the configuration in version 6.

5. Save and install the configuration.

6. Start and test the configuration.

Syntax

fm4to6 symext symdir4 sym4 sym6 dir4 conf4 dir6 conf6 [area [almincr]]

symext The extension of the old symbol file (for example, V02)

symdir4 The location of the old symbol file (for example, C:\Gss)

sym4 The name of the old symbol file (for example, Symbols)

sym6 The name of the new symbol file (will be placed in the configuration root folder)

dir4 The location of the old configuration (for example, C:\MyV4Config)

conf4 The name of the old configuration (for example, MyV4Plant)

dir6 The location of the new v6 configuration (for example, C:\MyV6Config)

conf6 The name of the v6 configuration (for example, MyV6Plant)

area The name of the area where the old configuration is placed in the new configuration
(default: Global)

almincr All alarm numbers will be increased with 100 plus the increment specified here (default: 0).

Example
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fm4to6 v01 c:\v4\system\gss symbol symbols c:\v4\MyV4Config MyV4Plant
c:\v4\v6\MyV6Config MyV6Plant
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Chapter 6: Reference and Lookup

6.1 Getting Help in IGSS

IGSS comes with a comprehensive help system designed to help both system designers and operators to
get started with IGSS as quickly as possible.

Documentation overview

The IGSS documentation includes the following items:

Documentation item Description

Getting Started

An introduction to IGSS and its most fundamental terms and features.
Getting Started is intended to get you up and running as fast as pos-
sible. The manual provides a system and architecture overview fol-
lowed by a number of real-life use cases you can go through before
building your first real IGSS project. The manual is available in Adobe
Acrobat format (.pdf).

Module help

For each module there is a help file with the same name as the module
itself, for example, Def.chm for the Definition module.

The help file is invoked by clicking the in the upper right corner of
the module. The Table of Contents will then allow you to browse
through the topics.

Form and Dialog help̓

For each Form or dialog there is a help topic with the following stand-
ard information:

l Overview

l Preconditions

l Where do I find it?

l Field help

Form help is invoked by clicking the help button in the upper right
hand corner of the dialog box or located in the Table of Contents of the
individual help file.

Thematic help

IGSS also provides thematic help. When there is a special theme that
requires special attention from the user, a dedicated help file is
provided. Examples include "Driver-Specific Help" and "Database
Administration Help".

Where are the help files located?

The IGSS help files are located in the appropriate language folder in the installation path of IGSS, by
default C:\Program Files\Schneider Electric\IGSS32\V13.0. The help files are available in English at
release time.

The paths to the help files are:
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Language Path

English [IGSS InstallPath]\ENG

Danish [IGSS InstallPath]\DAN

German [IGSS InstallPath]\DEU

Translated help files

Selected help files have been translated into Danish. If you require help files in your language, please con-
tact Schneider Electric.

Help updates

The help files are continuously updated and improved. Check regularly with the IGSS Update in the IGSS
Master.

6.2 Conventions in this Manual

The following typographical conventions are used:

Convention Description Example

User inter-
face ele-
ment

When referring to labels and names
in the user interface. The Data Management tab.

User input When the user has to type specific
data in IGSS

Type the following description:

Incoming flow in Tank 2

Module
name When referring to a module in IGSS Open the Definitionmodule.

Note

A note emphasizes or supplements
important points of the main text. A
note provides information that may
apply only in special cases.

By default, the timestamp is in universal
time format, UTC1. This can be changed in
the Driver Log Filters dialog box.

Tip

A tip suggests alternative methods
that may not be obvious in the user
interface. A tip also helps the user in
working more effectively with IGSS.
A tip is not essential to the basic
understanding of the text.

Alternative to this simple
find function, you can also fil-
ter on text in the messages
in Driver Log Filters dialog
box.

Warning
A warning is an important note that is
essential for the completion of a If you disregard the System

1Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating time in
most parts of the world. IGSS uses this time format internally in the database. You can switch between UTC
and local time by enabling or disabling the "UTC" field in various dialog boxes in the system.
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Convention Description Example

task. In some cases, disregarding a
warning may result in undesirable
functionality or loss of data.

alarm, you may risk loss of
data in the LOG and BCL
files.

6.3 Version Information (IGSS Help System)

© Schneider Electric, IGSS Version 13.0

The IGSS help files are based on software build number 10305 (initial release)

English help files

To update the help files, click the Update IGSS Software button on the Information and Support tab
in the IGSS Master. There must be a connection from the PC to the Internet. Every time IGSS Update is
run, IGSS help files as well as IGSS system files will automatically be updated on the PC from the web
server at Schneider Electric.

You select the languages you want to update in the Tools menu of the IGSS Update form.

If you are not able to update the IGSS system directly via the Internet, the alternative is to download the
updates from the Schneider Electric website as zip files. These can then be transferred onto a CD or USB
memory stick, which is then the medium used to update on site.

After updating your IGSS installation , the build numbers in various IGSS modules may change to a
higher number. This signifies that the module in question has been updated with newer files. Build
numbers consist of four digits, where the first digit represents the year and the last three represent
the day number in the year in question. The build number can be seen in the About dialog box which
can be activated from the Helpmenu.

An example:

Build number = 10305
18 = the year 2018
305 = The 305th day of the year
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Chapter 7: Glossary

A
Application menu

The Application menu is the first ribbon in the IGSS Master module. Click the icon to drop down
the menu. The menu contains items that were typically found in the File menu in previous ver-
sions of IGSS. In most modules, an "Options" item allows the user to define global module set-
tings. The Application menu was introduced in the Microsoft Office 2010 package. It replaces the
Application button (nicknamed Doughnut) which was introduced in IGSS V7 and V8.

D
descriptor

A descriptor is the graphical display of an object. IGSS includes many types of descriptors includ-
ing: - Built-in standard symbols - Animated symbols (Symbol Factory library) - Graphics and
animation - Drawing symbols - Windows controls - ActiveX controls An IGSS object can be rep-
resented with different descriptors on different diagrams.

R
Ribbon

The Ribbon is a new term/element in the Microsoft universe. The Ribbon replaces the well-known
toolbars in applications. The Ribbon provides quick access to the most commonly used functions
in the application. The Ribbon is divided into logical groups (the tabs) and each tab is divided into
sections (the blocks in the tab). The Ribbon is context-sensitive which means that only relevant
functions are accessible dependent on the current user action.

S
SCADA

Supervisory Control & Data Acquisition

U
UTC

Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating
time in most parts of the world. IGSS uses this time format internally in the database. You can
switch between UTC and local time by enabling or disabling the "UTC" field in various dialog boxes
in the system.
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