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Chapter 1: Installing a Configuration

1.1 Overview: Installing configurations

Introduction

When you install a configuration, its validity and logical completeness is checked. What takes place
outside IGSS and the relationships to the PLC remain the user’s responsibility. A configuration must
be error-free and approved, before it can be put into operation. The installation module automatically
checks the whole configuration and reports on the installation result.

Many basic control functions are incorporated in the Definitionmodule, such as preventing duplic-
ate object names, unnamed objects, references to non-existent objects, etc.

Before you begin

Even though the installation module reports any errors encountered during the installation, it is
recommended to go through the following checklist before installing.

l It is recommended to install the configuration regularly to check your definitions and correct
possible errors. This is not achieved when you use the Save function.

l Is the configuration complete?

l Have you specified an external type for analog, table, digital, counter and string objects?

l Have you supplied PLC addresses for all object atoms (I/O points) which are not defined as
local?

l Have you defined and linked an alarm text to each alarm atom, for example, High Alarm
and Low Alarm for an analog object?

What does the Chelm installation module control?

The Chelm installation module primarily checks the connection to the physical process, internal defi-
ciencies in the configuration and consistency between alarm atoms and alarm texts.

The installation module checks the following.

l Are all PLC addresses specified for object atoms defined as in, out and in/out?

l Are all alarm atoms linked to an alarm text?

The result of the installation is reported on-screen as soon as the installation is complete.

Typical installation errors

The most typical installation errors are:

l Missing external type for analog, table, digital, counter and string objects

l Missing PLC addresses for object atoms defined as in, out and in/out

l No alarm text linked to an alarm atom

Installing the configuration

Installing a configuration is very simple. Do one of the following:

l If the configuration is running, select File → Online Update

l If the configuration is not running, select File → Install Configuration.
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In both cases, the Installation Options dialog box appears.

l If the installation is successful, a message prompt appears informing you of how many
objects the installed configuration holds. From the message prompt, you can access the con-
figuration installation report (MyConfig.prt).

l If there are any errors in the configuration, the Troubleshooter form appears assisting you
in correcting the errors. By using the information supplied in this file, you can easily correct
any errors and then repeat the installation.

Installation backup files

The latest valid configuration is always backed up in the configuration backup folder, \7TBackup. If
you are not able to install your configuration, you can always go back to the latest valid version.

1.2 To install a configuration

When you’ve made changes to a configuration, you must install the changes before the operator can
use the modified configuration. There are two methods available.

If the configuration is running

1. Select File → Online Update.

2. Click Yes to save the changes. The
Installation Options dialog box appears.

3. Change the options, if necessary and click OK.

l If the installation is successful, a message prompt appears informing you how many objects
the installed configuration holds. From the message prompt, you can access the installation
report (MyConfig.prt) by pressing Yes.

l If there are any errors in the configuration, the Troubleshooter form appears assisting you
in correcting the errors.

4. In most cases, you will not want to see the installation report. Press No to allow IGSS to
complete the installation of the configuration and restart the configuration.

If the configuration is not running

1. Select File → Install Configuration.

2. If you have unsaved changes, you are prompted to save them. Otherwise, the Check and
Install Module (Chelm) module is automatically launched and the Installation Options
dialog box appears.

3. Change the options as required and click OK.

l If the installation is successful, a message prompt appears informing you how many
objects the installed configuration holds. From the message prompt, you can access the
installation report (<MyConfig>.prt) by pressing Yes.



l If there are any errors in the configuration, the Troubleshooter form appears assisting
you in correcting the errors.

4. In most cases, you will not want to see the installation report. Press No to allow IGSS to
complete the installation of the configuration.

For details about the properties in the Installation Options dialog box,
click the ?, then click the relevant item in the dialog box.

Once you have set up the appropriate options, you can check Skip
This dialog box to bypass it when you install your configuration.

1.3 About Pre and Post Check Scripts

You can run a script prior to or after the configuration is checked and deployed (installed) by spe-
cifying a path to a script or file to be executed. Any script file capable of being executed can be run;
for example batch files or executable files (BAT, CMD, PS1, EXE etc) and you can also specify doc-
ument files or other files which can be opened and run by the operating system such as .pdf, .txt or
.docx files.

You can only specify one script per event - one script file to be run prior to a check-and-install and
one script file to be run after a check-and-deploy.

The Pre and Post check scripts can be used to copy, move or back-up configuration files, open pro-
grams and applications and other automated procedures in conjunction with a check-and-deploy.

Check-and-Deploy procedure paused

The Pre- and Posts Check scripts will be opened and executed but not closed unless specified in the
script itself.

The check-and-deploy procedure will be paused while the Pre- and Posts Check scripts are open.
Once the process started by the Pre- and Posts Check scripts has been closed, the procedure will con-
tinue.

Location

The Pre check script and Post succeeded check script fields on the Application tab on the
System Configuration form are used to specify the path and script file to be run prior to and /or
after a check-and-deploy procedure.

The specified scripts or files are specific to the station as the Application tab on the System Con-
figuration form is available for all station types. For example, you can specify one script to run
when checking and installing from an IGSS server and another script to run when checking and
installing from an Operator station.



Check Script Variables

You can retrieve and insert information about the check-and-Deploy procedure by using four vari-
ables:

l $MODE

l $CURCONFIG

l $CONFIGNAME

l $INSTCONFIG

You can insert the variables into the path or script/file name and thereby select which script or file is
to be executed depending on the values of the variables.

Variable Descriptions

$MODE

Can contain the values Online or Offline.

If the Check-and-Deploy procedure is performed on a running configuration, the value Online will be
stored in the $MODE variable. If the Check-and-Deploy procedure is performed on a configuration
that is not running, the value Offline will be stored.

The Mode information may be important because there is a difference in what files are involved in the
installation.

l For offline deployment, configuration files in the configuration folder are directly updated.

l For online deployment, a temporary copy of the files edited in the Definitionmodule is cre-
ated in the DefWork folder, and the installation process is run on these files. When the
installation process has completed the temporary files will be copied into the configuration
folder during the final phases of deployment.

$CURCONFIG

Contains the path to your configuration folder.

$CONFIGNAME

Contains the name of your configuration.

$INSTCONFIG

Can contain the path to your configuration folder or the path to the DefWork folder.

l If you are performing an offline deployment, the variable will contain the path to your con-
figuration.

l If you are performing an online deployment, the variable will contain the path to the
DefWork folder.

Examples

Example 1

Post succeeded check script: C:\windows\notepad.exe $CURCONFIG\$CONFIGNAME.prt

This post Check-and-Deploy script opens the Windows notepad application and displays the install-
ation report generated after the installation.



Example 2

Pre check script: C:\$MODE\runme.bat

This pre Check-and-Deploy script opens a command prompt and executes the runme.bat script which
includes a close command so the check-and-install procedure can continue without having to close
the command prompt.

There are two runme .bat script files:

l C:\Offline\Runme.bat

l C:\Online\Runme.bat

If the configuration is checked and deployed while the configuration is shut down, the Runme.bat
batch file in the Offline folder will be executed as the $Mode variable will contain the text: Offline.

If the configuration is checked and deployed while the configuration is running (an Online Update),
the Runme.bat batch file in the Online folder will be executed as the $Mode variable will contain the
text: Online.



Chapter 2: Installation Report

2.1 Installation report, MyConfig.prt

The configuration installation report, <MyConfig>.prt, contains the information you enabled in the
Installation Options dialog box.

You may need to adjust the page setup in WordPad to fit the report con-
tents into a normal page.

The following sections can be included in the report:

This section … shows the following … Example

Report header l The user-defined headline
for reports defined in Sys-
tem Configuration

l the name of the con-
figuration file

l the number of objects in the
configuration and

l text bytes used

Click here for an
example.

Objects sorted by
name

An alphabetical list of objects
divided into the areas of the con-
figuration. The object type and
description are always shown. If
you want to view all details for each
object, check Detailed object
information in the Installation
Options dialog box.

Click here for an
example.

Objects sorted by
type

All objects divided into the relevant
object type groups (analog, digital,
etc.). There is one list for each area
in the configuration.

Click here for an
example.

Objects sorted by
PLC address

All PLC addresses sorted by data
group. Each line shows the precise
address, its length, object name
and atom, scan interval and
external type.

If a PLC address is used more
than once, Overlap is noted
next to it. This will not result
in an error when you install,
because you may want duplic-
ate addresses by design.

Click here for an
example.

Objects sorted by
alarms

A section for each alarm number
showing the alarm text and the
objects that use it.

Click here for an
example.



This section … shows the following … Example

Base classes List of objects divided into the rel-
evant base classes (defined by the
Base interval on the Data Man-
agement tab) and data reduction
methods (Minimum, Maximum,
etc.).

Click here for an
example.

Scan classes The driver ID, node number, PLC
address and length for each object
defined in the respective scan
classes (defined by the Scan inter-
val on the Data Management
tab).

The Manual section contains
objects for which None was
selected as scan interval.

Click here for an
example.

Communication
efficiency inform-
ation

Click here for details.

Resource usage
(last section)

The usage of objects, scan records,
data groups, atoms, alarm texts
and data reduction methods.

The final lines tell you that the con-
figuration is properly installed.

Click here for an
example.

Station and driver
setup

This section of the report shows the
settings defined for all stations and
drivers.

Click here for an
example
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Chapter 3: Installation Errors

3.1 Installation log file and the Troubleshooter

The error log file, MyConfig.err, contains information about errors in the configuration.

If there are errors when you install a configuration, the Troubleshooter form will appear.

In this case, the user has forgotten to attach an alarm text to an alarm atom which has been
enabled on the object t1.

To correct the error

1. Double-click the line in the Troubleshooter window. A dialog box appears providing fur-
ther details about the error.

2. Click the Locate Error in Definition button. You will be taken to the affected object's
dialog box where you can correct the error.

3. Correct the error in the object properties dialog box. In this case, you simply need to
attach an alarm text to the High Limit atom. Notice that the Alarm Details drop-down
list is empty - this caused the error.



4. Correct all errors and repeat the installation until all errors are eliminated.

IGSS will not allow you to start the modified configuration in Supervise, until all errors have
been corrected.



Chapter 4: Dialog Box Help

4.1 Installation Options

What it shows

This dialog box appears when you install a configuration in the Definitionmodule. It allows you to
determine what you want to show in the installation report, MyConfig.prt and a few other options.

For details about a property in the dialog box, click , then click the
item.

If you check Skip This dialog box, the installation will bypass the dialog box. To show it again,
hold down SHIFT while you select Install Configuration.

How it looks

The figure below shows the Installation Options dialog box.

Correcting installation errors

Errors will be displayed in the Troubleshooter module.



Chapter 5: Reference and Lookup

5.1 Conventions in this Manual

The following typographical conventions are used:

Convention Description Example

User inter-
face ele-
ment

When referring to labels and names
in the user interface. The Data Management tab.

User input When the user has to type specific
data in IGSS

Type the following description:

Incoming flow in Tank 2

Module
name When referring to a module in IGSS Open the Definitionmodule.

Note

A note emphasizes or supplements
important points of the main text. A
note provides information that may
apply only in special cases.

By default, the timestamp is in uni-
versal time format, UTC1. This can
be changed in the Driver Log Filters
dialog box.

Tip

A tip suggests alternative methods
that may not be obvious in the user
interface. A tip also helps the user in
working more effectively with IGSS.
A tip is not essential to the basic
understanding of the text.

Alternative to this
simple find function,
you can also filter on
text in the messages in
Driver Log Filters dialog
box.

Warning

A warning is an important note that is
essential for the completion of a
task. In some cases, disregarding a
warning may result in undesirable
functionality or loss of data.

If you disregard the Sys-
tem alarm, you may
risk loss of data in the
LOG and BCL files.

5.2 Getting Help in IGSS

IGSS comes with a comprehensive help system designed to help both system designers and oper-
ators to get started with IGSS as quickly as possible.

Documentation overview

The IGSS documentation includes the following items:

1Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating time
in most parts of the world. IGSS uses this time format internally in the database. You can switch
between UTC and local time by enabling or disabling the "UTC" field in various dialog boxes in the
system.



Documentation item Description

Getting Started

An introduction to IGSS and its most fundamental terms and fea-
tures. Getting Started is intended to get you up and running as fast
as possible. The manual provides a system and architecture over-
view followed by a number of real-life use cases you can go
through before building your first real IGSS project. The manual is
available in Adobe Acrobat format (.pdf).

Module help

For each module there is a help file with the same name as the
module itself, for example, Def.chm for the Definition module.

The help file is invoked by clicking the in the upper right corner
of the module. The Table of Contents will then allow you to browse
through the topics.

Form and Dialog help̓

For each Form or dialog there is a help topic with the following
standard information:

l Overview

l Preconditions

l Where do I find it?

l Field help

Form help is invoked by clicking the help button in the upper
right hand corner of the dialog box or located in the Table of Con-
tents of the individual help file.

Thematic help

IGSS also provides thematic help. When there is a special theme
that requires special attention from the user, a dedicated help file
is provided. Examples include "Driver-Specific Help" and "Data-
base Administration Help".

Where are the help files located?

The IGSS help files are located in the appropriate language folder in the installation path of IGSS, by
default C:\Program Files\Schneider Electric\IGSS32\V13.0. The help files are available in English at
release time.

The paths to the help files are:

Language Path

English [IGSS InstallPath]\ENG

Danish [IGSS InstallPath]\DAN

German [IGSS InstallPath]\DEU

Translated help files

Selected help files have been translated into Danish. If you require help files in your language,
please contact Schneider Electric.

Help updates



The help files are continuously updated and improved. Check regularly with the IGSS Update in the
IGSS Master.

5.3 Version Information (IGSS Help System)

© Schneider Electric, IGSS Version 13.0

The IGSS help files are based on software build number 10305 (initial release)

English help files

To update the help files, click the Update IGSS Software button on the Information and Sup-
port tab in the IGSS Master. There must be a connection from the PC to the Internet. Every time
IGSS Update is run, IGSS help files as well as IGSS system files will automatically be updated on
the PC from the web server at Schneider Electric.

You select the languages you want to update in the Tools menu of the IGSS Update form.

If you are not able to update the IGSS system directly via the Internet, the alternative is to download
the updates from the Schneider Electric website as zip files. These can then be transferred onto a CD
or USB memory stick, which is then the medium used to update on site.

After updating your IGSS installation , the build numbers in various IGSS modules may change
to a higher number. This signifies that the module in question has been updated with newer
files. Build numbers consist of four digits, where the first digit represents the year and the last
three represent the day number in the year in question. The build number can be seen in the
About dialog box which can be activated from the Helpmenu.

An example:

Build number = 10305
18 = the year 2018
305 = The 305th day of the year



Chapter 6: Glossary

A
Application menu

The Application menu is the first ribbon in the IGSS Master module. Click the icon to drop
down the menu. The menu contains items that were typically found in the File menu in pre-
vious versions of IGSS. In most modules, an "Options" item allows the user to define global
module settings. The Application menu was introduced in the Microsoft Office 2010 pack-
age. It replaces the Application button (nicknamed Doughnut) which was introduced in IGSS
V7 and V8.

D
descriptor

A descriptor is the graphical display of an object. IGSS includes many types of descriptors
including: - Built-in standard symbols - Animated symbols (Symbol Factory library) - Graph-
ics and animation - Drawing symbols - Windows controls - ActiveX controls An IGSS object
can be represented with different descriptors on different diagrams.

R
Ribbon

The Ribbon is a new term/element in the Microsoft universe. The Ribbon replaces the well-
known toolbars in applications. The Ribbon provides quick access to the most commonly
used functions in the application. The Ribbon is divided into logical groups (the tabs) and
each tab is divided into sections (the blocks in the tab). The Ribbon is context-sensitive
which means that only relevant functions are accessible dependent on the current user
action.

S
SCADA

Supervisory Control & Data Acquisition

U
UTC

Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for cal-
culating time in most parts of the world. IGSS uses this time format internally in the data-
base. You can switch between UTC and local time by enabling or disabling the "UTC" field in
various dialog boxes in the system.
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