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Chapter 1: Welcome to IGSS Supervise
1.1 What is IGSS Supervise?
The Supervise module is an integral part of IGSS (Interactive Graphical SCADA1 System). The
Superviseprogram is a tool for online process monitoring and operator control based on the user
interaction using mouse and keyboard.
A set of pictures - called process diagrams - present the plant or process graphically on your PC
screen. Each diagram consists of a static background picture and dynamic symbols representing the plant’s working components (motors, valves, flow meters, temperature scales,
etc.). States and values of these process objects, also called process components, are updated
automatically each time they change. Click-sensitive areas give you operator access to the
process diagram; they bring up another diagram or open a command box, for example.

Diagrams and Areas
The first thing for you to know is that the IGSS screen representation of your plant or process
is subdivided into Areas and Diagrams.
Typically, a process diagram may be opened from the Diagram menu. The pictures that you
see in the Diagram menu all belong to the same part of the process, the same area. If you
select another area from the Area menu, you will see other pictures for selection in the Diagram menu.
Related Topics

"Login and access rights" on page 14
"Menus" on page 5
"Operator control using the keyboard only" on page 8
"The IGSS Supervisescreen" on page 4

Graphs
Graphs opened from the Graph menu allow you to have process values presented in curve
charts so that you can evaluate their variation with respect to time. There are two graph
types: Standard Graphs (graphs that are predefined by the system designer) and Operator
graphs (graphs you can define yourself on-the-fly during online process monitoring. )

1 Supervisory Control & Data Acquisition

Related Topics

"Graph Properties Form" on page 43
The graph window
"Adjust the Y-Axis for each signal" on page 72
"Add or remove a signal" on page 73
"Change the graph appearance" on page 70
"Change signal appearance" on page 69
"Compare two graph periods" on page 81
"Display graph points and show graph values" on page 66
"Create an Operator Graph" on page 75
"Set up graph properties" on page 78

Controlling Process Objects
The Supervise program allows you to directly intervene in the plant and process operation
provided you have the right access authority assigned to your user name and password.
Clicking on a dynamic object in a process diagram displays the principal characteristics of the
component in the status bar at the bottom of the process diagram window. At the same time a
popup menu appears. It gives you direct access to the Properties menu of the object and
also displays the object commands which you can trigger with a simple mouse click; commands such as opening or closing a valve, adjusting a limit or setpoint value.
Related Topics

"Control data collection" on page 11
"Find out the purpose of a process object" on page 25
"Give a command on a process object" on page 26
"Open a process diagram" on page 25
"What happens when you click on a process object" on page 25

Handling process alarms
When a component in the process is in some way faulty, if for instance a valve is open when it
should be closed or some level in a tank is too high, an alarm may be triggered. In this case,
the symbol representing the faulty component will typically flash in red. Simultaneously, all
details about the alarm situation are registered in the alarm list. You gain access to this list by
clicking the Active Alarms button in the task bar at the bottom of the screen, or by doubleclicking on the alarm icon.
In the alarm list, instructions on how to handle the alarm may be attached and you yourself
may describe how you resolved the problem in a note that is automatically attached to the
alarm.
The alarm can be acknowledged the moment it arises but remains in the list of alarms until the
error situation in the process is resolved. After that, the alarm is automatically transferred to
the alarm log.
Throughout online process monitoring, and even when you turn to other programs on your PC,
the alarm icon will remain visible, always informing you about the current alarm situation.
Double-clicking on the alarm icon takes you directly into the alarm list and the Alarm module
for further alarm handling.
Related Topics

"Acknowledge alarms" on page 32
Acknowledge in the EDIT menu
"Recognise alarms" on page 31
"View the alarm text" on page 32

Printing process information
All process information can be printed out, be it a screen dump of a complete process diagram, the contents of the alarm list or log, a graph or the values of process objects.
Related Topics

"Direct message printing" on page 135
"Print a complete graph window" on page 134
"Print a report" on page 135
"Print out a process diagram" on page 133

"Print the alarm list/alarm log" on page 135
"Print the current values of a process diagram" on page 133
"What can you print?" on page 133

Plant Reports
The system has built-in facilities for generating operational reports and automatically keeps
track of when the last report was created and printed. These report facilities are defined by the
system designer and are usually made available to the plant operator in the form of User Programs.
Reports may be displayed in several formats. In most cases, the standard IGSS reports will fulfil your documentation requirements. Special requirements can be taken into account by customised reports which again are called up by the operator under the menu function User
Programs.

1.2 Technical support
In case you need technical support, please contact your local system integrator.
The system integrator knows a lot about the IGSS system and will help you find the optimal
solution to the needs of your plant.
In turn, the system integrator has direct access to technical support from Schneider Electric.

1.3 The User Interface
The IGSS Supervisescreen
Your IGSS Supervise screen typically looks like this.

Click the item descriptions to get more detailed explanations:

Menus
The following menus are available in the Supervise module.

Menu

Description

In the File menu you can:
l

l

File

Log in and out if you are using the IGSS User Administration module
as well as change you r password.
Start and stop ordinary Data Logging, Data Collection and Extended
Logging as well as initiating scans, restarting stations, delete spool file
and restart as a single user backup.

l

Save any changes made to object properties.

l

Save an active graph as an Operator graph.

l

Print, view a print preview as well as set up the print properties.

Menu

Description
l

Save the present values of selected objects in a list file.

l

Exit and close the Supervise module.

In the Edit menu you can:
l

Open the Object Properties form for the selected object.

l

Open the Object Browser form to find objects in the configuration.

l

Select all objects in the diagram.

l

Edit
l
l

l

l

Open the Object Historian form to view historical data either for the
selected objects or for an object added after the Object Historian
form is opened.
Acknowledge alarms for the selected object if the object is in alarm.
View alarm information and instructions for the selected object if the
object is in alarm.
Display the Maintenance form for the selected object if the Maintenance form is already open.
Open the Select Job type and Indicator object form to create a
new maintenance job for the selected object if the Maintenance form
is open.

In the View menu you can:

View

l

Display customized toolbars (if any)

l

Display the navigation toolbar in the top of the screen

l

Display the status toolbar in the bottom of the screen

l

Toggle between displaying the time from local to UTC1 time

l

Display milliseconds in the time display

l

Display object properties menus when selecting the object with the
mouse

l

Open the Object Watch Window

l

Open the Audit Trail data for the selected object

l

Display any unit sets defined for the configuration

l

Save and Restore Views containing diagrams and Graphs

1 Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating

time in most parts of the world. IGSS uses this time format internally in the database. You can
switch between UTC and local time by enabling or disabling the "UTC" field in various dialog
boxes in the system.

Menu

Description
l

Display object edges and any defined tooltips for objects

l

Display the Pan Control window

l

Select an elements in the Most Recently Used (MRU) list

Open or run a user program in the list.
User Programs

If no user programs have been defined for the configuration, this option will
be inaccessible.

Area

Open an area in the configuration.

Diagram

Open a process diagram in the configuration.
In the Graph menu you can:

Graph

l

Create a new Operator graph

l

Open an existing graph

l

Open a Standard graphs made accessible in the Graph menu.

In the Tools menu you can:

Tools

l

Create, edit and delete Operator Reports

l

Create, edit and delete Events

l

Edit Alarm properties

l

Open the Playback form and define a playback sequence to display
historical data in the Supervise module.

l

Send a message to all online IGSS stations

l

Run a predefined macro as well as access the built-in VBA Editor

In the Server menu you can:
Server

l

Connect to another IGSS server in the server list

l

Add new IGSS servers to the server list

Select which layer views are to be enabled from the Views list.

Views

Layers and Views are created and maintained in the Definition module by a
System Designer and made available in the Supervise module.
If there are no defined layers and views, the Views menu will be inaccessible.

Window

In the Window menu you can:

Menu

Description
l
l

Close the active (current) diagram
View a list of currently open diagrams and graphs and select one to
bring to the front.

In the Help menu, you can:
Help

l
l

Open the online help for the Supervise module
Open the About IGSS form where you can find information about
your IGSS installation.

See Also

File menu
Edit menu
View menu
User Programs menu
Area menu
Diagram menu
Graph menu
Tools menu
Server menu
Window menu
Help menu

Operator control using the keyboard only
The plant components may be controlled and operated from your PC operator station, using
mouse or keyboard or a combination of both.

If you only use a keyboard for online operator control, follow the general Windows conventions
for keyboard operations. Some of them are explained below, for more detailed information
please consult the Windows User manual or Windows online help facility.

How to …

Procedure…

Pull down a menu

Press the ALT key and the underlined letter in the menu name.

Close a menu

Press F10 or the ALT key.

Give a command

In the open menu or dialogue, enter the underlined letter in the command name
or
use the arrow keys to select the command and confirm with ENTER.

Select an option

Within a dialogue, use the TAB key or the arrow keys to go from one option to
the next. Always confirm your selection with ENTER.

Close an application

With ALT+F4 you close the currently active application.

Tip: Your process control system may be provided with special function and control keys.
These features depend on the definitions made by your system designer. He/she may have
included global function keys that apply to the entire control system, and function keys that are
tied up with a specific process diagram.

Chapter 2: Starting and Stopping the Configuration
2.1 Connect to the IGSS Server
Connecting for the first time
Once the configuration is running on the IGSS Server, the operator station can connect to the
server and download the configuration.
Click the Start button on the IGSS Master > Home tab to start the IGSS configuration.

Result: The Operator Connect Options dialogue appears.

Show picture

3. Make sure that the name of the server is correct and click the Continue button.

Result: A message will appear prompting the operator to download the configuration from the
server.

Show picture

4. Click Yes. The configuration files are downloaded.
5. To start the configuration, click here.

Tip
l

If the operator station will always connect to this server, you can select the Don't show this dialog again
check box.

l

If the operator station will connect to multiple servers, click here.

2.2 Start and stop the configuration
Once the operator station is connected to the IGSS Server, the configuration can be started and
stopped as follows.

Typically controlled by the IGSS Server
Once an IGSS configuration has been commissioned, changes will typically be implemented on
the IGSS Server. These changes will be automatically downloaded to the connected operator

stations. On the individual operator station, IGSS can be set up to display a message when the
configuration on the server is updated. Otherwise, the changes are automatically downloaded.

Start the configuration
IGSS can be set up to start a configuration in three different modes:
l

Manual (the operator must click Start to start data collection and subsequently Supervise to view the process)

l

Auto (data collection starts automatically, but the operator must click Supervise to view the process)

l

Supervise (data collection starts and the operator is taken straight into the Supervise module)

If you need to start the configuration manually, open the File menu and select Start Configuration.
This is the same as clicking the Start button in the IGSS Master.

Stop the configuration
If you need to stop the configuration manually, open the File menu and select Stop Configuration.
This is the same as clicking the Stop button in the IGSS Master.

Only for authorized users
Starting and stopping the configuration are seen as system commands. If access control is
enabled, the current user must have the appropriate rights to start or stop the configuration.

2.3 Control data collection
You can control the acquisition of up-to-date process data, always assuming of course that you
have the appropriate access rights for these actions.

1. In the menu bar, go File → Status and Control….
2. The Data Collection Control dialogue opens showing you the current status of data collection and logging.
3. The following methods of influencing data collection are available:
Data collection
Data logging
Extended log
One manual scan

4. Select Start or Stop or Yes or No.
5. Confirm with

for the changes to take effect.

l

All data collection modes are password protected. You will have to enter the authorized password before you
can make any changes in the Data Collection Control dialogue.

l

For direct guidance on each individual item, option or entry of a particular dialogue, use the What’s This?
Help facility: while you are in the dialogue, click the
the item you want information about.

in the upper right corner of the dialogue, then click

2.4 Switch to another IGSS Server
In some cases, an operator must have access to multiple IGSSconfigurations residing on different IGSS Servers.

Switch to another server

1. In the Server menu, select the name of the server you want to switch to.

Result: The operator station disconnects from the current server and connects to the new
server. The configuration from the new server is downloaded to the operator station.

Edit the list of IGSS Servers
When an operator station connects to an IGSSServer, the operator chooses the appropriate
server in the Operator Connect Options dialogue. The drop-down list will contain the names
of servers typed in directly here or edited in the Edit Server List dialogue.

1. In the Server menu, select Edit Server List.

Show picture

2. Do one of the following:

l

To add a new server, place the cursor in the input field. Type the IP address of the new
server and click Add.

l

To rename a server, select the name. Type the new name and click Rename.

l

To delete a server, select the name and click Delete.

3. Click OK to save the changes.

Result: When you open the Server menu, the updated list is shown at the bottom.

Chapter 3: Logging In and Out of the System
3.1 Login and access rights
All plant components displayed in process diagrams may be individually protected. The system
designer may decide for each individual object whether or not a particular operator with a particular user name and password has the right to give a command or change a value for a particular plant component.
When you log into the Supervise program for online operator access and process control, you
are automatically given the access rights defined by the system designer for your user name
and password. Provided you have the authority, you may change your password in the File →
Change password… menu.

3.2 View user login/logout in Object Historian
You can view user login/logout information in the Object Historian without choosing any
objects for inspection. But the typical scenario would be to combine the event types, allowing
you to view which user was logged in when a certain event occurred.

1. Under Time interval, define the relevant start and end time. IGSS goes back one hour by default.
2. Under Event types, select the User login/logout check box.
3. Click Query data to view the data in the list.
4. For details on the individual columns in the list, click the

button, then click inside the list.

Show picture

To be able to view user login/logout, user administration must be enabled in the System
Configuration form and users must have been defined in the User Administration form.

3.3 Registration of user name
When user administration is enabled, the user name is registered in the following places.

Title bar of Supervise
The name of the active user can be shown in the title bar of Supervise as [xxx]. At a glance,
the operator can see whether he's logged in with the right user name or if he's logged in at all.
This option must be enabled in the System Configuration program.

The Object Historian
The user name is registered in the Object Historian as follows:
l

Outgoing commands under LOG data
(commands to digital objects, change of setpoint, change of alarm limits, etc.)

l

Acknowledgment of alarms under ALM data

l

Login and logout information under User login/out

The Alarm List
When a user acknowledges an alarm, it is registered in the User field in the Alarm List.

The Event List
When a user logs in and out of the system, it can be registered in the Event List.
In the Tools menu of Supervise, choose Events and add the User login/logout event.

Chapter 4: Navigating the Configuration
4.1 Areas, diagrams and graphs
Areas
An IGSS configuration can be divided into a number of areas. The area is typically a logical section of the monitored process, for example, a sub process.
Open the Area menu to switch between the areas of the configuration. In all IGSS configurations, an area named Global will be available. The remaining areas can be named freely.

When the configuration is started, the initial diagram is shown. When you switch to another
area, the initial diagram for that area is shown. When you choose an area, all the diagrams and
graphs in that area become available. In other words, only one area can be active at a time.
Each area contains a number of diagrams (process pictures), graphs and objects (the actual process components).

Diagrams
The diagram is a graphical process picture showing a section of the monitored process. The Diagram menu shows the diagrams available in the active area. Some diagrams may not be visible in the menu. In that case, choose Open to browse for those areas.
Typically, an overview diagram will be the initial diagram of an area. From that diagram, buttons lead to the other diagrams in that area. Here's an example from the IGSS Demo Configuration.

On every subdiagram, the system designer will typically place buttons allowing the operator to
navigate to related diagrams. Another way of navigating is using the Home, Back and Forward
buttons or the next/previous buttons on your mouse (if included on your mouse).
When a diagram is open, there's a checkmark beside its name. Multiple diagrams can be open
simultaneously.

Graphs
A graph is a chart showing the process values of a number of objects. The lower part of the
Graph menu shows the Standard graphs available in the active area.
When a graph is open, a check is displayed beside its name. Multiple graphs can be open simultaneously.

4.2 Panning
What is panning?
The pan function lets you view wide diagrams (panoramas) on a narrower screen for example if
you have a long production line represented on a single diagram in IGSS, but only one screen
to work with, the system integrator would then use the pan function to allow you to select which
section of the diagram you want to view.

Click here to view an example with pan

How to open the Pan window
Normally the pan window will automatically be displayed when a diagram, wider than the available screen(s), is opened. This means that if, for example the system integrator has created a
diagram which fits on 2 screens, the second screen must then be disabled in Windows before
IGSS will use the pan function.
The Pan window can also be manually opened (still only available when the above condition is
met):

1. Select the View tab.
2. Click Show Pan Control .

Right-click menu
If you right-click on the Pan window, the following menu will appear. click on any of the menu
items to view a description of its function.

4.3 Reusable diagrams
Same diagram – multiple sets of objects
As an operator you may come across reusable diagrams. This special type of diagram allows
the system designer to show multiple sets of objects on the same diagram. When you activate
a reusable diagram either from the Diagram menu or from a button, the Choose Objects to
Display dialogue appears.
Select the set of objects you want to show and click OK.

The title bar of the reusable diagram
When a specific set of objects has been selected, the diagram appears showing the name of the
set in the title bar.
To choose another set of objects, press F5 or choose the name of the diagram in the Diagram
menu.

Reference to reusable diagram
The system designer can choose to link directly to one of the sets of objects available. The operator will thus click a button with the name of the set and go straight to the reusable diagram
without seeing the Choose Objects to Display dialogue. The only indication that this is a
reusable diagram is the name of the set in the title bar.

4.4 Home, Back and Forward buttons
To use these buttons, activate the MRU Toolbar in the View menu.

The Home button
Press the Home button to go to the initial display of the IGSS configuration. The initial display
is set by the system designer and is typically an overview diagram.

The Back button
Press the Back button to return to the last diagram you viewed. Click the arrow to view the list
of previously viewed diagrams.

The Forward button
Press the Forward button to go to the diagram you last activated from the current diagram.
Click the arrow beside the button to view the list of diagrams previously activated from here.

Using the mouse
You can also use the next/previous buttons on your mouse (if included on the mouse) to navigate between the diagrams.

4.5 Most Recently Used toolbar
Activate the MRU Toolbar in the View menu.

It is used to navigate to the most recently used objects in the configuration. It shows the following:

l

The last five values / commands

l

The last five activated standard objects (analog, digital, string, table, counter)

l

The last five activated diagrams

l

The last five activated graphs

l

The last five activated areas

Note
When sending commands from the MRU Toolbar a confirmation dialog will appear, where the
command has to be confirmed, before it will be sent out. If the selected object is using Safe
Commands, the respective Safe Command dialog will appear when a command is sent from the
MRU Toolbar.
The confirmation dialog may be disabled by going to the Windows registry and setting the value
DefRun32 -> ConfirmMRUValues = 0.

4.6 Find an object using Open by Name
The Open by Name function
The Open by Name functionality in IGSS is very versatile. Use this function when you know
the name or part of the name of an object, but do not know which diagram it resides on. You can
also use it to view a list of objects with common properties, f.ex. all objects based on a specific
template, all objects sharing the same alarm number, etc.

1. Go to the Edit menu and select Open by Name or press CTRL + E.

The Object Browser
The Object Browser shows you a tree view on the left and a list of objects on the right. The
list of objects is filtered dependent on what you select in the tree view. When you open the
Object Browser, it shows all the objects in the configuration.

Examples
Here are some examples of use. We recommend that you start with the "Browse the tree view"
procedure and follow the instructions.

Standard functions
Browse the tree view
Browse the list of objects

Advanced functions
Filter the list with wildcards
Change the tree structure

4.7 Save View
You can save the current view of the Supervise module, saving all the position and placement
of all currently open diagrams and graphs. You can restore the saved view at a later date and
continue the process monitoring from where you left off.
l

To save the current view of the Supervisemodule, in the menu, click View > Save
View

l

To restore a previous view into the current Supervise module, in the menu click View >
Restore View

Single and multiple views

You can only create view for each operator machine, but you can create one view per IGSS user
if IGSS User Administration is enabled and set up for the configuration. You must also select the
Save/Restore view per user check box in the System Configuration form > Supervise
& Language tab.
Additionally, you can save multiple views per IGSS user if you also select the Multiple Views
check box in the System Configuration form > Supervise & Language tab.
Object values

Object values are not saved with the diagrams. When the saved view is restored, object values
in the diagrams and graphs will be populated with the actual values retrieved from normal process monitoring.
If you want to view historical object values in the diagrams of the Supervise module, you can
click the Playback button to open and set up the IGSS Player.

The maximum number of open diagrams setting in the System Configuration form will
limit the number of open diagrams in the Supervisemodule, including open graphs.
Any diagrams and graphs that have been removed from the configuration after the view
has been saved will not be displayed by restoring the view.

See Also
The Save and Maintain View form
"About IGSS Playback" on page 106

Chapter 5: Controlling Process Objects
5.1 Open a process diagram
1. In the menu bar, click the Diagram option.
2. You see a list of all process diagrams available for the selected area.
3. Click the diagram you wish to open.
4. This diagram is now the active one.

Note: Up to 4 process diagrams can be open simultaneously, but only one diagram is active at
any one time.

5.2 Find out the purpose of a process object
1. In the open and active process diagram, place the mouse pointer on a process component which can be
a digital process object such as a valve, or an analog process object , such as a temperature scale.
2. The object name and possibly a short description are displayed.

l

5.3 What happens when you click on a process object
Using the mouse, you have several possibilities to enquire about or send a signal to a process
component (object) displayed in the process window:

This fea- Allows you to …
ture…
Clicking … view the elements name and the available commands, if it is a digital element, and its possible charLEFT or acteristic values (actual and limit values), if it is an analog element. Provided that you have enabled
RIGHT …
View → Commandmenus in the Edit menu you are given direct access to all commands and values
associated with the selected object in a small selection box which opens up right next to the selected
object.

Result: (Click on the box entries to get more detailed information about their purpose.)

Provided that you have the right access authority , you can now operate the element: A mouse click on
the element’s name v17 or air in the command box takes you directly into the Object Properties dialogue.
Clicking
RIGHT…

… enquire about and modify the properties of the selected process object. The
button
appears. A right or left mouse click on this button takes you into the Object Properties dialogue:
Tip: For a more detailed explanation of the Object Properties dialogue, open the dialogue, click the
in the upper right hand corner of the dialogue and then - with the
mouse pointer - click the item you want information about.

symbol attached to the

Note: With View → Command menus switched off, a single left click on the object will have
no effect at all. A double click on the left mouse button will take you directly into the Object
Properties dialogue.

5.4 Give a command on a process object
1. In the menu bar, enable the option

View → Command menus.

2. In the active process diagram, left click on the process object you wish to operate.

Digital object:
A box appears giving you the possible commands. The currently valid command is
highlighted.

1. Click the new command.
2. The box closes automatically and the digital object adopts the new status.

Analog object:
A box appears giving you the characteristic values, such as
PV = process or actual value
HA = high alarm value

LA = low alarm value

1. Click on the value you wish to change.
2. A selection box opens.
3. Using the up and down buttons

, increase or decrease the value and confirm with

.

Tips
l

l

With View → Command menus switched off, a single left click on the object will have no effect at all. A
double click on the left mouse button will take you directly into the Object Properties dialogue which
allows you to change commands, settings and values for the selected object.
Giving a command on a process object requires that you have the access right for these actions as they will
most certainly cause changes in the plant or process.

5.5 Add an object note
5.6 Purpose
The object note is designed as a communications medium between operators. If an operator
needs to communicate an object-specific situation to the other operators, the object note is
ideal.
The object note is treated as an alarm and when the note is created, the alarm number 96
appears in the Active Alarms form. The other operators can see there is a note on the object
and can acknowledge and terminate the object note alarm from the object properties form in the
Supervise module.

Create the object note

1. Right-click the relevant object on the diagram and select Object Note.
2. On the Edit Object Note tab, type the object note in the Note group.
3. Click the OK button to create the object note.

Result: Alarm number 96 now appears in the Active alarms form and the symbol starts blinking on the diagram.
In this example, the operator writes "This pump must be serviced ASAP. I've contacted the service engineer and he will be here on Monday. If any other components need to be serviced,
please contact the service engineer.

Show picture
Alarm number 96
Every time an object note is created, alarm number 96 is associated with the object and
appears in the Active alarms form.

Show picture
By default, the alarm color is blue and the priority is 3. The object on the diagram will turn blue
and the symbol will blink. You can change the characteristics of the alarm number in the Definition module.
If you have selected the Use marks instead of alarms to indicate object note check box
in the System Configuration form > Supervise and Languages tab, an object note will be
indicated by a triangle icon in the upper right-hand corner of the object. The color of the triangle icon is the same color as defined for the alarm number 96.

Acknowledge the alarm

1. Right-click the relevant object on the diagram and select Object Note. Notice that there's a checkmark
indicating that an object note has been created.
2. Click the Acknowledge button to acknowledge the object note alarm.
3. Click the OK button to close the Object properties form.

Result: The alarm is now acknowledged and the symbol stops blinking on the diagram.
The alarm can also be acknowledged from the Active alarms form. If user administration is
enabled, the user name will be shown just above the note field.

Show picture
End the alarm

1. Right-click the relevant object on the diagram and select Object Note.
2. Click the Acknowledge button to acknowledge the object note alarm.
3. Click the OK button to close the Object properties form.

Result: The text in the note field is cleared and the alarm is ended. The alarm disappears from
the list of Active Alarms and moves to the Alarm Log.
Show picture

Notice that the acknowledgment time is shown to the left.

5.7 Start/stop data collection and logging on an object
Start / Stop logging
If logging is not enabled for a certain object, the operator can switch it on manually as follows.

1. Click the object symbol on the diagram.
2. In the command menu, select Properties.
3. Click the Data Collection & Logging tab.
4. Under Logging do the following:

l

Under In select Yes to start logging of incoming process values. All changes will be
logged.

l

Under Out select Yes to log outgoing commands.

l

Under Print select Yes to print log values directly.

5. Click OK to save the changes.

Start/stop data collection

1. Click the object symbol on the diagram.
2. In the command menu, select Properties.
3. Click the Data Collection & Logging tab.
4. Under Data collection, do the following:

l

Select Start to start the data collection

l

Select Stop to stop the data collection

5. Click OK to save the changes.

Note

If the data collection is stopped, the object becomes passive. The color of the object changes to
indicate that data collection has been stopped. This color is predefined by the system designer
in the Definition program.
In the View menu, select Passive Objects to view the list of passive objects in the configuration.
From this dialog box you can activate the data collection again.

5.8 Handle passive objects
A passive object is an object for which data collection has been stopped. The color of the object
changes to the passive color predefined by the system designer in the Definition program.
Passive objects can be re-activated as follows:

1. In the View menu, select Passive Objects.

Show picture

2. To re-activate the passive object(s), do the following:

l

To re-activate all passive objects, click the All button. The dialog box closes automatically.

l

To re-activate one object, select it and press the arrow button.

3. Click OK to save the changes.

Chapter 6: Handling Alarms
6.1 Recognise alarms
An alarm situation is indicated in three ways, depending on the definitions made by the system
designer:

1. The alarm icon is automatically incremented.
2. In the process diagram, the symbol representing the process object changes color and/or begins to
flash.
3. The diagram’s message line displays a message about the nature of the alarm.

To view the alarm, please…

1. Double click on the alarm icon

.

OR
2. Click

displayed in the taskbar at the bottom of the process diagram.

3. Left click of the flashing symbol in the process diagram. A selection box appears next to the symbol,

providing you with the options

, amongst others.

Notes
l

The first two actions take you directly into the Alarm List and the Alarm program with
all its alarm handling, alarm reporting and editing facilities.

l

Once you are in the Alarm program you have full access to the relevant help functions.

l

Action no. 3 allows you to acknowledge the alarm, to view the associated message
text and/or enter your own comments, but you stay in the Supervise program.

6.2 Acknowledge alarms
1. Double click the alarm icon.
2. You are directly taken into the Alarm List which displays all pending alarms - acknowledged and unacknowledged.
Unacknowledged alarms are usually shown in red.
3. In the list, select the alarm you wish to acknowledge.
4. In the menu bar, select Actions → Acknowledge.

Notes
l

This way of acknowledging an alarm takes you directly into the Alarm List and the
Alarm program with all its alarm handling, alarm reporting and editing facilities.

l

Once you are in the Alarm program you have full access to the relevant help functions.

6.3 View the alarm text
1. In the process diagram, click the object which is in the state of alarm.
2. In the menu bar, choose Edit → Alarm text.
3. The alarm text is displayed next to the faulty process object.

Tip:
For more detailed information on the alarm situation:

- press

in the taskbar or

- double click on the alarm icon

.

Both actions take you directly into the Alarm program with all its alarm handling,
alarm reporting and editing facilities.

Note: Once you are in the Alarm program you have full access to the relevant help functions.

6.4 Reading and editing Alarm notes
Alarm notes are created in the Alarm module and are attached to the individual alarm for the
specific object. You can read or edit any notes that have been created for the individual alarm
on the object in the Supervise module.

IGSS-based alarms
For IGSS-based alarms, only one alarm note will be displayed for the object because only one
alarm per object will be displayed for IGSS-based alarms. The alarm displayed will be the alarm
triggered by the highest or lowest value of the object, respectively.
For example, if the value of an analog object exceeds not only the High Limit, but the High
Alarm as well in one scanning pass of the object, then only the high alarm will be displayed on
the object.

Edit or read an alarm note

1. In the Supervise module, right-click the object in alarm and select Alarm Text to
open the Object Properties form.
2. In the Object Properties form, click the Edit Alarm Note tab.
3. On the Edit Alarm Note tab > Note group, you can read or edit the alarm note and
click the OK button to save any changes.

You can see details for the present alarm, such as alarm number, alarm start date and
time and alarm text in the All alarms on object group.

Digital (multiple) alarms
Digital alarms (alarms administered by PLC settings) enable simultaneous alarms to exist on
the object and you can therefore read and edit multiple alarm notes on the object by selecting
the desired alarm in the All Alarms on object group on the Edit Alarm note tab.
When an alarm is acknowledged and ended, the alarm note will stay attached to the alarm, but
will not be displayed for editing or reading on the object.

Edit or read multiple alarm notes

1. In the Supervise module, right-click the object in alarm and select Alarm Text to
open the Object Properties form.
2. In the Object Properties form, click the Edit Alarm Note tab.
3. On the Edit Alarm Note tab > All alarms on object group, select the alarm you
want to read or edit the alarm note for
4. In the Note group, you can read or edit the alarm note for the selected alarm and
click the OK button to save any changes.

You can see details for the present alarm, such as alarm number, alarm start date and
time and alarm text in the All alarms on object group.

6.5 Alarm indication on diagrams
When the alarm occurs
When an alarm occurs, the object's symbol will typically change color and start blinking. Also a
sound may be associated with the alarm. The system designer defines the alarm colors and
behavior in the Definition program.
On this picture the two objects, q1 and q3 are both in alarm.

When the alarm is acknowledged
The alarm can be acknowledged from the Alarm List or directly from the diagram by clicking
on the object and selecting Acknowledge Alarm in the command menu.
The object's symbol will typically change color and stop blinking. The acknowledge color is
defined by the system designer.

Alarm transparency
To provide the optimal overview for the operator, IGSS has a built-in feature called alarm transparency. It means that an alarm appearing on a diagram which is referenced by another diagram will be indicated in both places.

Example

The objects above, q1 and q3, are both located on the Dairy diagram. On the PlantTypes diagram there's a button referencing this diagram. When an object on the Dairy diagram goes in
alarm, the button will start blinking. By default, the alarm color will be blue and the alarm priority 3, but the system designer can change this in the Definition program. Alarm no. 1 is
used to achieve the alarm transparency effect. However, this alarm is for internal use and will
not be visible in the Alarm List.

6.6 Alarm delay on objects
Alarm delay is used to prevent the alarm list and alarm log from becoming filled with intermittent alarms which come and go within a very short time. If an alarm ends during the alarm
delay period , it will not be registered in IGSS - not even in the Alarm log.
If new alarms are triggered while an existing alarm is registered in the Active Alarms form,
the new alarm will immediately be registered in the Active Alarms form and the existing
alarm will be automatically acknowledged and moved to the Alarm log. This means the most
recent alarm will always be displayed in the Active Alarms form.
You can define alarm delay for each individual object in the Supervise module on the Object
Properties form > Data Collection & Logging tab > Alarm Delay field.
The maximum alarm delay is 2 billion seconds (2,000,000,000 seconds) roughly 63 years.
To define an alarm delay for an object

1. In the Supervise module, right-click the object and select Properties to open the
Object Properties form.

2. On the Data Collection & Logging tab > Alarm Delay field, enter or click the up
and down arrows to set the desired number of seconds for the alarm delay. If the
value of the Alarm Delay field is 0, alarms will not be delayed.
3. Click the OK button to save the changes and close the Object Properties form.

Access to the Object Properties form can be and has been restricted or removed on
some IGSS configurations.

See Also
Alarm Delay

6.7 Inhibit alarms
If a process component is being serviced or renders irrelevant alarms for other reasons, these
alarms can be temporarily inhibited. The operator can choose to inhibit all alarms for the object
or only specific ones.

Inhibit specific alarms
To inhibit specific alarms on an object, do the following:

1. Click the object on the diagram.
2. In the command menu, select Inhibit Alarms.
3. In the list select the check box beside the alarm(s) you want to inhibit.

Show picture

4. Click OK.

Result: Alarm no. 92 "Alarm Inhibit (specific alarms)" appears in the Alarm List.

Tip

To inhibit a specific alarm that is already active, right-click the alarm in the Alarm List and
select Inhibit Alarm.

Inhibit all alarms
To inhibit all alarms on an object, do the following:

1. Click the object on the diagram.
2. In the command menu, select Inhibit Alarms.
3. At the top, select the Inhibit All Alarms check box.
4. Click OK.

Result: Alarm no. 91 "Inhibit Alarms (all alarms)" appears in the Alarm List.

Tip
To inhibit all alarms, right-click in the Alarm List and select Inhibit All.

To reactivate inhibited alarms
In the Supervise program, do the following:

1. Click the object on the diagram.
2. In the command menu, select Inhibit Alarms.
3. Clear all check boxes. You can use Clear All button.
4. Click OK.

OR

In the Alarm program, do the following:

1. Right-click the relevant alarm (no. 91 or 92). A checkmark will be visible beside the Inhibit Alarms
menu item.
2. Select the Inhibit Alarms item.

6.8 Inhibit WinPager alarms
The IGSS Winpager module allows operators to receive plant alarms as SMS messages on
their mobile phones.
In some cases, you may want to inhibit the dialing out of these alarms.

Inhibit WinPager dialout from Supervise

1. Click the object on the diagram.
2. In the command menu, select Inhibit Alarms.
3. Select the Inhibit WinPager dialing check box.
4. Click OK.

Result: Alarm no. 93 "WinPager Inhibit" appears in the Alarm List.

Inhibit WinPager dialout from Alarm

1. Right-click the alarm in the Alarm List.
2. In the popup menu, select Inhibit WinPager.

Show picture

To reactivate WinPager-inhibited alarms

1. In the Alarm List, right-click alarm no. 93 and select Inhibit Winpager.

6.9 Change Alarm Priority
You can change the priority of an alarm in the Supervise module.

The highest alarm priority is 255 and the lowest priority you can assign an alarm priorities is 1.

In some installations, operator access to the Alarm Detail s form can be restricted
through user administration and internal security policies.

To change the alarm priority of an alarm

1. In the Supervise module, click Tools > Alarms to open the Alarm Details form.
2. In the Alarm Details form, select the alarm number you want to change the priority
for
3. Select the Edit button to open the Edit Alarm Description form.
4. In the Priority field, enter the new alarm priority and click the OK button to close
the Edit Alarm Description form.
5. In the Alarm Detail s from, click the Close button to save the new alarm priority.
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Chapter 7: Working with Graphs
7.1 Graphs in IGSS
A graph displays variations in object states or values with respect to time and can facilitate gaining a quick
overview of the characteristic behavior of selected key process components.
You can use graphs to evaluate the state of one or more process components over time and to detect
adverse trends at an early stage. IGSS graphs are capable of combining current trends and historical data
in the same chart. You can thus see at a glance what happened in the process just before and immediately
after an intervention or incident.

Graph types
IGSS contains two types of graphs: Standard graphs and Operator graphs.
l

Standard Graphs are graphs created, edited, maintained and deleted by a System Designer in
the Definition module and made accessible to the operators either in the Graph menu of the Supervise module or through a descriptor 1 in the process diagram. Operators cannot edit or delete a
Standard graph but can use Standard graphs as base to create their own Operator graphs.
Standard graphs can bee accessed from the Graph menu in the Supervise mobile or from selected
descriptors in the process diagrams (buttons, images, symbols, clickable areas and more)

l

Operator graphs are graphs created by operators. An Operator graph is not write-protected and
can be edited and deleted by any other online operator. Operator graphs can be created based on a
Standard graph or created from the ground up and can be created either in the Supervise module or
directly from the object menu in the process diagrams.
Operator graphs can only be access through the Graph menu in the Supervise module.

In addition to these two graph types, IGSS also contains Embedded graphs and Dashboard graphs.
Embedded graphs are embedded in the process diagram and are created and defined by the System
Designer in the Definition module.
Dashboard grahps can only be displayed in the Dashboard module and can be created and maintained by
the System Designer and the Operator both.

Supported object types
A graph chart may contain up to 16 signals from process components (IGSS objects). Signals from the following object types can be displayed in the graphs:
l

Analog

l

Digital

1 A descriptor is the graphical display of an object. IGSS includes many types of descriptors including: -

Built-in standard symbols - Animated symbols (Symbol Factory library) - Graphics and animation - Drawing
symbols - Windows controls - ActiveX controls An IGSS object can be represented with different descriptors
on different diagrams.
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l

Table

l

Counter

Navigating and making changes
Operators have a large degree of freedom when using the graphs - not only viewing and zooming the graph
but also adjusting the graph properties themselves.
Operators can use a large number of methods to navigate the graph charts, dragging X-and Y-axes forward
or backwards in time, hiding and displaying graph signals and signal lines, zooming graph areas for better
detail and clarification,
When a Standard or Operator graph is created, a number of default properties such as signal
appearance, graph colors and settings are automatically applied to the graph elements in order to facilitate
rapid creation and deployment of usable graphs. Operators can freely edit these defaults and save the results as a new Operator graph.
Operators can freely change any graph property including adding and removing signals to the chart and
save the results as a new Operator graph.

See Also
"Open an existing graph" on page 62
"Change graph period" on page 63
"Navigate the Axes" on page 65
"Highlight and hide a signal" on page 67
"Display graph points and show graph values" on page 66
"Change the graph appearance" on page 70
"Add or remove a signal" on page 73
"Zoom an area in the graph" on page 80
"Compare two graph periods" on page 81
"Print a Graph" on page 83
"Save an Operator graph" on page 83
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7.2 Graph Properties Form
Use the Graph Properties form to define the graph period, the object atoms and appearance of the graph
line, the data source to be displayed in the graph, the graph title and the font properties for all graph texts.
You can also set up the graph legend properties and chart colors as well enable display of the graph toolbar
and status bar.
Signals

A graph must contain at least one signal, which can be any object atom which contains data (LOG, BCL
and/or Live data).
You can select up to 16 signals that can consist of any object atoms which contain data (LOG, BCL or Live
data) from the following atom types:
l

Analog

l

Digital

l

Table

l

Counter

Preconditions
l

The Supervise module must be opened and the configuration must be started and running.

Where do I find it?
l

In the Supervise module > Graph > Create Operator Graph

l

In an open Operator Graph, right-click the graph and select Properties.

Tab Overview
Tab Page

Description

On this tab page you can :

Window

l

Enter the name and/or description of the graph

l

Set up the graph window properties

l

Define how the graph is displayed in the menu

l

Connect the graph to other objects

l

Enable object-level protection for the graph

On this tab page you can:
Period

l

Select the graph period to display:

l

Relative periods (1 hour back, 2 days back)
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Tab Page

Description
l

Absolute periods (Today, Yesterday)

l

Custom durations (3 hours back)

l

Custom periods, where you define the start and end dates and times of the
graph.

On this tab page you can:
l

Select the signals to be displayed in the graph.

Signals

l

Add new signals from the Object Browser form.

l

Remove existing signals.

l

Replace one signal with another new signal.

l

Rearrange the display order of the signals

l

Define the signal line color and legend text for the signal

l

Select to display the Y-axis for the signal

l

Define which value limits to apply to the signal

On this tab page you can:

Chart

l

Define the title of the graph

l

Define the placement of the graph legend

l

Select the signal legend properties

l

Select the font properties for all graph texts

On this tab page you can:
l

Define colors for the graph elements:

Options

l

Background color

l

Text color

l

Axis colors

l

Graph grid color

l

Display the graph toolbar

l

Display the graph status bar

Field and button Help
Period tab
Field name

Select display period

Description

Select the period you want to display in the graph for the signal selected in the display.
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Field name

Description

All back dates and times are based on the present date and time.
You canalso define a fixed custom duration or custom period:
l
l

Custom Duration: You must define the interval in the Duration field.
Custom Period: You must define the start and end date and times in the
From and To fields below.

Operators will be able to change the graph period by accessing the Graph properties.
Enter the duration and time interval for the Custom Duration graph period
Duration

These fields will only be accessible if you selected the Custom Duration graph
period in the Select period to display field.
Enter the start date for the Custom Period graph period.

From date

This field will only be accessible if you selected the Custom Period graph period in
the Select period to display field.
Enter the start time for the Custom Period graph period.

From time

This field will only be accessible if you selected the Custom Period graph period in
the Select period to display field.
Enter the end date for the Custom Period graph period.

To date

This field will only be accessible if you selected the Custom Period graph period in
the Select period to display field.
Enter the end time for the Custom Period graph period.

To time

This field will only be accessible if you selected the Custom Period graph period in
the Select period to display field.

Signals tab
Field/button
name

Description

The name of the object selected in the Signals to show on the graph pane.
Object
The content of this field cannot be edited.
The atom of the object selected in the Signals to show on the graph pane to be
displayed in the graph.
Atom
Select a new atom from the drop-down list in the field. Only those atoms that have
been enabled on the object will be listed in the drop-down list.
Data Source

Select the data source to be used for displaying data values from the atom selected
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Field/button
name

Description

in the Atom field.
Only data files that exist for the selected atom are accessible in the drop-down list.
l

l
l

l

Auto: The quickest and best data is retrieved first in order to draw the initial
graph lines. As the data retrieval continues, the graph line and details
become more refined and specific. This option is most effective if the object
saves LOG and reduced (BCL) data simultaneously.
LOG: Only data in the LOG files are used to draw the chart.
Reduced: Only reduced data in the BCL files are used to draw the chart. You
must also select which data reduction method enabled on the atom to apply
as well as which period to display reduced data for.
Online: Live data is used to draw the graph lines and points

Only accessible data options are displayed in the drop-down lists. If an object atom is
not set up to store data in LOG or BCL (reduced data) files, these options will not be
accessible.
Select which data reduction method is to be used as chart data.
Reduction

Only data reduction methods that have been enabled for the object selected in the
Signals to show on the graph pane will be displayed in the drop-down list.
This field is only accessible if you have selected Reduced in the Data source field.
Select which period Data reduction data is to be used as chart data:
l

l
l

l

Period
l

Auto: The quickest and best data is retrieved from all reduced data files
(BCL and HDM) in order to draw the initial chart lines
Base: The Base Class Files are used to draw the graph lines
Hour: The Hour values in the HourDayMonth (HDM) database are used to
draw the graph lines
Day: The Day values in the HourDayMonth (HDM) database are used to draw
the graph lines
Month: The Month values in the HourDayMonth (HDM) database are used to
draw the graph lines

This field is only accessible if you have selected Reduced in the Data source field.
If you have selected a period which does not contain reduced data for the atom, the
graph line will not be drawn.
Line Color

Select the line color used to represent the object you selected in the Signals to
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Field/button
name

Description

show on the graph pane.

Legend text
for signal

Enter the legend text for the object selected in the Signals to show on the graph
pane.
The text will be displayed in addition to the object name and description.

Click this button to open the Object Browser form and add an object to the Signals
to show on the graph pane.
Add button

In the Object Browser form, you can search for and select the object you want to
add for display in the graph.
You can specify which object atom to display as the signal in the graph in the Atom
field on the Basic tab.

Delete button

Click this button to remove the object selected in the Signals to show on the
graph pane from the graph.
Click this button to replace an object selected in the Signals to show on the graph
pane with new object.

Replace button

The Object Browser form will open and you can search for and select the new
object you want to add for display in the graph.
You can specify which object atom to display as the signal in the graph in the Atom
field on the Basic tab.

Move Up button

Click this button to move a selected object in the Signals to show on the graph
pane up in the Signals list.

Move Down
button

Click this button to move a selected object in the Signals to show on the graph
pane down in the Signals list.

Show Y-axis
for this signal

Select this check box to display the Y-axis in the graph for the object selected in the
Signals to show on the graph pane.
You can clear this check box when displaying multiple signals
Operators can display or hide individual Y-axes during runtime display of the graph.

Automatic

The graph will attempt to set the upper and lower limits of the Y-axis based on the
object data selected for display in the graph.

Limits from
object

Select this check box to use the atom limits (minimum and maximum) of the object
selected in the Signals to show in the graph pane as lowest and highest values on
the Y-axis.
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Field/button
name

Description

Select this option to manually define minimum and maximum Y-axis values in the
Minimum and Maximum fields below.
Fixed limits

The Y-axis will automatically be adjusted to reflect the new limits, distributing the Yaxis scale values evenly along the entire axis.
Any defined maximum and minimum values for the atom will not be used.
Enter the minimum (lowest) value of the Y-axis.

Minimum
Atom values lower than this value will not be displayed in the graph.
Enter the maximum (highest) value of the Y-axis.
Maximum
Atom values greater than this value will not be displayed in the graph.

Chart tab
Field name

Chart title
(Top)
Show Legend

Description

Enter the title of the chart.
The title is displayed on the top of the chart.
Select this check box to display the graph legend in the chart.
Select where the graph legend is to be placed in the chart area:

Legend Placement

l

Top

l

Bottom

l

Left

l

Right

Select this check box to display the object name, description and atom name in the
graph legend.
Show
object/atom
information

The object description will not be displayed if the object does not have a description.
If the object atom contains a display name, the display name will be shown instead
of the atom name.
This setting is applied to all signals in the graph.

Show text
defined for
each signal

Select this check box to display the text defined in the Signals tab > Basic sub-tab
> Legend text for signal field.
This setting is applied to all signals in the graph.
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Field name

Select font
button

Description

Click the button to open the Font form and select the font, font size and font type to
apply to all texts in the graph.

Options
Field name

Description

Clear this check box to manually define colors of the following graph elements:

Use automatic colors

l

Background

l

Text

l

Axis

l

Grid

If this check box is selected, the graph will be displayed in the default system colors .
Click the field to open the Colors form and select the graph background color.
Background

The background of the entire graph will be displayed in this color
This field is only accessible if the use automatic colors check box has been
cleared.
Click the field to open the Colors form and select the color of all X and Y axis scale
values.

Text
This field is only accessible if the use automatic colors check box has been
cleared.
Click the field to open the Colors form and select the color of the X-axis.

Axis

The Y-axis will still be displayed in the selected signal color and the individual
graph line colors are defined on the Signals tab for each individual signal.
This field is only accessible if the use automatic colors check box has been
cleared.
Click the field to open the Colors form and select the color of the grid lines in the
graph.

Grid

To remove grid lines, select the grid same color as the
grid background.
This field is only accessible if the use automatic colors check box has been
cleared.
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Field name

Description

Display
graph toolbar

Select this check box to display the graph toolbar in the top of the graph window.

Display
graph statusbar

Select this check box to display the graph status bar at the bottom of the graph window.

Auto hide
axes with the
same value
range

Select this check box to merge all Y-axes that have identical measuring ranges. This
reduces the number of identical Y-axes to only one.

See Also
"The Graph Toolbar" on page 50
"The Graph Status bar" on page 52

7.3 The Graph Toolbar
The graph toolbar presents a number of functions and options to the operator and can be displayed or hidden for the graph by selecting the Display Graph Toolbar check box on the Options tab in the Graph
Properties form.
Use the Graph Toolbar to
l

Display signal points on the graph line

l

Display signal value on the graph line

l

Magnify a graph area (Zoom in or zoom out)

l

Jump to a specific date in the graph

l

Change the period of the graph

l

Compare the present graph trend with the graph trend for another period

l

Send the present graph image to the default printer

l

Save the graph as an Operator Graph - either updating an existing Operator graph or creating a new
one.

Preconditions
The Display Graph Toolbar check box on the Options tab in the Graph Properties form must be selected for the Graph toolbar to be display .
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Button help
Buttons

Show Points

Description

Click this button to display the points in the graph line. The points will be displayed as
light gray dots.
If you want to see the values on the graph line, click the Show Values button.
Click this button to hide the points in the graph line.

Hide Points
The graph will be rendered as lines with no points.
Click this button to display data values in the graph line.

Show values

The yellow value indicator will be displayed in the X-axis of the graph. You can drag
the value indicator to any position in the graph and display the values on the graph
line as well as the date and time of the value..
If you want to see the points on the graph line, click the Show points button.

Hide values

Click this button to hide the value indicator.
Click this button to zoom an area in the graph.

Zoom in

You can continue to zoom graph areas, increasing the detail of the graph by click this
button and selecting area repeatedly.

Zoom out

Click this button to zoom out of a graph area, stepping back one zoom action.

Reset Zoom

Click this button to zoom out to the main graph area, resetting all zoomed areas.

Go to Date

Click this button to open the Go to Date form where you can jump to a an entered
date and time . You can also click the Now button to jump to the present date and
time in the graph.

Change
Period

Click this button to open the Graph Properties form and change the display period
of the graph.
Only the Period tab of the Graph properties form will be accessible.
Click this button to compare the present graph trend with the graph trend for another
period.

Compare
Periods

The graph area will be divided into two sections, the upper section which can be
scrolled individually and the lower section which is scrolled together with the upper
section.

Single
Period

Click this button to revert the graph from a split-sectioned graph used for comparing
two graph periods to a the original single-period graph.

Print

Click this button to send the present graph to the default printer.

Save

Click this button to open the Save As form where you can save the graph as an oper-
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Buttons

Description

ator graph, either overwriting the original operator graph or creating a new operator
graph.
You can always save a standard graph as an operator graph and afterwards edit the
graph properties parameters and signal settings of the operator graph, creating your
own customized graph.

See Also
"Graph Properties Form" on page 43
"Zoom an area in the graph" on page 80
"Compare two graph periods" on page 81

7.4 The Graph Status bar
The graph status bar displays the status of data retrieval when the graph is opened and being populated
with data or when scrolling along the X-axis , changing time period.
The Graph status bar can be removed from the graph by clearing the Display graph statusbar check box
on the Options tab in the New Graph Properties form.

See Also
"Graph Properties Form" on page 43

7.5 Graph Property Menu
Use graph property menu to:
l

Hide or display selected signals

l

Highlight or remove highlights from selected signals

l

Show or hide graph points

l

Show or hide graph values

l

Zoom in or zoom out graph areas as well as reset all zoom levels

l

Jump to a selected date in the graph
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l

Change the graph period

l

Compare the present period with another

l

Send the present graph to the default printer

l

Save the present graph as an operator graph

l

Open the Graph properties form

Where do I find it?
In the graph area, right-click to open the Graph property menu.

Preconditions
The graph must be opened in the graph window.

Menu help
Menu option

Description

Select this option to display the graph and Y-axis of all hidden signals.
Show All
This option is only accessible if there are hidden signals in the graph.
Remove all
highlights

Show Points

Select this option to remove all highlights from all signals.
Select this option to display the points in the graph line. The points will be displayed
as light gray dots.
If you want to see the values on the graph line, select the Show Values option.

Hide points

Select this option to hide the points in the graph line.
Select this option to display data values in the graph line.

Show Values

The yellow value indicator will be displayed in the X-axis of the graph. You can drag
the value indicator to any position in the graph and display the values on the graph
line as well as the date and time of the value..
If you want to see the points on the graph line, select the Show points option.

Hide Values

Select this option to hide the value indicator.
Select this option to zoom an area in the graph.

Zoom in

Zoom out

You can continue to zoom graph areas, increasing the detail of the graph by Select
this option and selecting area repeatedly.
Select this option to zoom out of a graph area, stepping back one zoom action.
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Menu option

Description

This option is only accessible if the graph has been zoomed once or more.
Select this option to zoom out to the main graph area, resetting all zoomed areas.
Reset zoom
This option is only accessible of the graph has been zoomed multiple times.

Go to Date

Change
Period

Select this option to open the Go to Date form where you can jump to a an entered
date and time . You can also click the Now button to jump to the present date and
time in the graph.
Select this option to open the Graph Properties form and change the display period
of the graph.
Only the Period tab of the Graph properties form will be accessible.
Select this option to compare the present graph trend with the graph trend for
another period.

Compare
Periods

Single Period

The graph area will be divided into two sections, the upper section which can be
scrolled individually and the lower section which is scrolled together with the upper
section.
Select this option to revert the graph from a split-sectioned graph used for comparing two graph periods to a the original single-period graph.
Select this option to hide one or more signals.

Hide

Hidden signals are not displayed in the graph and the Y-axis of the signal will be hidden.
Select this option to emphasize one or more signals.

Highlight
The graph lines and Y-axis of highlighted signals will be displayed with thicker lines.
Print

Select this option to send the present graph to the default printer.
Select this option to open the Save As form where you can save the graph as an
operator graph, either overwriting the original operator graph or creating a new operator graph.

Save

You can always save a standard graph as an operator graph and afterwards edit the
graph properties parameters and signal settings of the operator graph, creating your
own customized graph.
This option is only accessible if changes have been made to a standard graph or you
have opened an Operator graph.
Select this option to open the Graph Properties form.

Properties

Use the New Graph Properties form to define the graph period, the object atoms
and appearance of the graph line, the data source to be displayed in the graph, the
graph title and the font properties for all graph texts.
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Menu option

Description

You can also set up the graph legend properties and chart colors as well enable display of the graph toolbar and status bar.

See Also
"Graph Properties Form" on page 43

7.6 Signals Property Menu
Use Signals property menu to:
l

Hide or display selected signals

l

Highlight or remove highlights from selected signals

Where do I find it?
In the graph area, right-click a signal in the legend to open the Signals property menu.

Preconditions
The graph must be opened in the graph window and legends must be displayed in order to be able to rightclick on a signal.

Menu help
Menu option

Description

Select this option to emphasize the selected signal.
Highlight
The graph lines and Y-axis of highlighted signals will be displayed with thicker lines.
Remove Highlight

Select this option to remove emphasis for the selected signal.
This option is only accessible if the selected signal is highlighted.
Select this option to hide the selected signal in the graph.

Hide

Hidden signals are not displayed in the graph and the Y-axis of the signal will be hidden.
Select this option to display the selected signal in the graph.

Show
This option is only accessible if the selected signal is hidden.
Show All

Select this option to display the graph and Y-axis of all hidden signals.

- 55 -

IGSS V12, User Guide

Menu option

Description

This option is only accessible if there are hidden signals in the graph.
Select this option to hide all other signals.
Hide all others

Hidden signals are not displayed in the graph and the Y-axis of the signal will be hidden.
Select this option to open the Graph Properties form.

Properties

Use the New Graph Properties form to define the graph period, the object atoms
and appearance of the graph line, the data source to be displayed in the graph, the
graph title and the font properties for all graph texts.
You can also set up the graph legend properties and chart colors as well enable display of the graph toolbar and status bar.

See Also
"Graph Properties Form" on page 43

7.7 X-Axis Property Menu
Use the X-axis property menu to:
l

Move the graph period backwards by time period (day, week, month)

l

Move the graph to the present date or to a specified date

l

Change the period of the graph

l

Compare the signal with another time

l

Hide and display selected signals in the graph

l

Highlight and remove highlight for selected signals

Where do I find it?
In the graph area, right-click the X-axis to open the X-axis property menu. If comparing two periods,
right-click the lower X-axis to open the X-axis property menu.

Preconditions
The graph must be opened in the graph window.
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Menu help
Menu option

Description

Go Forward

Move the graph period forward by the selected period.

Go Backward

Move the graph period back by the selected period.

Go to Now

Move the graph to the present date and time.

Go to Date

Specify the date and time and move the graph to the date.

Change
Period

Select this option to open the Graph Properties form and change the display period
of the graph.
Only the Period tab of the Graph properties form will be accessible.
Select this option to compare the present graph trend with the graph trend for
another period.

Compare
Periods

Single Period

The graph area will be divided into two sections, the upper section which can be
scrolled individually and the lower section which is scrolled together with the upper
section.
Select this option to revert the graph from a split-sectioned graph used for comparing two graph periods to a the original single-period graph.
Select this option to open the Graph Properties form.

Properties

Use the New Graph Properties form to define the graph period, the object atoms
and appearance of the graph line, the data source to be displayed in the graph, the
graph title and the font properties for all graph texts.
You can also set up the graph legend properties and chart colors as well enable display of the graph toolbar and status bar.

See Also
"Navigate the Axes" on page 65
"Graph Properties Form" on page 43

7.8 Y-Axis Property Menu
Use the Y-axis property menu to:
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l

Hide and display selected signals in the graph

l

Highlight and remove highlight the selected signals

Where do I find it?
In the graph area, right-click a Y-axis to open the Y-Axis property menu.

Preconditions
The graph must be opened in the graph window and the Y-axis of the signal must be displayed in order to
be able to right-click on a Y-axis.

Menu help
Menu option

Description

Select this option to emphasize the signal associated with the Y-axis.
Highlight
The graph lines and Y-axis of highlighted signals will be displayed with thicker lines.
Select this option to remove emphasis for the selected signal associated with the YRemove High- axis.
light
This option is only accessible if the selected signal is highlighted.
Select this option to hide selected signal associated with the Y-axis.
Hide

Hidden signals are not displayed in the graph and the Y-axis of the signal will be hidden.
Select this option to hide all other signals.

Hide All Others

Hidden signals are not displayed in the graph and the Y-axis of the signal will be hidden.
Select this option to display the graph and Y-axis of all hidden signals.

Show All
This option is only accessible if there are hidden signals in the graph.
Select this option to open the Graph Properties form.

Properties

Use the New Graph Properties form to define the graph period, the object atoms
and appearance of the graph line, the data source to be displayed in the graph, the
graph title and the font properties for all graph texts.
You can also set up the graph legend properties and chart colors as well enable display of the graph toolbar and status bar.
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See Also
"Navigate the Axes" on page 65
"Graph Properties Form" on page 43

7.9 Compare X-Axis Property Menu
Use the Compare X-axis property menu to:
l

Move the period used for comparison

l

Move the graph to a specified date

Where do I find it?
In the graph area, right-click the upper X-axis to open the X-axis property menu.

Preconditions
The graph must be opened in the graph window

Menu help
Menu option

Description

Go Backward

Move the graph period back by the selected period.

Reset Offset

Select this option to reset any adjustment of the compare X-axis and restore the compare x-Axis to the same position of the lower X-Axis.

Go to Date

Specify the date and time and move the graph to the date.

Change
Period

Select this option to open the Graph Properties form and change the display period
of the graph.
Only the Period tab of the Graph properties form will be accessible.
Select this option to compare the present graph trend with the graph trend for
another period.

Compare
Periods

The graph area will be divided into two sections, the upper section which can be
scrolled individually and the lower section which is scrolled together with the upper
section.

Single Period

Select this option to revert the graph from a split-sectioned graph used for comparing two graph periods to a the original single-period graph.

Properties

Select this option to open the Graph Properties form.
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Menu option

Description

Use the New Graph Properties form to define the graph period, the object atoms
and appearance of the graph line, the data source to be displayed in the graph, the
graph title and the font properties for all graph texts.
You can also set up the graph legend properties and chart colors as well enable display of the graph toolbar and status bar.

See Also
"Graph Properties Form" on page 43

Delete this text and replace it with your own content.

7.10 Graph keyboard shortcuts and Mouse combinations
The following keyboard shortcuts and mouse combinations are available for operations in the graphs:

Keyboard shortcuts
Keyboard shortcuts

Description

Arrow Left

Offsets (moves) the lower X-axis and upper (compare) X-axis back.

Arrow Right

Offsets (moves) the lower X-axis and upper (compare) X-axis forward.
Offsets (moves) the Y-axis upwards.

Arrow Up

Arrow Down

This is only relevant for graphs that have been
zoomed.
Offsets (moves) the Y-axis downwards.
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Keyboard shortcuts

Description

This is only relevant for graphs that have been
zoomed.
Shift the Y-axis upwards by one graph page.
Page Up

This is only relevant for graphs that have been
zoomed.
Shift the Y-axis downwards by one graph page.

Page Up

This is only relevant for graphs that have been
zoomed.
Shift the lower X-axis and upper (compare) X-axis
backwards by one graph page.

Shift + Page Up
This is only relevant for graphs that have been
zoomed.

Shift + Page
Down

End

Shift the lower X-axis and upper (compare) X-axis
forwards by one graph page.
This is only relevant for graphs that have been
zoomed.
Moves the lower X-axis and upper (compare) X-axis
the graph to the end of the graph period.

Mouse Combinations
Mouse Combinations

Description

Left click + drag

Drag the lower or upper (compare) X-axis forward or backward

Shift + Left click +
drag

Drag both X-axes forward or backward.
In graph area: Scrolls both X-axes forward or backward.
In X-axis: Only scrolls the X-axis where the mouse cursor is placed.

Rolling Mousewheel

In Y-axis: Only scrolls the Y-axis where the mouse cursor is placed.

The Y-axis can only be scrolled if parts of the Y-axis is not displayed, for
example when zooming.
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Mouse Combinations

Description

Scrolls all Y-axes up or down.
Shift + Rolling
Mousewheel

Ctrl + rolling
mousewheel

The Y-axis can only be scrolled if parts of the Y-axis is not displayed, for
example when zooming.
The scrolling speed is increased, allowing for faster scrolling of greater time periods (X-axes) or values (Y-axes).
Moves the Value Indicator to the clicked mouse position.

Left click in graph
area

The Value Indicator must be enabled by clicking the Show Values button in the
Graph Toolbar.
Select an area of the graph to zoom.

Shift + Mouse click

Select the Zoom in button and press the Shift key to select a custom area of the
graph for zooming.
When zooming a graph area

Click in the zoom
window

The graph is moved to the position of the mouse cursor in the zoom overview window.

Click in the graph
area

The zoom overview window is moved to display the graph at the location of the
mouse cursor.

See Also

7.11 How To
Open an existing graph
You can open an existing Standard or Operator graph in the Supervise module in several ways:
Standard graphs, made accessible in the Graph menu

In the Supervise module, click Graph and select the graph you want to open.
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Standard graphs, made accessible directly through a descriptor

In the process diagram, click the descriptor 1 (button, image or graph symbol) connected to the graph to
open the Standard graph.

Operator graphs

In the Supervise module, click Graph > Open Operator Graph and select the operator graph you want
to open.
Operator graphs cannot be connected to descriptors in IGSS and must be accessed through the Graph
menu.

Change graph period
You can change the default period displayed in the graph for both graph types (Operator and Standard)

Standard graphs
The graph period defined for a Standard graph will be the default period when the graph is opened in the
Supervise module, but you can change the graph period to display object data for other periods.
When you change a graph property for a Standard graph, you can save the changes, converting the Standard graph to an Operator graph.

Operator graphs
The default period when a new Operator graph is created is one hour back, but you can change this by editing the graph properties of the Operator graph.
You can save your changes, either overwriting the original Operator graph or creating a new one. If you do
not save your changes, the Operator graph you opened will retain its original graph period.
To change the graph period

If the Graph toolbar is displayed

1. Click the Change Period button to open the Graph Properties form > Period tab
2. In the Select display period field , select period to display in the graph. You can select from
the fixed periods or select a custom duration or custom period.

1 A descriptor is the graphical display of an object. IGSS includes many types of descriptors including: -

Built-in standard symbols - Animated symbols (Symbol Factory library) - Graphics and animation - Drawing
symbols - Windows controls - ActiveX controls An IGSS object can be represented with different descriptors
on different diagrams.
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l

Fixed Duration: Select a fixed (pre-defined) duration in the drop-down list.

l

Custom Duration: Select Custom Duration in the drop-down list.In the Duration field,
enter the duration interval and the duration type (Minutes, Hours, Days, Weeks, Months or
Years)

l

Custom Period: Select Custom Period in the drop-down list.
1. In the From date field, select the start date of the graph period.
2. In the From time field, select the start time of the graph period.
3. In the To date field, select the end date of the graph period.
4. In the To time field, select the end time of the graph period.

3. Click the OK button to save the changes and close the Graph Properties form

If the Graph toolbar is not displayed

1. Right-click the graph or right-click the X-axis and select Change period to open the Graph
Properties form > Period tab
2. In the Select display period field , select period to display in the graph. You can select from
the fixed periods or select a custom duration or custom period.Fixed Duration: Select a fixed
(pre-defined) duration in the drop-down list.
l

Custom Duration: Select Custom Duration in the drop-down list.In the Duration field, enter
the duration interval and the duration type (Minutes, Hours, Days, Weeks, Months or Years)

l

Custom Period: Select Custom Period in the drop-down list.
1. In the From date field, select the start date of the graph period.
2. In the From time field, select the start time of the graph period.
3. In the To date field, select the end date of the graph period.
4. In the To time field, select the end time of the graph period.

3. Click the OK button to save the changes and close the Graph Properties form

To go to a date in the graph

If the Graph toolbar is displayed

1. Click the Go to Date button to open the Go to Date form.
2. Enter the date and time. Click the now button to enter the present date and time.
3. Click the OK button to close the Go to Date form and jump to the date entered

If the Graph toolbar is not displayed
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1. Right-click the graph or right-click the X-axis and select Go to Date to open the Go to Date
form
2. Enter the date and time. Click the now button to enter the present date and time.
3. Click the OK button to close the Go to Date form and jump to the date entered

You can also right-click the X-axis and select Go to Now to jump the graph to the present date and time.

See Also

"X-Axis Property Menu" on page 56
"Compare two graph periods" on page 81

Navigate the Axes
The X and Y axes can be moved, shifted and adjusted by the operators in the graph using the mouse and/or
keyboard combinations. This will shift the graph lines along with the axis in the direction moved.

Navigating the X-axis
You can move the X-axis to the left and right by using the LEFT and RIGHT arrows on the keyboard or you
can drag the X-axis to the left and right using your left mouse button. If you have a wheel mouse, scrolling
the wheel up will shift the X-axis t the right and scrolling down will shift the X-axis to the left.
If you right-click the X-axis, you can move the entire graph backwards or forwards by a selected period.
Shift the X-axes when comparing graphs

If the graph is used to compare two periods, dragging the upper or lower X-axis will shift the axis independently to the left or right. If you press SHIFT while dragging the upper or lower X-axis, both X-axes will
be locked and moved simultaneously.
If you have a wheel mouse, scrolling the wheel up will shift both X-axes t the right and scrolling down will
shift both X-axes to the left.

Navigating the Y-axis
The Y-axis can be adjusted by pressing the SHIFT button and dragging the axis with the left mouse button.
You can adjust the Y-axis individually for each signal and
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See Also

"Graph keyboard shortcuts and Mouse combinations" on page 60
"X-Axis Property Menu" on page 56
"Y-Axis Property Menu" on page 57

Display graph points and show graph values
A graph is by default not displayed with graph points or options for viewing the graph values, but you can
enable graph point display and view graph values in the graph lines when viewing the graph.

Display graph points
You can display the individual graph points, which each represent a data value retrieved from the data
source (LOG, BCL or Live data) as gray dots on the signal line.

If the Graph toolbar is displayed
l

Click the Show Points button to display individual graph points on the signal line.

l

Click the Hide Points button in the graph toolbar to hide the points again.

If the Graph toolbar is not displayed
l

Right-click the graph and select Show Points to display individual graph points on the signal line.

l

Right-click the graph and select Hide Points to hide the points again.

See values on the graph line
You can also display and use the Value bar to see the signal values for the graph line, dragging the value
bar to the position you want to see signal values for all signal lines.

If the Graph toolbar is displayed
l

Click the Show Values button to display the value bar. You can drag the value bar along the Xaxis to view the signal values on the graph lines.

l

Click the Hide Values button in the graph toolbar to hide the value bar again.

If the Graph toolbar is not displayed
l

Right-click the graph and select Show Values to display the value bar. You can drag the value bar
along the X-axis to view the signal values on the graph lines.

l

Right-click the graph and select Hide Values to hide the value bar again.

Zoom the graph to obtain a better overview of the graph line and period.
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See Also

"The Graph Toolbar" on page 50
"Graph Property Menu" on page 52
"Zoom an area in the graph" on page 80
"Change graph period" on page 63

Highlight and hide a signal
To improve the overview of your graph, you can highlight and emphasize as well as hide other signal lines,
cleaning up the graph and removing distractions and clutter.

Highlight a signal
You can highlight one or more signals in the graph, emphasizing the signal's graph line and the Y-axis by
thickening the line and axis to gain a better overview of the graph trend.

If the signal legend is displayed
Right-click the signal legend text of the signal you want to highlight and select Highlight. The signal line
and Y-axis will be changed to a thicker line.

Remove signal highlight
To remove a highlight from a signal, right-click the signal legend of the signal you want to remove the highlight from and select Remove Highlight.
You can remove all signal highlights by right-clicking a signal legend text that is not highlighted and selecting Remove all Highlights.
If there are multiple highlighted signals, you can right-click any signal legend text and select Remove all
Highlights to remove highlights from all signals.

If the signal legend is not displayed
Right-click the graph and select Highlight. Select the signal you want to highlight from the list. Repeat to
highlight another signal.

Remove signal highlight
To remove a highlight from a signal, right-click the graph menu and select Highlight. Select the signal you
want to remove highlight from the list. Repeat to remove highlight from another signal.
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Hide a signal
If the graph is cluttered with many signals obscuring the overview of the signals you want to monitor, you
can hide selected signals from display in the graph. The hidden signal line and corresponding Y-axis will
not be displayed in the graph and the signal legend (if displayed) will be dimmed to indicate that the signal
is not displayed.
You can hide an individual signal or hide all other signals than the individual signal. You cannot hide all signals from the graph. At least one signal must be displayed.

If the signal legend is displayed
To hide a signal from display in the graph, right-click the signal legend you want to hide and select Hide.
To hide all other signals from display in the graph, , right-click the signal legend you want to hide and
select Hide all others.

Display a hidden signal
To display a hidden signal, right-click the dimmed (hidden) signal legend text and select Show.
If multiple signals are hidden, you can display all signals by clicking any signal legend text and select
Show All .
If there are multiple hidden signals, you can right-click any signal legend text and select Show All to display signals in the graph.

If the signal legend is not displayed
Right-click the graph and select Hide. Select the signal you want to display from the list. Repeat to hide
another signal.

Display a hidden signal
To display a hidden signal, right-click the graph menu and select Hide. Select the signal you want to display from the list. Repeat to display another signal.

See Also

"Change the graph appearance" on page 70
"Change signal appearance" on page 69
"Change graph period" on page 63
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Change signal appearance
When a graph is created, a number of default colors and settings are automatically applied to the defined
signals in order to facilitate rapid creation and deployment of usable graphs.
You can change the settings if you want to better align the signal display with your preferences. You can
change...
l

The order of the signals in the chart

l

The signal line color

l

the signal legend text

l

the display of object/atom information in the signal legend

l

the font of all graph texts

To change the signal order

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Signals tab > Object field (left pane of the Signals tab),
select the signal you want to move.
3. Click the Move Up or Move Down buttons to move the selected signal to a new placement in
the list of signals.
4. Click the OK button to save the changes and exit the Graph Properties form

To change the line color of a signal

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Signals tab > Line color field , select a new color from the
drop-down list.
3. Click the OK button to save the changes and exit the Graph Properties form

To define a new signal legend text

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Signals tab > Legend text for signal field , enter a new
text for the signal. The text will be added to the existing object/atom signal legend text.
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You can hide the object/atom signal legend text if you only want to display the new signal
legend text.

3. Click the OK button to save the changes and exit the Graph Properties form

To hide object/atom signal legend text

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Chart tab, clear the Show object/atom information
check box to hide the default object name or description, atom name and measuring range from
the legend text for all signals.
3. Click the OK button to save the changes and exit the Graph Properties form

To change the font of all chart texts

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Chart tab, click the Select Font button to open the Font form
and select a new font, font styles, font size, font color and effects as necessary.
3. Click the OK button to save the changes and exit the Graph Properties form

See Also

"Add or remove a signal" on page 73
"Change the graph appearance" on page 70
"Adjust the Y-Axis for each signal" on page 72
"Graph Properties Form" on page 43
"Set up graph properties" on page 78

Change the graph appearance
When a graph is created, a number of default colors and settings are automatically applied to the graph elements in order to facilitate rapid creation and deployment of usable graphs.
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You can change the settings if you like to better align the chart appearance with your preferences. You can
change...
l

The background color of the graph

l

The X and Y axis text colors

l

The X-Axis line color

l

The grid color

l

The font of all graph texts

l

The display parameters of graph toolbar and status bar

l

Display one Y-axis for all signals with identical measuring ranges

When collecting Y-axes for all signals with identical measuring ranges, it is the measuring range used in
the graph which is used for comparison. If you have adjusted the Y-axis limits for a signal in the Signals tab
> Advanced sub tab, it will be these new Y-axis limits that will be used to determine whether or not the Yaxes contain identical measuring ranges.

To change the color of the graph elements

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Options tab, clear the Use Automatic colors check box
l

In the Background color field, select a new color for the chart background

l

In the Text color field, select a new color for the X and Y-axis values

l

In the Axis color field, select a new color for the X-axis

l

In the Grid color field, select a new color for the chart grid. If you do not want to display the
grid in the chart, select a color that matches the color selected in the Background field.

3. Click the OK button to save the changes and exit the Graph Properties form

To change the font of all chart texts

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Chart tab, click the Select Font button to open the Font form
and select a new font, font styles, font size, font color and effects as necessary.
3. Click the OK button to save the changes and exit the Graph Properties form

To remove the graph toolbar and/or graph status bar

1. In the graph, right-click and select Properties to open the Graph Properties form.
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2. In the Graph Properties form > Options tab:
3. Clear the Display graph toolbar check box to remove the graph toolbar
4. Clear the Display graph statusbar check box to remove the graph statusbar
5. Click the OK button to save the changes and exit the Graph Properties form

Display one Y-axis for all signals with the same measuring range

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Options tab:
3. Select the Auto hide axes with the same value range check box to only display one Y-axis
for all signals with identical measuring ranges.
4. Click the OK button to save the changes and exit the Graph Properties form

See Also

"Change signal appearance" on page 69
"Graph Properties Form" on page 43
"Set up graph properties" on page 78

Adjust the Y-Axis for each signal
You can adjust the Y-axis for each signal, setting the upper and lower limits displayed in the Y-axis.
The Y-axis of each individual signal can also be hidden from display, reducing the number of Y-axes and
reducing potential confusion.

Hide Y-axis for a signal

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Signals tab > Object field (left pane of the Signals tab),
select the signal you want to hide the Y-axis for.
3. Click the Advanced sub-tab and clear the Show Y-axis for this signal check box
To display the Y-axis for the individual signal again, select the Show Y-axis for this signal
check box
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4. Click the OK button to save the changes and exit the Graph Properties form

Change the display range of the Y-axis for a signal

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Signals tab > Object field (left pane of the Signals tab),
select the signal you want to change the Y-axis range.
3. In the Advanced sub-tab :
l

Select the Automatic option to set the upper and lower limits of the Y-axis based on the
object data selected for display in the graph.

l

Select the Limits from object option to use the atom limits (minimum and maximum) of
the object selected as the lowest and highest values on the Y-axis.

l

Select the Fixed limits option to define you own upper and lower limits of the Y-axis in the
Minimum and Maximum fields.

4. Click the OK button to save the changes and exit the Graph Properties form

See Also

"Change the graph appearance" on page 70
"Change signal appearance" on page 69
"Graph Properties Form" on page 43
"Set up graph properties" on page 78

Add or remove a signal
You can add new signals to an existing graph or remove or replace existing signals from an existing graph,
adjusting the signals in either an Operator graph or a Standard Graph.
If you add new signals to an Operator graph, you can save the changed Operator graph as a new graph or
overwrite the existing one. If you add signals to (or edit any graph properties for) a Standard graph, you
can save the changes as an Operator graph.
You can also add objects to existing graphs directly from the Process diagram by using the object menu.
The following atoms are used as signals by default:
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l

Analog object: Actual Value

l

Digital: State

l

Counter: Reset

l

Table: All active table indexes

Add an object to an existing graph in the process diagram

1. In the Supervise module, in the process diagram, open the graph you want to add another object
to.
2. In the process diagram, right-click the object you want to add to the graph for and select Add to
Graph. If multiple graphs are opened, you must select which graph to add the object to.
3. Right-click the graph and select Properties to set up graph properties if necessary
Example
If you need to change the atom used for the signal:

1. In the Graph Properties form, click the Signals tab and select the signal in the left
pane
2. In the Atom field, select another atom to display for the signal.
4. Adjust the graph appearance by using the graph toolbar, graph menu, signal menu, X-axis menu
and the Y-axis menu if necessary.
5. If you want to save the graph as an Operator graph:
l

In the graph toolbar, click the Save button to open the Save As form where you can select a
location and enter a name for the new Operator graph.

Add a new signal

1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Signals tab, click the Add button to open the Object
Browser form.
3. In the right pane of the Object Browser form, locate and select the object you want to add and
click the Open/Select button.
4. In the Basic tab, you can adjust the signal's object atom to be displayed, data source and line
color
5. In the Advanced tab, you can adjust the Y-axis properties for the new signal
6. Click the OK button to save the changes and exit the Graph Properties form

Remove/Replace a new signal
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1. In the graph, right-click and select Properties to open the Graph Properties form.
2. In the Graph Properties form > Signals tab > Object field (left pane of the Signals tab),
select the signal you want to remove.
3. Click the Remove button to remove the selected signal.
4. Click the Replace button to replace the signal with another signal, maintaining the replaced signal's appearance and placement in the signals list
5. Click the OK button to save the changes and exit the Graph Prop

See Also

"Open an existing graph" on page 62
"Graph Properties Form" on page 43
"Set up graph properties" on page 78
"Change signal appearance" on page 69
"Adjust the Y-Axis for each signal" on page 72
"Find an object using Open by Name" on page 23

Create an Operator Graph
You can create your own operator graphs, either creating them from the ground up or using a standard
graph as a foundation, adjusting the graph properties to the graph requirements.
You can create an Operator graph for Analog, Digital, Counter and Table objects only. The following atoms
are used as signals by default:
l

Analog object: Actual Value

l

Digital: State

l

Counter: Reset

l

Table: All active table indexes

You can create an operator graph in the Supervise module:
l

directly from the object menu

l

directly from the object in the Object Watch window

l

using the Graph menu

l

by converting a Standard graph

l

saving an Operator graph as a new Operator graph
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When creating an operator graph, you must also remember to
l

Define the period the graph is to display as a default

l

Define which signals (object atoms) to be displayed in the graph and the appearance of the signals.

l

Define appearance of the graph, such as the graph title, legend properties, fonts, graph colors and
whether to display the toolbar and/or graph status bar.

How to create a new operator graph

From the object menu

1. In the process diagram, right-click the object you want to create a graph for and select Show
Graph to open the Operator Graph.
2. If you want, you can add another object to the operator graph by right-clicking the object and
selecting Add to graph and then selecting the open graph.
3. Right-click the graph and select Properties to set up graph properties if necessary.
4. Adjust the graph appearance by using the graph toolbar, graph menu, signal menu, X-axis menu
and the Y-axis menu if necessary.
5. In the graph toolbar, click the Save button to open the Save As form where you can select a location and enter a name for the new Operator graph.

From the Object Watch window

1. In the Object Watch Window, right-click the object you want to create a graph for and select
Show Graph to open the Operator Graph.
2. Right-click the graph and select Properties to set up graph properties if necessary.
3. Adjust the graph appearance by using the graph toolbar, graph menu, signal menu, X-axis menu
and the Y-axis menu if necessary.
4. In the graph toolbar, click the Save button to open the Save As form where you can select a location and enter a name for the new Operator graph.

From the Graph menu
When you create an Operator graph from the Graph menu, you must select which signals are to be displayed in the graph as well as all other graph properties such as graph periods, signal data source and
chart element colors .

1. In the Supervise module, click Create Operator graph to open the Graph Properties form
1. In the Graph Properties form
2. In the Period tab, define the default graph period
3. In the Signals tab, add the signals to be displayed in the graph as well as the data
source and graph line appearance
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4. In the Chart tab, define the font and placement of the signal legend and the chart
title.
5. In the Options tab, define the colors for chart elements and whether to display the
graph toolbar and status bar.
2. Click the OK button to create the operator graph
3. In the graph toolbar, click the Save button to open the Save As form where you can select a location and enter a name for the new Operator graph.

by converting a Standard graph

1. Open a standard graph in the Supervise module, either by selecting the graph in the Graph
menu or by clicking a descriptor 1 in the process diagram (button, image, graph symbol and
others)
2. Right-click the graph and select Properties to open the Graph Properties form.
3. In the Graph Properties form, change any one of the properties in the tab pages - for example
changing the line color in the Signals tab > Line color field.
4. Click the OK button to save the changes and close the Graph Properties form.
5. In the graph toolbar1, click the Save button to open the Save As form where you can select a
location and enter a name for the new Operator graph.

1 A Standard graph can be set up not to display the Graph toolbar. If the graph toolbar is not displayed, you

cannot save the Standard graph as an operator graph.

by saving an Operator graph as a new Operator graph

1. In the Supervise module, click Graph > Open Operator Graph to select an existing operator
graph.
2. Right-click the graph and select Properties to set up graph properties if necessary.
3. Adjust the graph appearance by using the graph toolbar, graph menu, signal menu, X-axis menu
and the Y-axis menu if necessary.
4. In the graph toolbar, click the Save button to open the Save As form where you can select a location and enter a name for the new Operator graph.

See Also

"Add or remove a signal" on page 73
1 A descriptor is the graphical display of an object. IGSS includes many types of descriptors including: -

Built-in standard symbols - Animated symbols (Symbol Factory library) - Graphics and animation - Drawing
symbols - Windows controls - ActiveX controls An IGSS object can be represented with different descriptors
on different diagrams.
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"Set up graph properties" on page 78
"Graph Properties Form" on page 43
"Additional features with Object Watch" on page 128

Set up graph properties
When creating an operator graph, you must
l

Define the period the graph is to display as a default

l

Define which signals (object atoms) to be displayed in the graph and the appearance of the signals.

l

Define appearance of the graph, such as the graph title, legend properties, fonts, graph colors and
whether to display the toolbar and/or graph status bar.

Define the graph period

1. In the Supervise module, click Graph > Create Operator Graph to open the Graph Properties form.
2. In the Graph Properties form > Period tab > Select display period field , select period to
display in the graph. You can select from the fixed periods or select a custom duration or custom
period.
1. Fixed Duration: Select a fixed (pre-defined) duration in the drop-down list.
2. Custom Duration: Select Custom Duration in the drop-down list.
1. In the Duration field, enter the duration interval and the duration type
(Minutes, Hours, Days, Weeks, Months or Years)
3. Custom Period: Select Custom Period in the drop-down list.
1. In the From date field, select the start date of the graph period.
2. In the From time field, select the start time of the graph period.
3. In the To date field, select the end date of the graph period.
4. In the To time field, select the end time of the graph period.

Select the signal for the graph

1. In the Graph Properties form > Signals tab, click the Add button to open the Object
Browser form
2. In the right pane of the Object Browser form, select the object you want to display in the
graph and click the Open/Select button to add the object to the signals tab.
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1. In the Signals tab > Object field, select the object. It should selected already.
2. On the Basic Tab > Signal Data group:
1. In the Atom field, select the atom to be displayed in the graph.
2. In the Data Source field, select the data source to be used from the dropdown list:
l

Auto: The system selects which data files to use when rendering the
graph lines based on which data files are considered best for the period
being rendered.

l

LOG: The system will only use data from the LOG files to render the
graph lines. If an object atom is not set up to store data in the LOG files,
the graph line will not be rendered.

l

Reduced: The system will only use data from the BCL files to render the
graph lines. If an object atom is not set up to store data in the LOG files,
the graph line will not be rendered.

l

Online: The graph will only use line (direct) object data to render the
graph lines.

3. On the Basic tab > Appearance group:
1. In the Line color field, select the color of the graph line for the selected
signal.
2. In the Legend text for signal field, enter an addition signal text. The signal text will be added to the object/atom in the graph legend.
4. On the Advanced tab:
1. Select the Show Y-axis for this signal check box to display the Y-axis
for the selected signal. If you clear the check box, the Y-axis for the selected signal will not be displayed in the graph.
2. In the Axis limits group, select which axis limits to apply to the Y-axis:
l

Automatic: Let the system determine the lower and upper limits of the
Y-axis based on the available object data.

l

Limits form object: Use the minimum and maximum values defined
for the object atom.

l

Fixed limits: Define custom limits for the graph axis in the Minimum
and Maximum fields.

Define the appearance of the graph

1. In the Graph Properties form > Chart tab > Chart Title field, enter the title of the graph.
The title will be displayed on the top of the graph.
1. Select the Show legend check box to display the legend in the graph.
2. In the Legend Placement field, select where the graph legend is placed (Top, Bottom, Left or Right)
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3. In the For each signal group,
l

Select the Show object/atom information check box to display the object
name, description and atom name in the legend.

l

Select the Show text defined for each signal check box to display the signal
text defined in the Legend text for signal field on the Signals tab.

4. Click the Font button to open the Font form and select the font type, style, color and
size for all texts in the graph.
2. In the Graph Properties form > Options tab:
1. Clear the Use automatic colors check box to define custom colors for the graph elements:
l

Background: Select a color for the graph background

l

Texts: Select a color for the scale values of the X and Y axes.

l

Axis: Select a color for the X and Y axis lines

l

Grid : Select a color for the grid in the graph.

2. Select the Display graph toolbar check box to display the graph toolbar for users.
Clear the check box to hide the toolbar.
3. Select the Display graph statusbar check box to display the graph status bar for
users. Clear the check box to hide the status bar.
4. Select the Auto hide axes with the same value range check box to only display
one Y-axis for all signals that have identical measuring ranges.
3. Click the OK button to create the operator graph.

See Also

"Graph Properties Form" on page 43
"Graph Property Menu" on page 52

Zoom an area in the graph
You can zoom a selected area in the graph, increasing the detail and enabling you to better analyze details
in the graph.
You can continue zooming the graph area, magnifying the graph line and area for increased detail.
To zoom a graph area
l

If the Graph toolbar is displayed in the graph: Click the Zoom in button in the Graph Toolbar

l

If the Graph toolbar is not displayed in the graph: Right-click in the graph window and select
Zoom in. The mouse cursor changes to a crosshair cursor.
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l

l

Select an area in the graph and release the mouse.
l

If you press the Shift key while dragging an area in the graph, you can select a custom
area in the graph, defining which value (Y-axis) and period (X-axis) to be zoomed.

l

If you only drag an area using the mouse, you can only determine which period (X-axis) is
to be zoomed.

The selected area is magnified and a zoom overview window will open in the upper right-hand
corner of the graph displaying the graph area in miniature with the zoomed area.

Drag the zoom area in the zoom overview window to zoom an different graph area.

To zoom out from an area

The zoom out function will zoom out an area one step per application. If you have zoomed in twice, zooming out once will revert one 'zoom in' step.
l

If the Graph toolbar is displayed in the graph: Click the Zoom out button in the Graph Toolbar

l

If the Graph toolbar is not displayed in the graph: Right-click in the graph window and select
Zoom out.

l

The zoomed graph area will be zoomed one step out. If the graph is zoomed back to its original
size, the overview window will be closed.

To return to the original graph
l

If the Graph toolbar is displayed in the graph: Click the Reset Zoom button in the Graph Toolbar

l

If the Graph toolbar is not displayed in the graph: Right-click in the graph window and select
Reset Zoom.

l

The graph area reverts to its original size and the overview window is closed.

See Also

"The Graph Toolbar" on page 50
"Graph Properties Form" on page 43
"Graph Property Menu" on page 52

Compare two graph periods
You can compare the present graph trend with the graph trend for another period for the same set of signals
in order to detect similar historic trends and developments.
The original graph period will be displayed in the lower section of the graph while the other graph period
will be displayed in the upper section. The Y-axis will be split into the two sections, enabling visual orientation of the graph lines.
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It is a good idea to hide all other non-relevant signals when comparing periods in order to cut down the amount of visual clutter and distractions. You
can always display he hidden signals again when you are done comparing
the periods.
Comparing periods

A precondition when comparing trends is always that the basis for comparison is available and common to
both trends. You must have access to object data for both periods and the data must be comparable. If your
configuration is set up to delete LOG data that is older than 3 months, then comparing two signals using
LOG data will not yield the same degree of veracity when comparing data older than 3 months. Often, the
system will attempt to retrieve the BCL data values when querying for the period if these are the only values retrievable. This is because BCL data is often but not always maintained longer than LOG data
Likewise, if you are comparing a signal using BCL data to the same signal using LOG data, results might be
skewed as BCL data is aggregated and averaged data values and LOG data is (often) absolute data values.
Finally, if data storage settings are changed on the object atom, comparing two periods may also yield
potentially different results, depending on when the data storage setting changes were made.
To compare two graph periods
l

If the Graph toolbar is displayed in the graph: Click the Compare Period button in the Graph
Toolbar

l

If the Graph toolbar is not displayed in the graph
l

Right-click in the graph window and select Compare Period or

l

Right-click the X-axis and select Compare Period

The graph area will be split into two seamless sections, the upper section which can be scrolled individually
and the lower section which is scrolled together with the upper section.
To compare periods, scroll the lower graph section back to the period you want to compare. You can zoom
in and zoom out as well as hide other signals in the graph to remove non-relevant graph lines.
You can also shift the upper section by only scrolling the upper section of the graph, moving it backwards
or forwards to compare the graph trend in other periods with the lower section.

The upper section can be scrolled seamlessly, making it easy to scroll back
and forth. This also makes it easy to lose alignment with the lower section,
making further comparison difficult. To restore the alignment between the
upper and lower sections of the graph, click the Single Period button to
remove the period comparison and then click the Compare Period button
again to compare periods once again.
The upper and lower sections will now be aligned correctly on top of each
other.
To restore the original (single period) graph
l

If the Graph toolbar is displayed in the graph: Click the Single Period button in the Graph
Toolbar
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l

If the Graph toolbar is not displayed in the graph:
l

Right-click in the graph window and select Single Period

l

Right-click the X-axis and select Single Period

The split graph area will revert to one graph area, displaying the original graph signal and line.
See Also

"Graph Property Menu" on page 52
"Compare X-Axis Property Menu" on page 59
"Y-Axis Property Menu" on page 57
"Graph keyboard shortcuts and Mouse combinations" on page 60

Print a Graph
You can send the graph presently displayed in the graph window to a connected printer by clicking the
Print button in the graph toolbar.
If the graph toolbar is not displayed, you can right-click the graph and select Print.
Both methods will open the Print form where you can
l

Select the printer to send the graph to

l

Send the graph print to a file

l

Define the print range

l

Define the number of copies to send to print

l

Set up additional properties for the selected printer

See Also

"The Graph Toolbar" on page 50
"Graph Property Menu" on page 52

Save an Operator graph
When you have created your own operator graph, either from the ground up or using a Standard graph or
another Operator graph as a foundation, you can save your changes to either create a new Operator graph
or overwrite an existing graph.

Operator graphs are not write-protected from IGSS and any operator may edit and over-write existing
operator graphs.
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Standard graphs cannot be overwritten as any changes to the Standard graph must be saved from the
Definition module.
Any operator can make changes to a Standard graph and then save the graph as an Operator graph.

l

If the graph toolbar is displayed: Click the Save button to open the Save As form.

l

If the graph toolbar is not displayed: Right-click the graph and select Save to open the Save As
form.

If you are saving changes to an existing operator graph and want to overwrite it, find and select the graph,
make sure the graph name is correct in the File name field and click the OK button.
If you want to save a new Operator graph or a new version of an existing operator graph, enter a new name
in the File name field and click the OK button.
See Also

"Create an Operator Graph" on page 75
"Open an existing graph" on page 62
"Change the graph appearance" on page 70
"Change signal appearance" on page 69
"Change graph period" on page 63
"Add or remove a signal" on page 73
"Set up graph properties" on page 78
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Chapter 8: Working with Reports
8.1 Form Help
The Report Formats form
Use this form to create Operator reports in the Supervise module.

Overview
The Report formats form is split into two panes. The left pane contains a tree-view of the existing Operator reports in the configuration. You can see the report headings in each report by
clicking the [+] button to expand the report.
The right pane of the Report Formats form contains an overview of the objects placed under a
report heading. To view the objects, expand the report headings in the left pane and select a
report heading. The right pant will display all objects under that heading as well as the area in
which the object is defined and the data reduction method.
Each report type is displayed with the following icons:
l

A blue report format is an alarm statistics report

l

A burgundy report format is a periodical report

l

A light red report format is a snapshot report

The default report format for each report type is clearly marked with a D.

You can right-click in the right pane to delete an object, reset the
object properties or open the Object Browser or Manual
Report Object form.
You can right-click in the left pane to add or edit reports and/or
report headings as well as delete reports and report headings. You
can also clean the report and set the report as a default.

Preconditions
The IGSS configuration must be started and the IGSS DataServer must be running in order to
create and subsequently run any Operator reports..

Where do I find it?
In the Supervise module, click Tools > Operator Reports format to open the form.

Field /button help
Field name

Field Group

Description

Create

Report
Format

Click this button to open the Report Format Properties form
to create a new report.

Edit

Clean

Report
Format

Report
Format

Click this button to open the Report Format Properties form
to edit an existing report.
You can change the name of the format and enable or disable
the Set as default option.
Click this button to remove all objects that are no longer
defined in the configuration from the selected report.
A confirmation message will appear.

Delete

Report
Format

Click this button to delete the selected report.
A confirmation message will appear.
Click this button to open the Report Heading Properties
form to create a new report heading in the selected report.

Create

Report heading
By default, the report headings are sorted alphabetically.
However, you can change this by dragging the report heading
to the desired position.

Edit

Report head- Click this button to open the Report Heading Properties
ing
form to edit an existing report heading in the selected report.

Delete

Click this button to delete the selected report heading and all
Report headits associated objects for the selected report. A confirmation
ing
message will appear.

Browse

Chosen
objects

Click this button to open the Object Browser form to locate
and add an IGSS object to the report heading of the selected
report. You can add an object to the report heading by selecting the object in the Object Browser form and dragging the
object into the right pane of the Report Formats form.
Note
You must select the report heading in the left pane of the
Report Format form before clicking this button.

Manual

Chosen

Click this button to open the Manual Report Object form to

Field name

Field Group

Description

locate and add a manual report object to the report heading of
the selected report.
You can add an object to the report heading by selecting the
object in the Manual Report Object form and dragging the
object into the right pane of the Report Formats form.
objects

Note
You must select the report heading in the left pane of the
Report Format form before clicking this button.
Manual report objects can only be created in the Definition
module.

Delete

Description

Chosen
objects

Properties
for selected
objects

Click this button to remove the selected object from the report
heading.
Displays the object description that will appear in the report
for the selected object. The description is defined for the
object in the configuration but you can replace this with your
own object description in this field if required.
Note
To reset the description used for the object in this report unit,
click the Reset Properties button.

Unit

Properties
for selected
objects

Displays the unit that will appear in the report for the selected
object. The unit is defined for the object in the configuration
but you can insert your own unit designation in this field if
required.
Note
To reset the unit designation used for the object in this report
unit, click the Reset Properties button.

Decimals

Properties
for selected
objects

Displays the number of decimals used for displaying the object
values in the report for the selected object. The number of
decimals is defined for the object in the configuration but you
can replace this with your own number of decimals in this field
if required.
Note

Field name

Field Group

Description

To reset the number of decimals used for the object in this
report unit, click the Reset Properties button.
Properties
Reset Propfor selected
erties
objects

Click this button to reset the description, unit and number of
decimals to the values defined for the selected object in the
configuration.
Select this check box to display the actual total report value or
idealized total report value in periodical reports for the selected object(s).

Total

Show values
If you only select this check box, you get the actual total value.
If you also select the Idealized total check box, you will get
the idealized total value.
Select this check box to display the idealized total report value
in periodical reports for the selected object(s).

Total idealized

Show values

This check box is only accessible if you have selected the
Total check box.
This option is only available for periodical reports.

Reduced

Show values

Select this check box to display the reduced report value in
periodical reports for the selected object(s). The reduced value
in the report will be calculated using the same data reduction
method which was included in the report.
This option is only available for periodical reports.

Std. Dev.

Show values

Select this check box to display the standard deviation report
value in periodical reports for the selected object(s).
This option is only available for periodical reports.

OK

Click this button to save your report and close the form.

Cancel

Click this button to close the form without saving any changes
made in this form.

See Also

"Create an Operator report" on page 97
"Create a report heading in an Operator report" on page 98

"Clean an Operator Report" on page 105
"Add an IGSS object to an Operator report" on page 98
"Add a manual report object to an Operator report" on page 99
"Delete an Operator Report" on page 104
"Delete a report heading in an Operator report" on page 104
"Delete an object in an Operator report" on page 105
"About Operator Reports" on page 93
"About Report Values" on page 95

The Report Format Properties form
Overview
Use this form to create or edit Operator report properties.
When you create an Operator report, you must select the report type. Once an Operator report
type has been selected, you will not be able to change the type afterwards.

Preconditions
The Report Formats form must be open in order to open this form.

Where do I find it?
You can access this form from the Report Formats form by clicking the Create or Edit buttons
in the Report Format group.

Field Help
Field name

Description

Format name

Type the name of the report format. This is the name that the
operator sees when choosing a report to print.

Set as default

Select this check box to set the selected report as the default
report for that report type (Periodical, Snapshot or Alarm Statistics).

Field name

Description

The default report format will be suggested automatically to the
operator when he opens the associated reporting program.

Periodical report

Select this check box to create a report format to be used for
periodical reports. A periodical report is a daily, weekly,
monthly, quarterly or yearly report.
You cannot change the report type of an already existing Operator report.

Snapshot report

Select this check box to create a report format to be used for
snapshot reports. A snapshot report contains the current process
values for the selected objects.
You cannot change the report type of an already existing Operator report.

Alarm Statistics report

Select this check box to create a report format to be used for
alarm statistics reports. This type of report can also be generated by choosing File, then Alarm Statistics in the Alarm program.
You cannot change the report type of an already existing Operator report.

OK

Click this button to save your report properties and close the
form and return to the Report Formats form..

Cancel

Click this button to close the form without saving any changes
made in this form and return to the Report Formats form.

See Also

Periodical report
Snapshot report
Alarm statistics report

The Report Heading Properties form
Overview

Use this form to create and edit a report heading.

Preconditions
The Report Formats form must be open in order to open this form. You must select a report in
the left pane of the Report Formats form before creating a new report heading and you must
select the report heading you want to edit if you are editing a report heading.

Where do I find it?
You can access this form from the Report Formats form by clicking the Create or Edit buttons in the Report Format group.

Field Help
Field name

Description

Heading text

Type the text you want to appear as a heading in the report. By
default, the report headings are sorted alphabetically, but you can
change the sequence in the Report Formats dialog box, if required.

Start on new page

Check this box to insert a page break before this report heading.

OK

Click this button to save your report heading properties and close
the form and return to the Report Formats form.

Cancel

Click this button to close the form without saving any changes made
in this form return to the Report Formats form.

Manual Report Object form
Overview
Use this form to select manual report objects to add to your Operator report.
The form lists all manual report objects that have been created for the configuration. Manual
Report Objects are created in the Definition module but are accessible in this form.

Preconditions
The Report Formats form must be open in order to open this form. You must select a report
heading in the left pane of the Report Formats form before adding manual report objects to
the report heading.

Where do I find it?

You can access this form from the Report Formats form by clicking the Manual buttons in the
Chosen object group.

Field Help
Field name

Description

Always on top

Select this check box to force this dialog box to stay on top of other
windows.

Close

Click this button to close this form

8.2 Use the reporting facilities
The IGSS Reporting System is a set of programs designed to help the system designers and
plant operators in defining the formats of the plant reports and viewing and printing different
types of reports about the plant situation.
The IGSS Reporting System consists of these three report formats:
l

Operator reports

l

Custom reports

l

Standard reports

Custom Reports
Custom reports are created, edited and maintained in Microsoft Excel 2007 or 2010 but are
saved in the Report folder defined for the configuration in the System Configuration form
> Configuration tab . Saved Custom reports are therefore also accessible to all operator stations that access the IGSS server configuration.
Custom reports contain less design restrictions than Standard and Operator reports and can be
designed to cover nearly any aspect of the IGSS configuration, even retrieving data values from
other IGSS configurations and foreign data sources.
MS-Excel is used to format and prepare report data and can be used to render the report, either
as a preview or a print.
For more information, click the Reports help in IGSS Master > Help navigation pane.

Standard and Operator Reports
Standard and Operator reports are nearly identical and the method of creation and editing a
Standard or Operator report is nearly identical. Both use the Report Formatsform to create
and edit the report and both report formats have clearly defined functionality. Both reports use
the Report parameters defined in the System Configuration form > Reports tab.
l

Standard reports are created and edited in the Definition module only. They allows a
System Designer to create system-wide reports that all operators can use but cannot
edit or delete by mistake.

l

Operator reports are created and edited in the Supervise module only. Operator
reports are accessible from the Supervise Module and all operators can create, edit
and delete any Operator report from the Supervise Module.

Standard and Operator reports must be one of the three report types listed below:
l

Periodical report

l

Snapshot report

l

Alarm statistics report

Additionally, you can add manual report objects to your Standard and Operator reports, expanding the reporting functionality to include objects that are not actively monitored or scanned by
IGSS. Data values from manual report objects must be entered manually.

8.3 About Operator Reports
Operator report functionality enables an operator to quickly create and run a variant of Standard reports from the Supervise Module in order to gain a better overview of the monitored process and the object values in the process.
Using Operator reports, the operator is given access to a report-creation system which enables
the creation and printing of reports on the fly as the need for reporting arises. Once the need for
the report is passed, the Operator report can be deleted. An Operator report can also be
retained for future use or converted to a Custom Report if required.
Any operator may create Operator reports as well as edit and delete existing Operator reports.

Location of Operator report formats
When you create an Operator report, the report format will be saved in the STD folder in the
IGSS Report folder defined in the System Configuration form > Configuration Tab. Like
other report formats, you can set up an alternative report folder for all your reports in the
System Configuration form.

The Operator reports will be accessible to all operator stations that access the Report folder of
the IGSS server they connect to.
The Operator report format is saved as a normal text file with a GUID name and.FMT extension.
Although you can open the file in an text editor, any edits to the Operator report must be made
through the Supervise module in IGSS.
In a Dualized-Server set-up, each report folder will be duplicated on the two servers and synchronized in the same procedure as Standard reports are synchronized.

Running an Operator report
Like all IGSS reports, you can run an Operator report from the IGSS Master > Reports Navigation pane, but since the IGSS DataServer is used to access all Operator reports, the IGSS
Dataserver application must be running for the Operator reports to be accessible in the Reports
Navigation pane. This means the IGSS configuration must be started in order to access any
reports in the configuration.
You can also run the Operator Report as a batch job or through the Job Scheduler. You can
apply the same command line parameters to the Operator Report as you can to a Standard
Report.

Differences between Standard and Operator reports
Standard and Operator reports are nearly identical and share the same report creation process
and forms, but there are differences between the two report types.
l

Standard reports are created in the Definition module and must be edited and deleted
from the Definition module. Standard reports cannot be edited or deleted from the
Supervise module. This allows a System Designer to create system-wide reports that
all operators can use but cannot edit or delete by mistake.

l

Operator reports are created in the Supervise module and can only be edited and
deleted from the Supervise module. Operator reports cannot be edited or deleted from
the Definition module. Because Operator reports are accessible from the Supervise
Module, operators can create, edit and delete any Operator report from the Supervise
Module.

Both report types display reduced object values (BCL data) in the Periodic report while the
snapshot report uses actual, real-time object values.

Operator Report types
There are three types of Operator reports:
l

Periodical report

l

Snapshot report

l

Alarm statistics report

Each report type is displayed with the following icons:
l

A blue report format is an alarm statistics report

l

A burgundy report format is a periodical report

l

A light red report format is a snapshot report

The default report format for each report type is clearly marked with a D.

8.4 About Manual Report Objects
A manual report object is an object that does not have a direct connection to a PLC and thus is
not monitored directly by IGSS.
Object values for Manual Report Objects are entered manually through the Manual Report
Editor form found in the IGSS Master > Home Tab > Manual Report Editor button.
A Manual Report Object can be included in any Standard or Operator periodical report once it
has been created.

8.5 About Report Values
In addition to the reduced object values, you can select to display four report values when creating a periodic Operator report:
l

Total: A simple sum of all hourly values

l

Total Idealized:The average of the hourly values multiplied by 24.

l

Reduced: Re-uses the data reduction method selected for the object.

l

Standard Deviation: The standard deviation based on the Actual values and the Average value for the object.

The report values refer to the Transfer to History settings for each object in the configuration
and use the reduced hourly object values that have been transferred to the HDM database.

8.6 Create Operator Reports
Any operator can create Operator reports from the Tools menu in the Supervise module but
the configuration must be started in order to create Operator reports.
Operator reports are saved in the Report folder specified for the IGSSS Server in the System
Configuration form and therefore available to all operator stations that connect to the IGSS
server.

When creating a new Operator report, you must define a name for each report and determine
the report type (Snapshot, Periodical or Alarm Statistics report). The report type will determine
what types of IGSS object data you can display in your Operator report.
To create a new Operator report, you must go through the following steps:
Create the report

Create a new Operator report format in the Report Formats form, defining a name and setting
the report type (Periodical, Alarm Statistics or Snapshot). You can also set the report as the
default report for the selected report type.
Create the Report headings

Once you have created the report, you must create at least one report heading to contain the
IGSS objects.
The Operator report format consists of a number of user-defined headings where you can place
the IGSSobjects you want displayed in the report. You can define any number of report headings in order to provide a better overview of a report, assigning IGSSobjects to each report
headings, but you must have at least one heading in order to add IGSSobjects to the report.
Add objects to the report

Add any IGSS objects or Manual Report Objects to your report using the Object Browser or
the Manual Report Objects forms.
Individual IGSS objects are added to the report by dragging the object from the Object
Browser form into the Report Formats form and individual manual report objects are added
to the report by dragging the object from the Manual Report Objects form into the Report
Formats form.
The item Current value or state can only be used in Snapshot or Alarm Statistics reports.
The data reduction method(s) can only be used in Periodical reports.
Adjust the object display settings

The key properties for the IGSS object (Description, Unit and Decimals) are automatically
imported into the report format, but can be changed, if necessary.
You can determine which report value(s) to display for each IGSS object in the report such as.
l

Total

l

Idealized total

l

Reduced value

l

Standard deviation

Save the report

Click the OK button in the Report Formats form to save the report. The report will be created
in the report folder specified for the IGSS server in the System Configuration form > Configuration tab and made available to all operator stations in the IGSS Master.

See Also
"About Manual Report Objects" on page 95
Periodical report
Snapshot report
Alarm statistics report
"About Report Values" on page 95

Create an Operator report
To create a new Operator report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form
2. In the Report Formats form > Report format group, click the Create button to
open the Report Format Properties form.
3. In the Format name field, enter the name of the report format. This is the name
that the operator will see when he runs the report from the IGSS Master.
4. Under Report type, select the relevant report type (Periodical, Snapshot or Alarm
statistics report)
5. Select the Set as default checkbox if you want the report format to be suggested
as the default format to the operator.
Only one report format can be set as default per report type. The default report
format will be clearly marked with a “D” in the Report Formats form.

6. Click the OK button to create the new Operator report and close the Report Format
Properties form. The The new report name appears in the left pane of the Report
Format form.

See Also

Periodical report
Snapshot report

Alarm statistics report

Create a report heading in an Operator report
To create a report heading in an Operator report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form
2. In the left pane of the Report Formats form, select the report you want to create a
report heading in.
3. Click the Create button in the Report Heading group to open the Report Heading Properties form.
4. In the Heading Text field in the Report Heading Properties form, enter the
name of the report heading.
Select the Start on new page check box if you want to insert a new page in the
report when the heading is encountered.

5. Click the OK button to create the report heading and close the Report Heading
Properties form.
6. Click the OK button in the Report Formats form to save the report and close the
form.

Add an IGSS object to an Operator report
An object can only be placed under a report heading in an Operator report. If your report does
not contain at least one report heading, you must create one prior to adding an object to the
report.
To add an IGSS object to an Operator report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form.
2. In the left pane of the Report Formats form, select the report you want to create
an IGSS object in.
3. Click the [+ ] button to expand the report headings in the report and select the heading you want to create the IGSS object in.

4. Click the Browse button in the Chosen objectsgroup to open the Object
Browser form.
5. In the Object Browser form, find the object you want to add to the report and drag
the object and it's data reduction method to the right pane of the Report Formats
form.
In the Properties for selected objects group, you can define which report values
(Total , Total Idealized, Reduced and/or Standard Deviation) to include in the
report as well as edit the object properties (Description, Unit and Decimals) for
each individual object data reduction method.
You can continue to drag objects from the Object Browser form to the Report
Formats form until you have added all the objects you want to the report.

6. Click the Close button to close the Object Browser form and return to the Report
Formats form.
7. Click the OK button in the Report Formats form to save the report and close the
form.

The current object value or state can only be used in Snapshot or Alarm Statistics reports.
The data reduction method(s) can only be used in Periodical reports.
See Also

Periodical report
Snapshot report
Alarm statistics report
"About Report Values" on page 95

Add a manual report object to an Operator report
An object can only be placed under a report heading in an Operator report. If your report does
not contain at least one report heading, you must create one prior to adding an object to the
report.
To add a manual report object to an Operator report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form.
2. In the left pane of the Report Formats form, select the report you want to create
an IGSS object in.
3. Click the [+ ] button to expand the report headings in the report and select the heading you want to create the IGSS object in.
4. Click the Maual button in the Chosen objectsgroup to open the Manual Report
Object form.
5. In the Manual Report Object form, find the object you want to add to the report
and drag the object and it's atom to the right pane of the Report Formats form.
You can define which report values (Total , Total Idealized, Reduced and/or
Standard Deviation) to include in the report as well as edit the object properties
(Description, Unit and Decimals) for each individual object atom in the Properties for selected objects group in the Report Formats form.
You can continue to drag objects from the Manual Report Object form to the
Report Formats form until you have added all the objects you want to the report.

6. Click the Close button to close the Manual Report Object form and return to the
Report Formats form.
7. Click the OK button in the Report Formats form to save the report and close the
form.

You cannot create manual report objects through the Supervise module, If you need to create
manual report objects, you must use open the Manual Report object form from the Report
formats form found in the Definition module > Edit > Report Formats.
See Also

"About Report Values" on page 95

8.7 Edit an Operator Report
Operator Reports can only be edited from the Supervise module. The configuration must be
started in order to edit an Operator Report.
To edit an existing report:
l

Open the Supervise module and click Tools > Operator Report formats to open
the Report Formats form.

l

In the right-hand pane of the Report Formats form, select the report you want to edit.

Edit the report format
l

Click Report Format group > Edit button to open the Report Format Properties
form and edit the name and default setting of the selected report.

Edit a report heading
l

In the right-hand pane of the Report Formats form, select the report you want to edit
click the [ + ] top expend the headings of the report.

l

Select the heading you want to edit and click the Report Heading group > Edit button
to open the Report Heading Properties form to edit the name of the report heading
and set the Start on new page check box if necessary.

l

To add a new report heading, click the Create button in the Report Heading group to
open the Report Heading Properties form.

l

To delete a report heading, click the Delete button in the Report heading group. If
you delete a report heading, all objects contained in the report heading will also be
removed from the report.

Edit an object in the report
l

In the right-hand pane of the Report Formats form, select the report you want to edit
click the [ + ] top expend the headings of the report.

l

Select the heading which contains the object you want to edit and select the object in
the right pane of the Report Formats form.

l

In the Properties for selected objects group, make the required changes to the
selected object properties.

l

To add a new IGSS object to the report heading, click the Browse button in the
Chosen Objects group to open the Object Browser form where you can locate the
new IGSS object. Drag the object into the report heading to add it to the report.

l

To add a new manual report object to the report heading, click the Manual button to
open the Manual Report Object form. Drag an existing manual report object into the
report heading to add it to the report. You can also create a new manual report object
and drag it into the report heading.

l

To delete an object, select the object and click the Delete button in the Chosen
Objects group.

Save the report
l

When you have completed your edits, click the OK button in the Report Formats form
to save the changes and close the form.

Edit an Operator Report
To edit an existing Operator Report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form
2. In the left pane of the Report Formats form, select the report you want to edit
3. Click the Edit button in the Report Format group to open the Report Format
Properties form.
4. In the Format name field, change the name of the report format. This is the name
that the operator will see when he runs the report from the IGSS Master.
Select the Set as default checkbox if you want the report format to be suggested
as the default format to the operator.
Only one report format can be set as default per report type. The default report
format will be clearly marked with a “D” in the Report Formats form.

5. Click the OK button to close the Report Format Properties form.
6. Click the OK button in the Report Format form to save the changes and close the
form.

Edit a report heading in an Operator report
To edit an existing report heading in an Operator report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form
2. In the left pane of the Report Formats form, select the report which contains the
report heading you want to edit.
3. Click the Edit button in the Report Heading group to open the Report Heading
Properties form.
4. In the Heading Text field in the Report Heading Properties form, you can
change the name of the report heading.
Select the Start on new page check box if you want to insert a new page in the
report when the heading is encountered.

5. Click the OK button to create the report heading and close the Report Heading
Properties form.
6. Click the OK button in the Report Formats form to save the changes and close the
form.

Edit an object in the Operator report
You can edit an object in the Operator report. the procedure is the same regardless of the object
type (IGSS object or manual report object)
To edit an object in an Operator report

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form.
2. In the left pane of the Report Formats form, select the report you want to edit an
object in.
3. Click the [+ ] button to expand the report headings in the report and select the heading which contains the object you want to edit.
4. In the right pane of the Report Formats form, select the object you want to edit.
5. In the Properties for selected objects group, you can change the report values
(Total , Total Idealized, Reduced and/or Standard Deviation) as well as edit
the object properties (Description, Unit and Decimals) for each individual object
data reduction method.
6. Click the OK button in the Report Formats form to save the report and close the
form.

Change order of the objects

You can change the placement (sorting order) of the objects in a report heading by selecting
the object in the right pane of the Report Formats form and dragging it to a new position.
See Also

"About Report Values" on page 95

8.8 Delete an Operator Report
Operator Reports and their elements (headings and objects) can only deleted from the Supervise module.
The configuration must be started in order to delete an Operator Report.

Delete an Operator Report
Operator Reports can only deleted from the Supervise module. The configuration must be started in order to delete an Operator Report.
To delete an existing report:

1. Open the Supervise module and click Tools > Operator Report formats to open
the Report Formats form.
2. In the right-hand pane of the Report Formats form, select the report you want to
delete.
3. Click the Delete button to delete the selected report.
4. Click the OK button to confirm the delete and close the Report Formats form. The
Operator report format will be removed from the Reports Navigation pane in theIGSS
Master.

Delete a report heading in an Operator report

To delete a report heading

1. Open the Supervise module and click Tools > Operator Report formats to open
the Report Formats form.
2. In the left pane of the Report Formats form, select the report which contains the
heading you want to delete
3. Click the [+ ] button to expand the headings of the report.
4. In the left pane of the Report Formats form, select the heading you want to delete
and click the Delete button in the Report heading group. If you delete a report
heading, all objects contained in the report heading will also be removed from the
report.
5. Click the OK button in the Report Formats form to save the changes and close the
form.

Delete an object in an Operator report

To delete an object in the report

1. Open the Supervise module and click Tools > Operator Report formats to open
the Report Formats form.
2. In the left pane of the Report Formats form, select the report which contains the
object you want to delete.
3. Click the [+ ] button to expand the headings of the report.
4. In the left pane of the Report Formats form, select the heading which contains the
object you want to delete and select the object in the right pane of the Report
Formats form.
5. Click the Delete button in the Chosen Objects group.
6. Click the OK button in the Report Formats form to save the changes and close the
form.

8.9 Clean an Operator Report
You can remove all objects that are no longer in the associated configuration,cleaning the Operator Report that uses the removed objects.
To clean an existing report:

1. Open the Supervise module and click Tools > Operator Report formats to open
the Report Formats form.
2. In the right-hand pane of the Report Formats form, select the report you want to
clean.
3. Click Report Format group > Clean button to open the Clean Report Format dialog.
4. Click the Yes button to clean the report and close the Clean Report Format dialog.
5. Click the OK button in the Report Formats form to save the changes and close the
form.

Chapter 9: Viewing Object Data and Events
9.1 IGSS Playback
About IGSS Playback
IGSS Playback allows you to view the entire monitored process for a specific period of time in
the past (the Playback interval), effectively replaying the monitored process for all important
elements.
IGSS Playback uses historical data taken from LOG data as input for the objects in the diagrams, allowing you to observe how the entire system reacted to the log data changes as
opposed to data mining the log data to see how individual objects reacted. Objects that have
not been set up to save LOG data will not be displayed when using the IGSS Playback functionality. If you want to use the IGSS Playback functionality, you must make sure to save key
object values as LOG data.
IGSS Playback gives you a wider perspective and a larger picture to observe log process data,
the conditions prior to an event and the consequences after an event as displayed in the process diagrams.
You must define the start and end times to be replayed (the Playback interval), and you can
adjust the playback speed, pause the playback, skip forwards or backwards and redefine the
playback interval as you go.
IGSS Playback is a view-only option, displaying log data only. You cannot interact with the playback interval, for instance changing object values or states to model a different outcome.
The IGSS Playback functionality uses the IGSS Player form to define the playback interval
period and to manage the playback process.
Changes to IGSS when the IGSS Player is running

When the IGSS Player form is running the playback interval, the Active Alarm and Event list
forms will be displayed with a red background instead of the normal white background. All
events listed in the Event list forms will be emptied while the Active Alarm list will be populated with historical alarm data from the Alarm Log files. If you need to access the active
alarms during playback, you can set up the alarm module to display real-time active alarms in
the Active Alarm form during playback in the System Configuration form.
All diagrams in Supervise are displayed with a semi-transparent red mask and all object values
will be displayed with three question marks “????” which indicate that the object values are
unknown. Object values will be populated with the LOG data values they had at the start of the
playback interval when the IGSS Player form is started. Object values that cannot be loaded
from the log data will be displayed with three question marks “????” throughout the playback
interval.

All menus, toolbars and dialog boxes where commands to the system or to objects can be
entered or sent are disabled.
All widgets in the IGSS Dashboard will be closed and the Dashboard will indicate that IGSS is
running in Playback mode.
Graphs opened in the Supervise module will display LOG data values up to the start of the
playback interval but the graph data values and display will not be updated dynamically when
the IGSS Player form is running the playback interval.
Even though the IGSS Player form is running the playback interval, important and vital IGSS
functionality will not be impacted by the IGSS Player form. All applications (including 3rd
party applications and VBA applications) which have started normally on the IGSS Server will
continue to run after the IGSS Player form is started.
IGSS Servers and single-user stations will continue to collect data and perform calculations
even when the IGSS Player form is running and IGSS operator stations will still be connected
to the IGSS Server.
All external interfaces of IGSS (such as Maintenance, Notifier, Alarm Management) are not
affected when IGSS Player form is running the playback interval. The external interfaces can
still access online data, including alarms triggered by online data. Alarms are still registered in
IGSS and will be displayed in the Active Alarm form when playback stops.
Disturbing the IGSS Player form

When the IGSS Player form is running the playback interval, be aware that certain actions will
cause the form to stop the playback.
l

If the IGSS station is stopped and closed down, the IGSS Player form will also stop
and close.

l

If data collection in IGSS is stopped, the IGSS Player form will stop. Once data collection is restarted, the form not resume playback and must be restarted.

l

If you update (edit, submit changes to) the IGSS configuration when the IGSS Player
form is running, the form will stop playback of the playback interval. When the update is
finished, the IGSS Player form will not resume playback and must be restarted.

l

If the IGSS Player form is running a playback interval on an operator station and the
connection to the IGSS server is lost, the form will stop running. When the connection
to the IGSS server is restored, the the form will not resume playback and must be restarted.

l

If the IGSS Player form is running a playback interval on an operator station and a
new connection to another IGSS server is set up, the form will stop running. When the
new

l

connection to the IGSS server is enabled, the form will not resume playback and must
be restarted.

See Also

"Display alarms in the Active Alarms form during playback" on page 114

IGSS Playback forms
The IGSS Player form
Use the Player form to display historical IGSS data in the Supervise process diagrams, gaining
an overview of the system values and displays during the playback interval.

Overview
You can define the period which you want to replay critical events and adjust the playback
speed to closely monitor the controls and objects in the diagrams or you can speed up the
replay speed to see the entire process unfold rapidly.
When the IGSS Player form is started, log data is loaded sequentially, starting from the
defined start date and start time. Log data is loaded in one hour chunks at a time and the progress of the entire playback interval is displayed in the Period slider bar in the middle of the
form.
When you use the IGSS Player form to display log data in the process diagrams of Supervise,
IGSS will enter Playback mode. When IGSS is in Playback mode, the process diagrams in Supervise will change appearance and display the log data, but data will still be collected from the
online monitored process.
Closing the IGSS Player form will bring IGSS back into the mode the application was in when
the IGSS Player form was opened, either Runtime or Design mode.

IGSS Player status
IGSS Player form status is displayed in the left-hand bottom of the form. There are the following IGSS Player status:
l

Ready

l

Stopping

l

Reading LOG values

l

Loading Configuration

l

Awaiting IGSS Start

Using the IGSS Player form and Multimedia keyboards
If you have a multimedia keyboard, you can use the multimedia buttons in addition to the normal keyboard shortcut keys described below.

Preconditions
None

Where do I find it?
Click the IGSS Master > Home tab> Player Button to open the IGSS Player form.

Field Help
Field name

Description

Click this button to change the status of the IGSS Player.The
button color displays the current IGSS Player status.
There are three status levels:
l

Status Button
l

l

Select Period

Off /Offline (Gray): IGSS is not presently running.
IGSS Playback functionality is not available and the
IGSS Player form is dimmed.
On/Online (Green): IGSS is running in normal mode
(runtime or Design mode). IGSS Playback functionality is available and the IGSS Player form can be
used. The IGSS Player is not running.
Replay/Running/Playback (Red): IGSS is running in
Playback mode and the IGSS Player is running, displaying the log data in the diagrams in Supervise.

Click this button to open the Select Period form to select the
period you want the IGSS Player to display.
Click the plus [ + ] button to increase the playback speed by
one speed level and click the minus [ – ] button to decrease
the playback speed by one speed level. You can also press the
+ or – keys to increase or decrease the playback speed.

Player speed
The available playback speeds are displayed in the drop-down
field in the middle of the button area. You can select any playback speed by opening the drop down box in the button area
and selecting the playback speed.

Field name

Description

Playback Speed examples:
l

l

l

l

l

1/10: Ten minutes are used to replay one minute of
LOG data. Ten minutes are used to display one minute
of LOG data.
½: The playback speed is half as fast as the log data
was registered. Two minutes are used to display one
minute of LOG data.
1: The playback interval is displayed at the same
speed as the log data was registered.
2: The playback speed is twice as fast as the log data
was registered. 30 seconds are used to display one
minute of log data.
10: The playback speed is ten times as fast as the log
data was registered. 6 seconds are used to display one
minute of log data.

The last used playback interval is automatically loaded when
the IGSS Player form is opened.
On Top Check Box

Select his check box to always display the IGSS Player form
on top of all other forms.

Present time

The present time of the playback interval is displayed in the
middle of the form.
Click and drag the slider to display the values and objects in
the diagrams for the selected time. The slider bar also displays the status of the data being loaded into the IGSS Player.
Keyboard short cut keys :
l

Period Slider bar

l

l

Press the left/right keys or page up / page down keys
to move the slider left or right.
Press the Home key to move the slider to the beginning of the slider bar.
Press the End key to move the slider to the end of the
slider bar.

Slider bar colors:
l

If the slider or part of the slider is green, the required
log data has been loaded and the IGSS Player can display that part of the playback interval.

Field name

Description
l

If the slider or part of the slider is yellow, the log data
is still loading. The IGSS Player cannot display that
part of the playback interval yet.
When an hour’s worth of log data is in the process of
being loaded, this is represented by a yellow color on
the Period slider bar. Once the hour data is loaded and
ready for playback, the color will change to green, permitting playback.

l

l

Stop

If the slider or part of the slider is red, the log data
has not yet been loading and the IGSS Player cannot
display that part of the playback interval.
If the slider is gray, IGSS is running in Runtime or
Design mode and the IGSS Player is not available.

Click this button to stop the IGSS Player and return the slider
in the Period Slider bar to the start of the playback interval.
Click this button to jump 2.5% backwards in the playback
interval.

Jump Backward

Keyboard Shortcut key: Press the F2 key to jump backwards.
The entire playback interval is divided into 200 equal parts.
Each time you click the Jump Backward button, the playback
slider is moved backwards by one part (out of the 200).
Click this button to skip backwards to the previous value in the
log data of the playback interval.

Skip backward

The playback time stamp is set to the time stamp of the log
data and the object values are sent to the process diagrams
for display.
Keyboard Shortcut key:Press the F3 key to play the playback interval skip forward in the playback interval.
Click this button to reverse the playback interval at the speed
defined in the Player Speed field.

Reverse
Keyboard Shortcut key:Press the F4 key to play the playback interval in reverse.
Pause

Click this button to pause the playback interval. The present

Field name

Description

time slider will remain where it is.
You can resume the playback interval by clicking the Pause
button again. You can also resume the playback by clicking
the following buttons:
l

Jump Backward

l

Skip Backward

l

Skip Forward

l

Fast Forward

Keyboard Shortcut key: Press the F5 key to pause or
resume the playback interval.
Click this button to fast forward the playback interval at the
speed defined in the Player Speed field.
Fast Forward
Keyboard Shortcut key:Press the F6 key to play the playback interval in reverse.
Click this button to skip forward to the next value in the log
data of the playback interval.

Skip Forward

The playback time stamp is set to the time stamp of the log
data and the object values are sent to the process diagrams
for display.
Keyboard Shortcut key:Press the F7 key to play the playback interval skip forward in the playback interval.
Click this button to jump 2.5% backwards in the playback
interval.

Jump Forward

Keyboard Shortcut key:Press the F8 key to jump backwards.
The entire playback interval is divided into 200 equal parts.
Each time you click the Jump Forward button, the playback
slider is moved forwards by one part (out of the 200).

Setup time interval to analyze button

Click this button to open the Define playback interval form
where you can set up the start and end date and times for the
IGSS Player form.

See Also

"The Define Playback Interval form" on page 113
The Define Playback Interval form
Use this form to specify the playback interval the IGSS Player form. You must select the start
date and time as well as the end date and time of the playback interval.

Overview
Once you have selected the playback interval, log data will be loaded for the IGSS Player
form.
Please note that selecting a very long playback interval, for example many days or weeks, will
affect system memory usage, slowing system performance and a longer loaded time for the
IGSS Player form will result. If at all possible, select as narrow an interval as possible.
If you have selected a playback interval that is too long, you can change the playback interval
duration by selecting new start and end dates and times, automatically pausing the playback
and inserting the new playback interval.
The last used playback interval is automatically loaded when the IGSS Player is opened.

Preconditions
The IGSS Player form must be opened in order to access the Define Playback Interval
form..

Where do I find it?
Click the Setup time interval to analyze button in the IGSS Player form to open the
Define Playback Interval form .

Field Help
Field name

Description

Start Date

Select the start date of the playback interval from the calendar in the field or enter the date directly in the field.

Start Time

Enter the start time of the playback interval.

End Date

Select the end date of the playback interval from the calendar
in the field or enter the date directly in the field.

End Time

Enter the end time of the playback interval.

See Also

"The IGSS Player form" on page 108

Configuring the IGSS Player
You can configure the appearance of the Supervise module when the IGSS Playback functionality is running.
By default, the Alarm list and Supervise diagrams are shaded in a semi-transparent red mask to
indicate the IGSS Playback functionality is enabled. You can change the color of the IGSS Playback mask for both the Alarm List and the diagrams in the Supervise module.

Note
IGSS uses an eight character hexadecimal color code to represent colors in the
IGSS application.
The eight character hexadecimal color codes consists of 4 pairs of two-character combinations
and looks like this: ##BBGGRR
An eight character hexadecimal color code consists of the following:
l

The first pair (first two characters ##) is always 00.

l

The next pair (characters 3 and 4, BB) defines the blue values of the background color
and must be within the hexadecimal values 00 and ff

l

The next pair (characters 5and 6, GG) defines the green values of the background color
and must be within the hexadecimal values 00 and ff

l

The next pair (characters 7 and 8 RR) defines the red values of the background color
and must be within the hexadecimal values 00 and ff

The hexadecimal code refers to the 00-ff values for the Red, Green and Blue parts of the color.
See Also

"Configuring the Alarm List playback background color" on page 115
"Configuring the Supervise playback background color" on page 116
Display alarms in the Active Alarms form during playback
By default, the Active Alarm will display historical alarm data and the Event list will be emptied of data. Both will be displayed with a red background during playback. Alarms and event
will still be registered in the Active Alarm during playback and will be displayed when playback ends.
If you need to access the active alarms during playback, you can set up the alarm module to
display real-time active alarms in the Active Alarm form during playback in the System

Configuration form. The Active Alarm form will not be displayed with an overlay mask during
playback if you set up the alarm module to display real-time active alarms during playback.
To display real-time active alarms in the Active Alarm form during playback

1. In the IGSS Master > Design and Setup tab, click the System Configuration
button to open the System Configuration form.
2. In the System Configuration form. > Alarm tab > Alarm Settings group, select
the Show real alarms in playback mode check box
3. Close the System Configuration form and save the new configuration settings.

The configuration must be restarted after saving new system configuration settings.

Configuring the Alarm List playback background color
The background color of the Alarm list form is overlaid with a semi-transparent red mask
when the IGSS Playback functionality is in use (the IGSS Player form is running)
You can change the default appearance of the semi-transparent red layer by defining a new
indicator color.
You can change the indicator color of the Alarm list form layer list to another color in two
ways:
l

In the Registry settings of the local machine

l

In the System Configuration form

Using the System Configuration form
Make sure you are running in Design Mode in the IGSS Master.

1. In the IGSS Master, click Design and Setup tab > System Configuration button to open the System Configuration form.
2. Select the IGSS server in the left hand pane of the System Configuration form
(Right-click the server name in the tree and select This PC).

3. In the System Configuration form, click the Alarm tab > Playback mode field
and select the new color you want to display in the Active Alarms form Supervise
when the IGSS Player is playing IGSS data.
4. In the System Configuration form, click File > Save Project and exit the System Configuration form. The IGSS configuration will re-start and deploy your
changes.

Using the Registry settings
You can change the background color of the Alarm list form to another color by defining a new
eight character hexadecimal value for the background color in the registry settings for IGSS on
the local machine.
The default value is 00d0d0ff.

1. Open the Registry Editor form on the local machine. Click Start and type "Regedit.exe" in the search field of the Windows Start menu.
2. In the Settings folder in HKEY_CURRENT_USER\Software\Schneider Electric\IGSS32\V12.00.00 \ Player, right-click on the Alarm List Background Colour
registry key and select Modify.
3. In the Value Data field of the Edit String form, enter the new eight character hexadecimal value of the background color and click the OK button to save.
4. Click File > Exit to exit the Registry Editor form and save the registry values.

See Also

"Configuring the Supervise playback background color" on page 116
"Configuring the indicator mask for the Data Playback function" on page 118
Configuring the Supervise playback background color
The background color of the diagrams in Supervise are overlaid with a semi-transparent red
layer when the IGSS Playback functionality is in use (the IGSS Player form is running).
The layer consists of an indicator color, which is used to indicate when IGSS Playback functionality is in use and an indicator mask, which is used to define the form and transparency of
the indicator color.

You can change the default appearance of the semi-transparent red layer by defining a new
indicator color and a new indicator mask as well as define how much of the screen area is to be
covered by the playback indicator mask.
You can change the indicator color of the Supervise layer list to another color in two ways:
l

In the Registry settings of the local machine

l

In the System Configuration form

Using System Configuration form
Make sure you are running in Design Mode in the IGSS Master.

1. In the IGSS Master, click Design and Setup tab > System Configuration button to open the System Configuration form.
2. Select the IGSS server in the left hand pane of the System Configuration form
(Right-click the server name in the tree and select This PC).
3. In the System Configuration form, click the Supervise and Language tab
> Setup indicator mask button to open the Setup Indication Mask form.
4. In the Player Mode indicator color field, select the new color you want to display
in Supervise when the IGSS Player is playing IGSS data.
5. In the System Configuration form > Supervise and Language tab > Cover
field, define how much of the screen is to be covered by the playback indicator
mask, expressed as thousandths (permille instead of percent) of the screen area.
6. In the System Configuration form, click File > Save Project and exit the System Configuration form. The IGSS configuration will re-start and deploy your
changes.

Using the Registry settings
If you use the registry editor to change the indicator color of the Supervise layer list to another
color, you must define a new 8 character hexadecimal value for the background color in the
registry settings for IGSS on the local machine.
The default value is 00d0d0ff.

To change the background color of the diagrams in Supervise:

1. Open the Registry Editor form on the local machine. Click Start and type "Regedit.exe" in the search field of the Windows Start menu.

2. In the Settings folder in HKEY_CURRENT_USER\Software\Schneider Electric\IGSS32\V12.00.00 \ Player, right-click on the SupverviseMaskColor registry
key and select Modify.
3. In the Value Data field of the Edit String form, enter the new 8 character hexadecimal value of the background color and click the OK button to save.
4. Click File > Exit to exit the Registry Editor form and save the registry values.

See Also

"Configuring the indicator mask for the Data Playback function" on page 118
Configuring the Alarm List playback background color

Configuring the indicator mask for the Data Playback function
The background color of the diagrams in Supervise are overlaid with a semi-transparent red
layer when the IGSS Playback functionality is in use (the IGSS Player form is running).
The layer consists of an indicator color, which is used to indicate when IGSS Playback functionality is in use and an indicator mask, which is used to define the form and transparency of
the indicator color.
You can change the default appearance of the semi-transparent red layer by defining a new
indicator color and a new indicator mask.

To change the indicator mask for IGSS Playback functionality
Make sure you are running in Design Mode in the IGSS Master.

1. In the IGSS Master, click Design and Setup tab > System Configuration button to open the System Configuration form
2. In the System Configuration form, click the Supervise and Language tab
> Setup indicator mask button to open the Setup Indication Mask form.
3. In the Indication Mask group, click the pixels to toggle the transparency on or off.
If a pixel is toggled to black, the selected indicator color will be displayed in the
pixel.

If a pixel is toggled to white, the original background of the Supervise module will be
displayed in the pixel.

4. You can see how the selected combinations and concentrations of pixels will look in
the Sample field.

You can increase of decrease the degree of transparency by
increasing or decreasing the concentration of black vs. white
pixels in the Indication Mask pixel. If you fill the entire area with
black pixels, this will correspond to 100% transparency while an
all-white area will correspond to 0% transparency.
See Also

"Configuring the Supervise playback background color" on page 116

Run a playback interval in the Supervisemodule
If you want to run a playback interval in the Supervise module's diagrams, you must do the following:

1. Ensure the IGSS Master is started and running.
2. Locate and open the IGSS Player form from the IGSS Master.
3. Open the Define Playback Interval form and define the playback interval
4. Start the playback and monitor the diagrams during the playback sequence
5. Once the playback is ended, close the IGSS Player form and return IGSS to normal
running mode.

You can also start IGSS Playback from the Tools menu in the
Supervise module.
See Also

"The IGSS Player form" on page 108
"Define the playback interval" on page 120
"Set playback speed in the IGSS Player" on page 120

Define the playback interval
To define the playback interval for the IGSS Player form:

1. Open the IGSS Player form from the IGSS Master
2. In the IGSS Player form, click the Setup time interval to analyze button to
open the Define Playback Interval form
3. In the Define Playback Interval form:
1. In the Start Date and Start Time fields, enter the Start date and start
time of the playback interval.
2. In the End Date and End Time fields, enter the end data and end time of
the playback interval.
4. Click the OK button to close the form and save the settings.

See Also

"The Define Playback Interval form" on page 113
"Run a playback interval in the Supervisemodule" on page 119
"Set playback speed in the IGSS Player" on page 120

Set playback speed in the IGSS Player
You can increase the playback speed of the IGSS Player form to run through the playback
interval or slow the speed down for more in-depth analysis of the monitored process.
The playback speed in IGSS Player form is set in pre-defined speeds compared to a standard
one second playback.
l

If you set the playback speed to "1/10", this will result in a slower playback speed. Ten
minutes will be used to replay one full minute of LOG data in the monitored process.

l

If you set the playback speed to "2", this will result in a faster playback speed. One
minute will be used to replay two full minutes of LOG data in the monitored process.

The available playback speeds are displayed in the drop-down field in the middle of the button
area. You can select any playback speed by opening the drop down box in the button area and
selecting the playback speed.

To change the playback speed:

In the IGSS Player form, click the plus [ + ] button to increase the playback speed by one
speed level and click the minus [ – ] button to decrease the playback speed by one speed
level.
You can also press the + or – keys to increase or decrease the playback speed.
See Also

"The IGSS Player form" on page 108
"Run a playback interval in the Supervisemodule" on page 119
"Define the playback interval" on page 120

9.2 Object Historian
What is the Object Historian ?
Definition
The Object Historian allows the operator to view past events in the monitored process. The operator can view four different event types in the Object Historian:
l

Log data

l

Alarm data

l

BCL data

l

User login/logout

Use
The Object Historian is a supplement to the traditional tools available to the operator. LOG and
BCL data can also be viewed in a graph, alarm data can be seen in the Alarm List.
But the Object Historian binds all these data types together and provides a full chronological
picture of the events in the process, including information about which user was logged in at the
time in question.

Using the Object Historian
Introduction

This topic serves to give you an overview of the Object Historian functionality. For step-by-step
procedures, click here and choose the relevant one.

Example
The functionality is best illustrated with an example. The dialogue below shows the LOG data
for 24 hours for the selected objects.

Select objects for inspection
The first step is to choose the objects you want to inspect. This can be done in two ways:
l

Lasso the objects on a process diagram, then select Edit → Object Historian.

l

Select Edit → Object Historian, then browse through the configuration to find the objects.

The selected objects appear in the list with the text "Will be checked for events".

Define the time period

By default, the Object Historian goes back one hour but you can choose any start and end
time in the Time interval area.
But remember that you must have the corresponding data files in the configuration's report
folder. The lifetime of the different data files may be limited as defined in the System Configuration program on the Files tab. As an example, the lifetime for .log files is set to 24 hours
by default. So if you don't get any data in the list, this may be the reason.

Choosing the event types
You can now choose between four different event types: LOG, BCL, Alarm data or user login/logout information. Any combination of the four types is valid.
Once the relevant types are selected, simply click the Query data button.

Printing or exporting data
Once the data is displayed in the list, you can print the data or export it to a .csv file for further
processing.

What's This? Help
When you work with the Object Historian, you can always click the
corner of the dialogue, then click the item you want information about.

in the upper right

View LOG data in Object Historian

1. Choose the objects for inspection as follows:

l

l

Lasso the objects on the process diagram, then select Edit → Object Historian.
Select Edit → Object Historian and click Browse to find the relevant objects. To add
multiple objects simultaneously, select them in the Object Browser and drag them
onto the Object Historian dialogue.

Result: The selected objects appear in the list with the text "Will be checked for events".

2. Under Time interval, define the relevant start and end time. IGSS goes back one hour by default.
3. Under Event types, select the Log check box.
4. Click Query data to view the data in the list.

Tip: For details on the individual columns in the list, click the
list.

button, then click inside the

Show picture

If you don't get any data in the list, you may not have the necessary .log files in the
report folder. The lifetime of the data files can be limited by the settings on the Files
tab in the System Configuration form.

View alarm data in Object Historian

1. Choose the objects for inspection as follows:

l

l

Lasso the objects on the process diagram, then select Edit → Object Historian.
Select Edit → Object Historian and click Browse to find the relevant objects. To add
multiple objects simultaneously, select them in the Object Browser and drag them
onto the Object Historian dialogue.

The selected objects appear in the list with the text "Will be checked for events".

1. Under Time interval, define the relevant start and end time. IGSS goes back one hour by default.
2. Under Event types, select the Alarm check box.
3. Click Query data to view the data in the list.
4. For details on the individual columns in the list, click the

button, then click inside the list.

Show picture

If you don't get any data in the list, you may not have the necessary .alm files in the
report folder. The lifetime of the data files can be limited by the settings on the Files
tab in the System Configuration form.

View BCL data in Object Historian

1. Choose the objects for inspection as follows:

l

l

Lasso the objects on the process diagram, then select Edit → Object Historian.
Select Edit → Object Historian and click Browse to find the relevant objects. To add
multiple objects simultaneously, select them in the Object Browser and drag them
onto the Object Historian dialogue.

The selected objects appear in the list with the text "Will be checked for events".

2. Under Time interval , define the relevant start and end time. IGSS goes back one
hour by default.
3. Under Event types, select the BCLcheck box.
4. Click Query data to view the data in the list.
5. For details on the individual columns in the list, click the

button, then click inside the list.

Show picture
Note
If you don't get any data in the list, you may not have the necessary .bcl files in the report
folder. The lifetime of the data files can be limited by the settings on the Files tab in the System Configuration program.

Export data from Object Historian

1. Once the required data is displayed in the list, click the Export as CSV button.
2. In the Save As dialogue, give the .csv file a name. IGSS defaults to the report folder for the configuration, but you can choose another folder, if required.

The .csv file can be opened in another program for further processing, for example, in Microsoft
Excel.

Print data from Object Historian

1. Once the required data is displayed in the list, choose what to print as follows:

l

To print all items in the list, go to step 2.

l

To print only selected items, select the relevant items in the list.

2. Click the Print button.

9.3 Object Watch
The Object Watch Window
The Object Watch Window form is a small separate window in IGSS where the operators can add
specific object atoms. These object atoms in the Object Watch Window will be displayed on top
of any present diagram.
Use

The Object Watch Window can be used when certain atoms has to be monitored more frequently, for example if there are two critical flow meters that must be monitored extra carefully
these might be placed in the Object Watch. Then the operator would still be able to monitor the
normal process in the background diagram and also keep an extra eye on the flow meters in the
Object Watch window (If the multi monitor feature is enabled the Object Watch Window may be
placed on a separate screen).
See Also

"View Object Watch" on page 127
"Add object atoms to the Object Watch Window" on page 126
"Additional features with Object Watch" on page 128

Add object atoms to the Object Watch Window
Types of objects

Atoms from the following object types can be added to the Object Watch Window:
l

Analog

l

Digital

l

Table

l

Counter

l

String

Add atom(s) to the Object Watch window

1. In the process diagram, right-click the object you want to add to the Object Watch
window and select Watch Object.
2. In the Atoms to show in object watch window form, select which atoms from
the object you want to display in the Object Watch window and click the
OK button.
3. The Object Watch window will open with the selected atoms added. You can adjust
the order of the object atoms and create graphs or historical data overviews from the
objects displayed in the Object Watch window.

If the command menu does not open when you right-click an object, you must enable command
menus in the Edit > View Command Menus and check the settings on the Supervise and
Language tab in the System Configuration form in the IGSS Master.
Remove atoms from the Object Watch Window

To remove an atom from the Object Watch, select the atom and click Delete or go to the Edit
tab and click Remove. You can also clear the whole list from the Edit tab by clicking Clear
List (or Ctrl+Delete)
See Also

"What happens when you click on a process object" on page 25
"The Object Watch Window" on page 126
"View Object Watch" on page 127
"Additional features with Object Watch" on page 128

View Object Watch
How to open the Object Watch window

To open the Object Watch Window, click View > Watch Window.

Change Object Watch location

To change the location of the Object Watch window, select the Window tab and select on any
of the four listed places where you want the Object Watch to be located.

You can also manually resize the Object Watch window and place it anywhere on the screen.

By default the Object Watch Window is set to always be on top of any other window,
which is the recommended setting.
Change list order

To change the Object Watch list order, select an atom, go to the Edit tab and click Move Up
or Move Down. You can also use the hot keys Ctrl+Up or Ctrl+Down.
See Also

"The Object Watch Window" on page 126
"Add object atoms to the Object Watch Window" on page 126
"Additional features with Object Watch" on page 128

Additional features with Object Watch
Find Object from the Object Watch Window

You can locate any of the objects that are currently in the Object Watch Window in the Supervise module..

1. In the Object Watch Window, select the object you want to locate in the Supervise
module.
2. Click Edit tab > Find (or click Ctrl+F) to open the diagram in the Supervise module
which contains the object. If the object resides on multiple diagrams, you must
select which diagram to open.

Save process data from the Object Watch Window

The process data collected from the objects shown in the Object Watch list can be exported to a
.csv file.

1. In the Object Watch window and select the object you want to export process data
from .
2. Click File > Capture to File to open the Save As form and select the location of
the data file.
3. In the Save As form, select a destination and a file name for the .csv file and finish
by clicking Save. The .csv file is now continuously updated when any object atom
changes.
4. When you do not want to register any further changes in the .csv file go to the File
tab and click Stop Capture.

View Object Historian from Object Watch

You can access the Object Historianform from the objects listed in the Object Watch Window, viewing historical object data for the selected objects..

1. In the Object Watch Window Select the object or objects you wish to view the
object data.
2. Click Edit > Show History (or click Ctrl+H) to open the Object Historian form and
enter the required parameters.

View graphs from Object Watch

You can generate Operator graphs for any of the objects listed in the Object Watch.

1. In the Object Watch Window, select the object or objects you wish to create an
Operator graph for.
2. Click Edit> Show Graph (or click Ctrl+H) to open the Define Graph Period form
and enter the graph parameters.

See Also

"Using the Object Historian" on page 121
"Create an Operator Graph" on page 75
"The Object Watch Window" on page 126
"View Object Watch" on page 127
"Add object atoms to the Object Watch Window" on page 126

Chapter 9: Broadcasting a message
9.4 Send message to all stations
You can send a short message to all stations that are connected to the IGSS server. A message
window will be displayed in the Supervise module of all operator stations.
You can prevent operators from closing the message window and you can define when the message window will automatically close.

1. In the Supervise module > click Tools > Broadcast Message button to open the
Broadcast Message form .
2. Enter the message you want to send to all stations in the Text message to display on all stations field. You can only enter 400 characters in the message.
1. If you want to prevent operators from closing the message window on
their stations, select the Operators cannot close this message check
box.
2. If you want to define when the message window will automatically close,
select the Remove message after check box and enter the number of
hours the message window is to be displayed. The minimum value is 1
hour and the maximum value is 100 hours.
3. Click the Broadcast Message button to send the message to all connected stations.

You can also send messages to all stations from the Home ribbon in the IGSS Master.

See Also
"The Broadcast Message form" on page 130

9.5 The Broadcast Message form
Use the Broadcast Message form to define and send a message to all online IGSS stations.

Overview
You can define a message which you can send to all online IGSS stations. The IGSS Broadcast Viewer form will be displayed on all receiving IGSS stations.
The message dialog on the receiving IGSS stations will display the following information:

l

the text message.

l

the station from which the message was sent.

l

the date and time the message was received.

IGSS stations that are offline but connect after the message is sent later will not receive the
message but once the message has been received, it can remain visible even if the IGSS station disconnects from the IGSS server.
You can define parameters which can prevent an operator from closing the message dialog and
you can also set how long the message dialog will be displayed on the IGSS stations.
You can only send a message that consists of 400 characters or less but you can send multiple
messages and an IGSS station can receive multiple messages from many other stations.

Preconditions
The Supervise module must be opened and IGSS must be running.
The receiving IGSS Player stations must be online and connected to the IGSS station sending
the message.

Where do I find it?
To open the Broadcast Message form:
l

In the Supervise module, click Tools > Broadcast message.

l

In the IGSS Master , click Home tab> Broadcast Message.

Field Help
Name

Description

Enter the message to be sent to all IGSS stations.
Text message to display on all stations

You can only send a message that consists of 400 characters
or less.
Select this check box to prevent operators from closing the
IGSS Broadcast Viewer form.

Operators cannot close
message

Remove message after

If you select this checkbox, the Close button on theIGSS
Broadcast Viewer form will be disabled for all IGSS stations, including the station that sent the message.
Select this check box to automatically close the IGSS Broadcast Viewer form on all IGSS stations after it has been dis-

Name

Description

played for a number of hours.
You must define the actual number of hours, setting a minimum of one hour and a maximum of 100 hours.

Button Help
Button Name

Description

Broadcast Message

Click this button to send he message to all connected IGSS stations. An empty message cannot be sent.

Cancel

Click this button to close the Broadcast Message form
without sending the message.

See Also
"Send message to all stations" on page 130

Chapter 10: Printing Process Information
10.1 What can you print?
IGSS allows you to print out current process information in different ways:
You may print out …
l

the complete contents of a process diagram

l

the current values of the objects displayed on a process diagram

l

a graph

l

a plant and operations report

l

the contents of the alarm list / alarm log

l

all process alarms as they occur, on a special message printer reserved for continuous message logging

10.2 Print out a process diagram
To take a screen dump of the currently active process diagram, follow the below procedure:

1. In the menu bar, select File → Print → Window.
2. In the Print dialogue select the relevant printer, its properties and specify the print range and the number of copies you wish to have printed.

Note
l

l

l

With File → Page Setup and File → Print Preview you can change the paper format
and page margins, and view the print page before you actually send it to the printer.
It is always the top process window, that is to say, the currently active one, whose contents is printed out.
The command File → Print → Screen prints out the entire contents of the screen,
incl. the title bar, menu bar, etc.

10.3 Print the current values of a process diagram
1. Do one of the following:

l
l

To print all process values from the active diagram, select Edit → Select All Objects.
To print the process values of specific objects, select them one by one while holding
down the SHIFT button. The selected objects will be indicated by a frame around them.

2. In the File menu, select Print Values.
3. The Save As dialogue appears asking you to save the values in an .lst file. Save the data.

Result: The WordPad text editor is automatically opened. You may now edit and print the data
in the form of a list.

Note
With File → Page Setup you can change the paper format and page margins before you actually send the information to the printer.

10.4 Print a complete graph window
You can take a picture (screen dump) of the active graph window and send it to the printer.
Only the chart currently displayed in the graph window will be sent to the printer.
If you want to print another graph area or period, you must first define the graph period and display it in the graph before you can send the graph window to the printer.
To print the active graph window

1. In the Supervise module, open the graph you want to print.
2. In the graph toolbar, click the Print button to open the Print form
3. In the Print form, select the printer and define print properties for the job
4. Click the OK button to send the graph to the printer.

Click File > Page Setup to change the paper format and page
margins before you send the graph to the printer.

See Also
Open a graph
Change graph period

10.5 Print a report
All reporting facilities included by the system designer can be accessed in the User Programs
menu.

Note: Once you are in the selected report program you have full access to the relevant help
functions.

10.6 Print the alarm list/alarm log
To print out the Alarm List or Alarm Log follow the procedure below:

1. If you are not in the Alarm program, but on a normal process diagram in the Supervise program, select
in the taskbar at the bottom of the screen,
2. In the menu bar of the Alarm program, select File → Print.
3. Make your selections in the Print dialog box.
4. Confirm with OK.

Cut to Paper Width
If this function is selected, the contents of the displayed Alarm List or Log is cut
off if it exceeds the right margin of the printing paper.
If this function is not selected and the contents of the list exceeds the width of
one print page, printing is continued on a second page. In this way you may join
two printed pages to see the entire contents of the list on paper.

Tip
Once you are in the Alarm program you have full access to the relevant help functions.

10.7 Direct message printing
The function of continuous alarm logging on a message printer is enabled or disabled in the System Configuration program by the system designer. The operator has no access to this function. However, if you are given the authority by the system designer, you may decide on the
format of message logging using the command File → Save Format for Alarm Printer in
the Alarm program.

Note
Pressing
in the taskbar at the bottom of the process diagram automatically
takes you into the Alarm program where you have access to all online explanations and help
functions associated with alarm handling.

Chapter 11: Exporting and E-mailing Process Information
11.1 Export functions
Export data from Object Historian

1. Once the required data is displayed in the list, click the Export as CSV button.
2. In the Save As dialogue, give the .csv file a name. IGSS defaults to the report folder for the configuration, but you can choose another folder, if required.

The .csv file can be opened in another program for further processing, for example, in Microsoft
Excel.

11.2 E-mail functions
Email a diagram
A diagram can be sent as a JPEG file to a mail recipient. In order to send the file, a so-called
MAPI client such as Microsoft Outlook must be installed and set up.

This feature is not supported by Novell and other operating systems.

1. Open the diagram you want to send.

Note: Before you email the diagram, make sure that no other windows lie on top of the diagram.

2. Right-click and select Email Diagram.

Show picture

3. Do the following:

l

In the To field, type the email address of the recipient.

l

In the Subject field, type a descriptive title for the mail.

l

In the text field, type a message just as you would in a normal email.

The Attachments field contains the filename as processed by IGSS. The filename cannot
be changed.

4. Click the Send button to send the email.

Chapter 12: Reference and Lookup
12.1 Conventions in this Manual
The following typographical conventions are used:

Convention

Description

User interface element

When referring to labels and names
in the user interface.

User input

When the user has to type specific
data in IGSS

Example

The Data Management tab.

Type the following description:

Incoming flow in Tank 2

Module
name

When referring to a module in IGSS

Note

A note emphasizes or supplements
important points of the main text. A
note provides information that may
apply only in special cases.

By default, the timestamp is in
universal time format, UTC1.
This can be changed in the
Driver Log Filters dialog box.

Tip

A tip suggests alternative methods
that may not be obvious in the user
interface. A tip also helps the user in
working more effectively with IGSS.
A tip is not essential to the basic
understanding of the text.

Alternative to this
simple find function, you can also
filter on text in the
messages in Driver
Log Filters dialog
box.

Warning

A warning is an important note that is
essential for the completion of a
task. In some cases, disregarding a
warning may result in undesirable
functionality or loss of data.

If you disregard the
System alarm, you
may risk loss of
data in the LOG
and BCL files.

Open the Definition module.

1 Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating

time in most parts of the world. IGSS uses this time format internally in the database. You can
switch between UTC and local time by enabling or disabling the "UTC" field in various dialog
boxes in the system.

12.2 Getting Help in IGSS
IGSS comes with a comprehensive help system designed to help both system designers and
operators to get started with IGSS as quickly as possible.

Documentation overview
The IGSS documentation includes the following items:

Documentation item

Description

Getting Started

An introduction to IGSS and its most fundamental terms and
features. Getting Started is intended to get you up and running
as fast as possible. The manual provides a system and architecture overview followed by a number of real-life use cases
you can go through before building your first real IGSS project.
The manual is available in Adobe Acrobat format (.pdf).
For each module there is a help file with the same name as the
module itself, for example, Def.chm for the Definition module.

Module help

The help file is invoked by clicking the
in the upper right
corner of the module. The Table of Contents will then allow you
to browse through the topics.
For each Form or dialog there is a help topic with the following
standard information:

Form and Dialog help̓

l

Overview

l

Preconditions

l

Where do I find it?

l

Field help

Form help is invoked by clicking the help button
in the
upper right hand corner of the dialog box or located in the
Table of Contents of the individual help file.

Thematic help

IGSS also provides thematic help. When there is a special
theme that requires special attention from the user, a dedicated help file is provided. Examples include "Driver-Specific
Help" and "Database Administration Help".

Where are the help files located?

The IGSS help files are located in the appropriate language folder in the installation path of
IGSS, by default C:\Program Files\Schneider Electric\IGSS32\V12.0. The help files are available in English at release time.
The paths to the help files are:

Language

Path

English

[IGSS InstallPath]\ENG

Danish

[IGSS InstallPath]\DAN

German

[IGSS InstallPath]\DEU

Translated help files
Selected help files have been translated into Danish. If you require help files in your language,
please contact Schneider Electric.

Help updates
The help files are continuously updated and improved. Check regularly with the IGSS Update in
the IGSS Master.

12.3 Version Information (IGSS Help System)
© Schneider Electric, IGSS Version 12.0
The IGSS help files are based on software build number 10305 (initial release)

English help files
To update the help files, click the Update IGSS Software button on the Information and
Support tab in the IGSS Master. There must be a connection from the PC to the Internet.
Every time IGSS Update is run, IGSS help files as well as IGSS system files will automatically
be updated on the PC from the web server at Schneider Electric.
You select the languages you want to update in the Tools menu of the IGSS Update form.
If you are not able to update the IGSS system directly via the Internet, the alternative is to
download the updates from the Schneider Electric website as zip files. These can then be transferred onto a CD or USB memory stick, which is then the medium used to update on site.

After updating your IGSS installation , the build numbers in various IGSS modules may
change to a higher number. This signifies that the module in question has been updated
with newer files. Build numbers consist of four digits, where the first digit represents the

year and the last three represent the day number in the year in question. The build number can be seen in the About dialog box which can be activated from the Help menu.
An example:

Build number = 10305
16 = the year 2016
305 = The 305th day of the year

Chapter 13: Glossary
A
Action Pane
The left pane of the main window in the Master module. Contains shortcuts to IGSS
modules and allows you to define your own shortcuts to other applications used with
IGSS.
Application menu
The Application menu is the first ribbon in the IGSS Master module. Click the icon to
drop down the menu. The menu contains items that were typically found in the File
menu in previous versions of IGSS. In most modules, an "Options" item allows the
user to define global module settings. The Application menu was introduced in the
Microsoft Office 2010 package. It replaces the Application button (nicknamed Doughnut) which was introduced in IGSS V7 and V8.

D
descriptor
A descriptor is the graphical display of an object. IGSS includes many types of
descriptors including: - Built-in standard symbols - Animated symbols (Symbol Factory library) - Graphics and animation - Drawing symbols - Windows controls - ActiveX
controls An IGSS object can be represented with different descriptors on different diagrams.

R
Ribbon
The Ribbon is a new term/element in the Microsoft universe. The Ribbon replaces the
well-known toolbars in applications. The Ribbon provides quick access to the most
commonly used functions in the application. The Ribbon is divided into logical groups
(the tabs) and each tab is divided into sections (the blocks in the tab). The Ribbon is
context-sensitive which means that only relevant functions are accessible dependent
on the current user action.

S
SCADA
Supervisory Control & Data Acquisition

U
UTC
Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for
calculating time in most parts of the world. IGSS uses this time format internally in
the database. You can switch between UTC and local time by enabling or disabling the
"UTC" field in various dialog boxes in the system.

W
Windows Shell
The Master module can be set as the Windows shell application. This will mean that
the operator cannot access normal Windows functions. Only functions accessible
through the IGSS .NET will be available.

