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Chapter 1: The IGSS Audit Trail

1.1 What is the Audit Trail module?

In SCADA1 systems, it is crucial to be able to monitor all actions performed in the process of the industrial plant.
When set up correctly, the Audit Trail module records all actions performed by the IGSS system operators.

What is recorded

The Audit Trail module can easily be customized to record any of the following operator actions:

l Acknowledgement of process alarms

l Commands send to the process PLCs

l Operators login or logout

l Changes in data collection settings

l Operator notes written - for example alarm notes or maintenance notes

l Changes in analog alarm limits

l System start/stop

l Broadcast messages to IGSS stations

Viewing and filtering the Audit Trail

The recorded audit trails are shown in a list in the Audit Trail form. Filtering in this list is flexible and can be per-
formed on many different system parameters. This is useful to track certain operator actions and detect any irreg-
ularities in the process control. Below is listed some of the information available for each record of an audit trail:

l Operator - which operator has performed the action

l IGSS Object - which object is influenced

l IGSS Operator station - from where has the action been performed

l Action Type - what has been done

l Approved by - which second person has approved the action

The Audit Trail form

Here's an example where numerous user and system actions have been recorded:

1Supervisory Control & Data Acquisition



1.2 Audit Trail Types and subtypes

User and system actions to be stored in the Audit Trail database are divided into Audit Trail types. Each type has sev-
eral sub-types further defining the stored user action.

The Audit Trail types are:

Output

User operations that affect outgoing values of object for example sending commands for Digital objects and changing
set points or present values for Analog, Table or Counter objects.

The Output Audit Trail type contains 5 subtypes:

Sub Type Description

Command When a user sends a command to a digital object.

Set Point When a user updates a set point on an analog object.

Table When a user updates a value in a table object.

String When a user updates a text on a string object.

Process Value When a user updates the process value (actual value) of an analog object.



Limits

User operations that affect the alarm limits of an object.

The Limits Audit Trail type contains12 subtypes:

Sub Type Description

High Alarm When a user updates the High Alarm limit on an object.

Low Alarm When a user updates the Low Alarm limit on an object.

High Limit When a user updates the High Limit on an object.

Low Limit When a user updates the Low Limit on an object.

High Scale When a user updates the High Scale limit on an object.

Low Scale When a user updates the Low Scale limit on an object.

Free Value 1 When a user updates the Free Value 1 atom on an object.

Free Value 2 When a user updates the Free Value 2 atom on an object.

Free Value 3 When a user updates the Free Value 3 atom on an object.

Free Value 4 When a user updates the Free Value 4 atom on an object.

Free Value 5 When a user updates the Free Value 5 atom on an object.

Free Value 6 When a user updates the Free Value 6 atom on an object.

Access

User operations that affect user log in and log out of the system.

The Access Audit Trail type contains 2 subtypes:

Sub
Type Description

LogIn When a user logs into the IGSS configuration.

LogOut When a user logs out of the IGSS configuration.

Notes

User and system operations that affect creation and updating object and alarm notes



The Notes and Ack Audit Trail type contains 6 subtypes:

Sub Type Description

Object When a user creates or updates an object note.

Alarm When a user creates or updates an alarm note.

End When a user terminates an object note.

Ack When a user acknowledges an alarm or object note

User When a user creates a note on an Audit Trail record

Broadcast
Sent

When a user sends a Broadcast message using the Broadcast form in the
Supervise module > Tools menu > Send Broadcast.

Alarms

User and system operations that affect the active alarms

The Alarm Audit Trail type contains 6 subtypes:

Sub Type Description

Acknowledge When the user acknowledges an alarm

Inhibit When a user inhibits an alarm in any way.

Revoke When a user removes an alarm inhibition, reinstating the alarm

Remove When a user removes an alarm from the Active Alarm form.

Hide When a user hides an alarm in the Active Alarm form

Unhide When a user reveals a hidden alarm (removing the hidden status)

Data Management

User and system operations that affect data logging and data collection in the configuration.

The Data Management Audit Trail type contains 11 subtypes:

Sub Type Description

Log in
stopped

The user stops data logging of inbound values in the Data Collection Control form in the Super-
vise module or for the individual object on the Data Collection & Logging tab in the Object



Sub Type Description

Properties form.

Log in star-
ted

The user start data logging of inbound values in the Data Collection Control form in the Super-
vise module or for the individual object on the Data Collection & Logging tab in the Object
Properties form.

Log out
stopped

The user start data logging of outbound values for the individual object on the Data Collection &
Logging tab in the Object Properties form.

Log out
started

The user stops data logging of outbound values for the individual object on the Data Collection &
Logging tab in the Object Properties form.

Log print
started

The user starts data print of values for the individual object on the Data Collection & Logging
tab in the Object Properties form.

Log print
stopped

The user stops data print of values for the individual object on the Data Collection & Logging
tab in the Object Properties form.

Scanning
started

The user starts data collection of values in the Data Collection Control form in the Supervise
module or for the individual object on the Data Collection & Logging tab in the Object Prop-
erties form.

Scanning
stopped

The user stops data collection of values in the Data Collection Control form in the Supervise
module or for the individual object on the Data Collection & Logging tab in the Object Prop-
erties form.

Extended
logging
started

The user starts extended data logging in the Data Collection Control form in the Supervise
module.

Extended
logging
stopped

The user stops extended data logging in the Data Collection Control form in the Supervise
module.

Manual
scan

The user performs a manual scanning in the Data Collection Control form in the Supervise
module.

System

User operations that affect system start and stop, including automated system start and stop.

The System Audit Trail type contains 11 subtypes



Sub
Type Description

Start

The user starts the Supervise module from the IGSS Master > Home tab > Data Collection
group > Start button.

If the Restart button is clicked, the configuration will first be stopped and then started auto-
matically.

Stop

The user stops the Supervise module from the IGSS Master > Home tab > Data Collection
group > Stop button.

If the Restart button is clicked, the configuration will first be stopped and then started auto-
matically.

SW Upda-
te

The user runs the IGSS Software Updater from the IGSS Master > Information and Support
tab > Update IGSS software button.

The button is only accessible if the IGSS Master runs in Design mode.

Kill App

The user closes a core or normal application by clicking the Kill button in the Detailed Status pane
in the IGSS Master workspace.

The Detailed Status is displayed by clicking the Detailed status button found in the IGSS Master >
Runtime and Diagnostics tab.

Launch
app

The user launches a core or normal application by clicking the Launch button in the Detailed
Status pane in the IGSS Master workspace.

The Detailed Status is displayed by clicking the Detailed status button in the IGSS Master >
Runtime and Diagnostics tab.

Report The user edits an Operator Report by clicking the Operator Report format in the Supervise mod-
ule > Tools menu.

Event The user creates, edits or deletes an event by clicking Events in the Supervise module > Tools
menu.

Single U-
ser

The user restarts the station as a Single-User backup station in the Data Collection Control form
in the Supervise module.

Restart The user restarts all stations in the Data Collection Control form in the Supervise module.

Spool
files
deleted

The user deletes the spool files logging in the Data Collection Control form in the Supervise mod-
ule.



Sub
Type Description

Design
Mode The user selects the Design Mode option in the Applicationmenu of the IGSS Master.



Chapter 2: Setting up the Audit Trail

2.1 Setting up the SQL Server for Audit Trail

If you have a full SQL Server, it will provide all the functionality you need without any limitations. The free ver-
sion, SQL Server Express, has a max. limit of 4 GB per database.

Install and set up the SQL Server

1. Start by installing the SQL Server on the IGSS Server or on another PC in the IGSS network.

l SQL Server Express 2008 and Management Tools can be downloaded from this link: http://www.-
microsoft.com/express/Database/

l SQL Server Express 2005 and its Management Studio is included on the IGSS installation disc.

2. If you're using SQL Server Express, it is recommended to create a new server name, instead of accepting
the default name, SQLEXPRESS. For example, you could call it "IGSS".

When you create a new SQL Server name, you obtain two advantages:
- If you have other applications dependent on SQL Server Express, they will not conflict in the
default server, SQLEXPRESS.
- You have the full 4 GB of data available, as only IGSS data will be saved in this server.

3. During installation, remember to enable both authentication types, if required. 

a. Windows Authentication (can only be used, if you're in a domain/workgroup)

b. SQL Server Authentication (necessary if you're not in a domain/workgroup)

4. Start the SQL Server Configuration Manager from the Windows Start menu under SQL Server 2008
> Configuration Tools.

http://www.microsoft.com/express/Database/


5. Make sure that that SQL Server and SQL Server Browser are started.

6. Make sure that following protocols are enabled, both for the Native client and SQL Server .

7. Close the SQL server Configuration Manager.

Run the Audit Trail script



1. Start the Microsoft SQL Server Management Studio.

2. Do the following:

l Under Server type, select Database Engine.

l Under Server name, select the correct server name (see Note above).

l Under Authentication, selectWindows Authentication or SQL Server Authentication, as
required.

3. In the File menu, choose Open -> File. Browse to the [IGSS installation path]\SQL folder.
Default path is C:\Program Files\Schneider Electric\IGSS32\V12.0\SQL.



4. Open the script named audittraildb.sql.

5. Press the Execute! button in the toolbar.

6. UnderMessages, there should be 1 line saying (1 Row(s) affected). If there are more lines, an error
has occurred. Troubleshoot the error and repeat this step, once fixed. 

7. If you have an operator station which is not in the same domain / workgroup as the SQL Server, you must
configure an SQL Server Authentication account.

8. In the Object Explorer tree view, unfold the Security branch, right-click on Logins and select New
Login.





9. In this particular case I have created an account called sql, with the password sql. 

10. On the General page, I have selected default database AUDITTRAIL and for this purpose I have also
selected that my sql user is a sysadmin under the Server Roles page.



11. Close the Microsoft SQL Server Management Studio.

Set up Audit Trail in System Configuration

1. In the IGSS Master, click the System Configuration button in the Design and Setup tab to open the
System Configuration form.



2. In the left pane of the System Configuration form, select the IGSS server or single user station.

No setup is necessary on the operator station in System Configuration. The only requirement for the
operator station is that it must have read/write access to the SQL Server.

3. On the Files tab, under Audit Trail, click the SQL Settings button.

4. In the SQL Server Settings form, select the check boxWrite audit trail value to SQL Server and
click the Database Setup button.

5. In the Data Link Properties dialog box, select the SQL Server Native Client 10.0 data source. If the
SQL Server Native Client 10.0 is not present, select Microsoft OLE DB Provider for ODBC Drivers
instead. You cannot use the SQL Server Native Client 11.0 for IGSS. For 64-bit machines, use the
ODBCad32.exe driver in C:\Windows\SysWOW64 instead of the default ODBC driver for 64-bit machines
as IGSS.1

6. Click the Next >> .button.

7. On the Connection tab, do the following:

Step 1: Select the SQL Server in the drop-down list.

In a real multiuser system, we recommend that you use the actual IP
address, for example, 192.168.0.1.

Step 2: Set user access to Use Windows NT integrated security or Use a specific user name
and password, if you're using SQL Server Authentication. Enter the user name and password and
remember to select Allow saving password.

Step 3: Under Select the database on the server, select the AUDITTRAIL database.

Step 4: Click Test Connection to test that the connection is working. If successful, then click OK.



8. Verify that the SQL Server Settings dialog box has these settings and click OK.

9. Finally, click the Access Control tab.



10. Enable the audit trail by selecting the Keep a record of all user activity in an audit trail data-
base check box.

Then select the activities you want to store in the audit trail database. Select the Comment required
check box, if you want to force the user to enter a comment for this type of operation.

In the Keep audit trail for field, write 0 (zero) to keep records forever or write a specific number of
days.



User administration and Audit Trail

Audit Trail really only makes sense, if you have users logged in. This will allow you to record exactly what
happened and who did it.

Therefore, we recommend that you do the following before starting the audit trail:



1. Define the relevant users and user groups in the User Administrationmodule.

2. Clear the check box Disable access control on the tab above in the System Configuration form.

3. Make sure that users are logged in permanently, while they are using IGSS. If a user is only temporarily
logged in, he will be prompted for his user name and password, every time an action is recorded in Audit
Trail.

1 The ODBCad32.exe file found in C:\Windows\SysWOW64 is used to run 32-bit applications (such as IGSS) on a 64-
bit Windows operating system while the default ODBCad32.exe file found in Control Panel > Administrative Tools >
Data Sources (ODBC) is used to run 64-bit applications on a 64-bit Windows operating system.

2.2 Auto-starting the Audit Trail

Once you've set up the SQL Server for the Audit Trail, you will probably want to automatically start the module every
time the user starts the IGSS configuration.

To auto-start the Audit Trail:

1. Open the System Configuration form.

2. Select the relevant IGSS station.

3. Click the Startup tab.

4. Under Auto start, select the Audit Trail check box.

5. Repeat steps 2-4 for all the stations where you want Audit Trail to start automatically.

6. In the File menu, select Save and Exit.

With the auto start option enabled, the Audit Trail module will now be started with the configuration and closed when
the configuration is stopped.



Chapter 2: Audit Trail form help

2.3 The Audit Trail Form

Use the Audit Trail form to view all recorded system and user actions in the current view period specified in the
Home ribbon.

You can add notes to the Audit Trail records if you want to provide for additional explanations for a record.

You can also create Audit Trail views, saving the Audit Trail filter criteria and restoring the view for quick display of
common Audit Trailfilter settings.

Preconditions

The Audit Trail button will only be accessible if the Audit Trail module has been set up correctly for storing data in
the Microsoft SQL Server.

Where do I find it?

Click the IGSS Master > Home tab > Audit Trail button.

The Application button

Click the Application button to:

l Print the Audit Trail records displayed in the list

l Define page set up when printing the Audit Trail records

l Preview the print before printing

l Export the Audit Trail records displayed in the list as a CSV (Comma-separated) file for analysis in 3rd party
applications such as Microsoft Excel.

The Home Ribbon

The Home ribbon contain functions for displaying Audit Trail data in the form.

Field Group
Name

Description

Add Note Note

Allows you to add an operator note. The note will not be tied to any specific object in the
configuration, but is a general operator note.

You must be logged in to have access to this function. The button is not active, if you are



Field Group
Name

Description

not logged in.

Refresh Contents Performs a manual update of the Action list based on the current filter settings.

Freeze Contents While this check box is selected, the automatic update of the Action list is disabled.

View
Period Period

Select the type of period you want to show.

Selecting Start and end time, Start time and time span or End time and time
span will open the relevant time options in the View tab.

Selecting any of the other options will disable all other time options, as these are pre-
defined periods.

Show
UTC1 Period Shows all time stamps in the universal time format, UTC. This is the raw time format

used in the IGSS databases.

Start
Date Period Click the drop-down arrow to browse through the calendar to find the date. Or type the

date in the format DD-MM-YYYY.

Start
Time Period Type the time in the format HH:MM:SS. Or use the up/down arrows to change the time.

Span Period Enter the time span for the data period. Time span can be combined with either start time
or end time.

End Date Period Click the drop-down arrow to browse through the calendar to find the date. Or type the
date in the format DD-MM-YYYY.

End Time Period Type the time in the format HH:MM:SS. Or use the up/down arrows to change the time.

Now Period When checked, the view period will end at the current date and time.

Type Filter

Select the action types you want to view in the Action list. The possible action types are:

l (All)

l Output

l Limits

1Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating time in most parts of
the world. IGSS uses this time format internally in the database. You can switch between UTC and local time by
enabling or disabling the "UTC" field in various dialog boxes in the system.



Field Group
Name

Description

l Access

l Notes

l Alarms

l System

l Data

Area Filter Filter the list by area. The drop-down list shows the areas of the current configuration.

Object Filter

Filter the Action list by object. Type the name of the object directly in the list or click the
three dots (...) beside the field to choose a specific object in the configuration.

To filter by multiple objects, you can filter the list using wildcards, For example, writing
"q*" will list all objects starting with the character q.

Station
name Filter Filter the Action list by IGSS station. Filter the Action list by user. Choose the relevant

user in the list. Users are defined in the User Administrationmodule.

User
name Filter Filter the Action list by user. Choose the relevant user in the list. Users are defined in the

User Administrationmodule.

Approved
by Filter Filter the list by approving user. An approving user is a user that has approved sending of

a safe command.

Save as
View Views

If you want to save a specific filter setup, click this button. You must specify the filter to
be used .

Click the drop-down arrow to open the options menu.

The options are:

l Update Selected View will update the current view with the current filter set-
tings.

l Delete Selected View will remove the filter.

l Make Default will make this view the default view.

Saved
Views Views This list shows the saved views. Choose the relevant view.

Field Help



Field Description

Date

The timestamp of the system or user action. By default, time is given in local machine time.

You can select the Show UTC check box in the Audit Trail ribbon to display all time stamps in
UTC time.

Type

The following Audit Trail action types are used:

l Output: Commands sent by the user to the PLC.

l Limits: Alarm limits changed by the user.

l Access: User logs in and log out of the system.

l Notes and Acks: Used for object notes, alarm notes as well as alarm actions, such as
acknowledgment and ending of alarms.

l System: Used for system start and stop (automatic or user-activated).

l Data: Used for operations concerning data logging and data collection.

Subtype

Each Audit Trail action type consists of several subtypes which further detail the user action . See
the link below for a detailed list of the Audit Trail subtypes.

Example: For the Access type, you will see Login and Logout.

Station The name of the station where the action was taken, either by the system or by the user.

User The name of the user currently logged in.

Area
For object operations only.

The name of the area in which the object resides.

Object
For object operations only.

The name of the manipulated object.

Atom
For object operations only.

The atom of the object which was manipulated.

Value The value which was sent to the PLC, for example, alarm limits, set points, etc.

String

The entire value string.

For analog objects, the unit will be displayed as shown in the picture above.

For digital objects, the command name will be shown (whereas the Value field shows the com-



Field Description

mand number).

Note A detailed explanation of the system or user action.

Comments User notes or comments concerning the Audit Trail record.

Approved by
This field is used with the Confirm 2 Users safe command only.

It shows the name of the user approving that the safe command will be sent.

See Also

"What is the Audit Trail module?" on page 1

"Audit Trail Types and subtypes" on page 2

"Choosing the view period" on page 25



Chapter 3: Using the Audit Trail

3.1 Choosing the view period

To get you up-and-running with the Audit Trail as fast as possible, we have developed a series of examples based on
the IGSS Demo Configuration.

If you start with this topic, you can move through the examples step-by-step as if you were operating a real plant.

Precondition: The Audit Trail module must have been set up for saving data in the IGSS SQL Server, before you
can perform this procedure.

1. If the IGSS Demo Configuration is not activated, open the System Configuration form.

2. In the File menu, select Open Demo Configuration and then select File and Save and Exit.

3. In the IGSS Master > Home tab, click the Start button. The IGSS Demo Configuration will now be auto-
matically started.

4. In the IGSS Master > Home tab, click the Login button.

5. Log in as the administrator user: User name = admin and Password = admin.

6. Let's do some user actions to get some information into the Audit Trail.
Click the Customer Cases button, then click the District Heating graphic.

7. Click the motor symbol in the upper left corner of the mimic diagram.

8. In the command menu, select the first command named Auto.



9. Repeat step 6, only this time sending the command Manual.

10. Repeat for the commands, Manual close and Manual open. The Audit Trail should now look like this.

11. Click the Stop button in the IGSS Master > Home tab to stop the system.

12. Start it again by hitting the Start button.

13. Let's change the view period. In the Period drop-down list, choose 2 hours back.

14. Now we have the right view period and some actions in the Action list. Let's continue with "Filtering the
Audit Trail" on page 26.

3.2 Filtering the Audit Trail

We are now ready to filter the Action list.



1. In the Home ribbon under Filter, do the following:

l Under Type, select System.

We are now seeing the system stop and start actions.

2. Change the Type filter back to (All).

3. Under User name, select the admin user.

The Action list should now look like this.

4. As the next step we want to learn how we're "Saving and applying views" on page 27

3.3 Saving and applying views

A View in the Audit Trail is a saved filter. You can save as many views as you need.

1. Our current filter shows all actions taken by the admin user. Let's save it as a view.

2. Click the Save as View button.



3. Type the view name Admin user (All) and click OK.

4. The next step is learning how we're "Adding a user note" on page 28

3.4 Adding a user note

A user note is a general note to the other users of the system. A user note is not tied to any specific object.

The user must be logged into the system in order to create a user note.

1. Click the Add Note icon.

2. Enter this text in the note field:
Call the service technicians.We need tomaintain those pumps now.



3. Click OK. The user note now appears in the Action list. Notice that the note text itself is shown in the
Comments field.

4. The next step is optional, but useful if you are using the IGSS Dashboard module.
You will learn how to "Presenting Audit Trail information in the IGSS Dashboard" on page 29

3.5 Presenting Audit Trail information in the IGSS Dashboard

If you want to show Audit Trail information in your dashboard(s), you can insert an Audit Trail widget.

1. In the IGSS Start menu, click the Dashboard icon. The default dashboard named Pump Station appears.
We will add the Audit Trail widget to this dashboard.

2. Click the Application button in the upper left corner of the window.

3. Select Configuration Mode.



4. On the Configuration tab under Insert Widget, click the Audit Trail icon.

5. Resize the widget and put it at the center of the screen. Notice that you can add user notes and activate
views just the same, as if you were in the Audit Trail module.

6. On the Audit Trail tab under Columns Visible When Minimized, select the Area, Object and Atom
check boxes.

Remember to explain to the end user that by clicking the Maximize button of the
widget, he will be able view all information fields. As you can see, all fields are
enabled under Columns Visible When Maximized.

You have successfully completed the series
of Audit Trail examples.





Chapter 4: Reference and Lookup

4.1 Conventions in this Manual

The following typographical conventions are used:

Convention Description Example

User inter-
face ele-
ment

When referring to labels and names
in the user interface. The Data Management tab.

User input When the user has to type specific
data in IGSS

Type the following description:

Incoming flow in Tank 2

Module
name When referring to a module in IGSS Open the Definitionmodule.

Note

A note emphasizes or supplements
important points of the main text. A
note provides information that may
apply only in special cases.

By default, the timestamp is in universal time
format, UTC1. This can be changed in the
Driver Log Filters dialog box.

Tip

A tip suggests alternative methods
that may not be obvious in the user
interface. A tip also helps the user in
working more effectively with IGSS.
A tip is not essential to the basic
understanding of the text.

Alternative to this simple find
function, you can also filter on
text in the messages in Driver
Log Filters dialog box.

Warning

A warning is an important note that is
essential for the completion of a
task. In some cases, disregarding a
warning may result in undesirable
functionality or loss of data.

If you disregard the System
alarm, you may risk loss of
data in the LOG and BCL files.

1Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating time in most parts of
the world. IGSS uses this time format internally in the database. You can switch between UTC and local time by
enabling or disabling the "UTC" field in various dialog boxes in the system.



4.2 Getting Help in IGSS

IGSS comes with a comprehensive help system designed to help both system designers and operators to get started
with IGSS as quickly as possible.

Documentation overview

The IGSS documentation includes the following items:

Documentation item Description

Getting Started

An introduction to IGSS and its most fundamental terms and features. Getting
Started is intended to get you up and running as fast as possible. The manual
provides a system and architecture overview followed by a number of real-
life use cases you can go through before building your first real IGSS project.
The manual is available in Adobe Acrobat format (.pdf).

Module help

For each module there is a help file with the same name as the module itself,
for example, Def.chm for the Definition module.

The help file is invoked by clicking the in the upper right corner of the mod-
ule. The Table of Contents will then allow you to browse through the topics.

Form and Dialog help̓

For each Form or dialog there is a help topic with the following standard
information:

l Overview

l Preconditions

l Where do I find it?

l Field help

Form help is invoked by clicking the help button in the upper right hand
corner of the dialog box or located in the Table of Contents of the individual
help file.

Thematic help
IGSS also provides thematic help. When there is a special theme that requires
special attention from the user, a dedicated help file is provided. Examples
include "Driver-Specific Help" and "Database Administration Help".

Where are the help files located?

The IGSS help files are located in the appropriate language folder in the installation path of IGSS, by default C:\Pro-
gram Files\Schneider Electric\IGSS32\V12.0. The help files are available in English at release time.

The paths to the help files are:



Language Path

English [IGSS InstallPath]\ENG

Danish [IGSS InstallPath]\DAN

German [IGSS InstallPath]\DEU

Translated help files

Selected help files have been translated into Danish. If you require help files in your language, please contact Sch-
neider Electric.

Help updates

The help files are continuously updated and improved. Check regularly with the IGSS Update in the IGSS Master.

4.3 Version Information (IGSS Help System)

© Schneider Electric, IGSS Version 12.0

The IGSS help files are based on software build number 10305 (initial release)

English help files

To update the help files, click the Update IGSS Software button on the Information and Support tab in the
IGSS Master. There must be a connection from the PC to the Internet. Every time IGSS Update is run, IGSS help
files as well as IGSS system files will automatically be updated on the PC from the web server at Schneider Electric.

You select the languages you want to update in the Tools menu of the IGSS Update form.

If you are not able to update the IGSS system directly via the Internet, the alternative is to download the updates
from the Schneider Electric website as zip files. These can then be transferred onto a CD or USB memory stick, which
is then the medium used to update on site.

After updating your IGSS installation , the build numbers in various IGSS modules may change to a higher num-
ber. This signifies that the module in question has been updated with newer files. Build numbers consist of four
digits, where the first digit represents the year and the last three represent the day number in the year in ques-
tion. The build number can be seen in the About dialog box which can be activated from the Helpmenu.

An example:

Build number = 10305
16 = the year 2016
305 = The 305th day of the year



Chapter 5: Glossary

A
Application menu

The Application menu is the first ribbon in the IGSS Master module. Click the icon to drop down the menu.
The menu contains items that were typically found in the File menu in previous versions of IGSS. In most
modules, an "Options" item allows the user to define global module settings. The Application menu was
introduced in the Microsoft Office 2010 package. It replaces the Application button (nicknamed Doughnut)
which was introduced in IGSS V7 and V8.

D
descriptor

A descriptor is the graphical display of an object. IGSS includes many types of descriptors including: -
Built-in standard symbols - Animated symbols (Symbol Factory library) - Graphics and animation - Draw-
ing symbols - Windows controls - ActiveX controls An IGSS object can be represented with different
descriptors on different diagrams.

R
Ribbon

The Ribbon is a new term/element in the Microsoft universe. The Ribbon replaces the well-known toolbars
in applications. The Ribbon provides quick access to the most commonly used functions in the application.
The Ribbon is divided into logical groups (the tabs) and each tab is divided into sections (the blocks in the
tab). The Ribbon is context-sensitive which means that only relevant functions are accessible dependent on
the current user action.

S
SCADA

Supervisory Control & Data Acquisition

U
UTC

Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating time in
most parts of the world. IGSS uses this time format internally in the database. You can switch between
UTC and local time by enabling or disabling the "UTC" field in various dialog boxes in the system.
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