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Chapter 1: Welcome to IGSS Supervise
1.1 What is IGSS Supervise?
The Supervise module is an integral part of IGSS (Interactive Graphical SCADA1 System). The
Superviseprogram is a tool for online process monitoring and operator control based on the user
interaction using mouse and keyboard.
A set of pictures - called process diagrams - present the plant or process graphically on your PC
screen. Each diagram consists of a static background picture and dynamic symbols representing the plant’s working components (motors, valves, flow meters, temperature scales,
etc.). States and values of these process objects, also called process components, are updated
automatically each time they change. Click-sensitive areas give you operator access to the
process diagram; they bring up another diagram or open a command box, for example.

u DIAGRAMS AND AREAS
The first thing for you to know is that the IGSS screen representation of your plant or
process is subdivided into areas and diagrams
Typically, a process diagram may be opened from the Diagram menu. The pictures
that you see in the Diagram menu all belong to the same part of the process, the
same area. If you select another area from the Area menu, you will see other pictures for selection in the Diagram menu.

u GRAPHS
Graphs opened from the Graph menu allow you to have process values presented in
curve charts so that you can evaluate their variation with respect to time. We distinguish static and dynamic graphs, graphs that are predefined by the system
designer and those that you can define yourself on-the-fly during online process monitoring.

u CONTROLLING PROCESS OBJECTS
The Supervise program allows you to directly intervene in the plant and process operation provided you have the right access authority assigned to your user name and
password.

1 Supervisory Control & Data Acquisition

Clicking on a dynamic object in a process diagram displays the principal characteristics of the component in the status bar at the bottom of the process diagram
window. At the same time a popup menu appears. It gives you direct access to the
Properties menu of the object and also displays the object commands which you
can trigger with a simple mouse click; commands such as opening or closing a valve,
adjusting a limit or setpoint value.

u HANDLING PROCESS ALARMS
When a component in the process is in some way faulty, if for instance a valve is
open when it should be closed or some level in a tank is too high, an alarm may be
triggered. In this case, the symbol representing the faulty component will typically
flash in red. Simultaneously, all details about the alarm situation are registered in the
alarm list. You gain access to this list by clicking the Active Alarms button in the
task bar at the bottom of the screen, or by double-clicking on the alarm icon.
In the alarm list, instructions on how to handle the alarm may be attached and you
yourself may describe how you resolved the problem in a note that is automatically
attached to the alarm.
The alarm can be acknowledged the moment it arises but remains in the list of alarms
until the error situation in the process is resolved. After that, the alarm is automatically transferred to the alarm log.
Throughout online process monitoring, and even when you turn to other programs on
your PC, the alarm icon will remain visible, always informing you about the current
alarm situation. Double-clicking on the alarm icon takes you directly into the alarm
list and the Alarm module for further alarm handling.

u PRINTING OUT PROCESS INFORMATION
All process information can be printed out, be it a screen dump of a complete process
diagram, the contents of the alarm list or log, a graph or the values of process
objects.

u PLANT REPORTS
The system has built-in facilities for generating operational reports and automatically
keeps track of when the last report was created and printed. These report facilities
are defined by the system designer and are usually made available to the plant operator in the form of User Programs.
Reports may be displayed in several formats. In most cases, the standard IGSS
reports will fulfil your documentation requirements. Special requirements can be

taken into account by customised reports which again are called up by the operator
under the menu function User Programs.

1.2 Technical support
In case you need technical support, please contact your local system integrator.
The system integrator knows a lot about the IGSS system and will help you find the optimal
solution to the needs of your plant.
In turn, the system integrator has direct access to technical support from Schneider Electric.

1.3 The User Interface
The IGSS Supervisescreen
Your IGSS Supervise screen typically looks like this.

Click the item descriptions to get more detailed explanations:

Menus
The following menus are available in the Supervise program. To get an explanation about the
general purpose of the menus, click on the menus in the illustration below.

For a more detailed explanation of the individual dialogues, open the dialogue in question, click
the
in the upper right hand corner of the dialogue and then - with the
to the mouse pointer - click the item you want information about.

symbol attached

Operator control using the keyboard only
The plant components may be controlled and operated from your PC operator station, using
mouse or keyboard or a combination of both.
If you only use a keyboard for online operator control, follow the general Windows conventions
for keyboard operations. Some of them are explained below, for more detailed information
please consult the Windows User manual or Windows online help facility.

How to …

Procedure…

Pull down a menu

Press the ALT key and the underlined letter in the menu name.

Close a menu

Press F10 or the ALT key.

Give a command

In the open menu or dialogue, enter the underlined letter in the command name
or
use the arrow keys to select the command and confirm with ENTER.

Select an option

Within a dialogue, use the TAB key or the arrow keys to go from one option to
the next. Always confirm your selection with ENTER.

Close an application

With ALT+F4 you close the currently active application.

Tip: Your process control system may be provided with special function and control keys.
These features depend on the definitions made by your system designer. He/she may have
included global function keys that apply to the entire control system, and function keys that are
tied up with a specific process diagram.

Chapter 2: Starting and Stopping the Configuration
2.1 Connect to the IGSS Server
Connecting for the first time
Once the configuration is running on the IGSS Server, the operator station can connect to the
server and download the configuration.
Click the Start button on the IGSS Master > Home tab to start the IGSS configuration.

Result: The Operator Connect Options dialogue appears.

Show picture

3. Make sure that the name of the server is correct and click the Continue button.

Result: A message will appear prompting the operator to download the configuration from the
server.

Show picture

4. Click Yes. The configuration files are downloaded.
5. To start the configuration, click here.

Tip
l

If the operator station will always connect to this server, you can select the Don't show this dialog again
check box.

l

If the operator station will connect to multiple servers, click here.

2.2 Start and stop the configuration
Once the operator station is connected to the IGSS Server, the configuration can be started and
stopped as follows.

Typically controlled by the IGSS Server
Once an IGSS configuration has been commissioned, changes will typically be implemented on
the IGSS Server. These changes will be automatically downloaded to the connected operator

stations. On the individual operator station, IGSS can be set up to display a message when the
configuration on the server is updated. Otherwise, the changes are automatically downloaded.

Start the configuration
IGSS can be set up to start a configuration in three different modes:
l

Manual (the operator must click Start to start data collection and subsequently Supervise to view the process)

l

Auto (data collection starts automatically, but the operator must click Supervise to view the process)

l

Supervise (data collection starts and the operator is taken straight into the Supervise module)

If you need to start the configuration manually, open the File menu and select Start Configuration.
This is the same as clicking the Start button in the IGSS Master.

Stop the configuration
If you need to stop the configuration manually, open the File menu and select Stop Configuration.
This is the same as clicking the Stop button in the IGSS Master.

Only for authorized users
Starting and stopping the configuration are seen as system commands. If access control is
enabled, the current user must have the appropriate rights to start or stop the configuration.

2.3 Control data collection
You can control the acquisition of up-to-date process data, always assuming of course that you
have the appropriate access rights for these actions.

1. In the menu bar, go File → Status and Control….
2. The Data Collection Control dialogue opens showing you the current status of data collection and logging.
3. The following methods of influencing data collection are available:
Data collection
Data logging
Extended log
One manual scan

4. Select Start or Stop or Yes or No.
5. Confirm with

for the changes to take effect.

l

All data collection modes are password protected. You will have to enter the authorized password before you
can make any changes in the Data Collection Control dialogue.

l

For direct guidance on each individual item, option or entry of a particular dialogue, use the What’s This?
Help facility: while you are in the dialogue, click the
the item you want information about.

in the upper right corner of the dialogue, then click

2.4 Switch to another IGSS Server
In some cases, an operator must have access to multiple IGSSconfigurations residing on different IGSS Servers.

Switch to another server

1. In the Server menu, select the name of the server you want to switch to.

Result: The operator station disconnects from the current server and connects to the new
server. The configuration from the new server is downloaded to the operator station.

Edit the list of IGSS Servers
When an operator station connects to an IGSSServer, the operator chooses the appropriate
server in the Operator Connect Options dialogue. The drop-down list will contain the names
of servers typed in directly here or edited in the Edit Server List dialogue.

1. In the Server menu, select Edit Server List.

Show picture

2. Do one of the following:

l

To add a new server, place the cursor in the input field. Type the IP address of the new
server and click Add.

l

To rename a server, select the name. Type the new name and click Rename.

l

To delete a server, select the name and click Delete.

3. Click OK to save the changes.

Result: When you open the Server menu, the updated list is shown at the bottom.

Chapter 3: Logging In and Out of the System
3.1 Login and access rights
All plant components displayed in process diagrams may be individually protected. The system
designer may decide for each individual object whether or not a particular operator with a particular user name and password has the right to give a command or change a value for a particular plant component.
When you log into the Supervise program for online operator access and process control, you
are automatically given the access rights defined by the system designer for your user name
and password. Provided you have the authority, you may change your password in the File →
Change password… menu.

3.2 View user login/logout in Object Historian
You can view user login/logout information in the Object Historian without choosing any
objects for inspection. But the typical scenario would be to combine the event types, allowing
you to view which user was logged in when a certain event occurred.

1. Under Time interval, define the relevant start and end time. IGSS goes back one hour by default.
2. Under Event types, select the User login/logout check box.
3. Click Query data to view the data in the list.
4. For details on the individual columns in the list, click the

button, then click inside the list.

Show picture

To be able to view user login/logout, user administration must be enabled in the System
Configuration form and users must have been defined in the User Administration form.

3.3 Registration of user name
When user administration is enabled, the user name is registered in the following places.

Title bar of Supervise
The name of the active user can be shown in the title bar of Supervise as [xxx]. At a glance,
the operator can see whether he's logged in with the right user name or if he's logged in at all.
This option must be enabled in the System Configuration program.

The Object Historian
The user name is registered in the Object Historian as follows:
l

Outgoing commands under LOG data
(commands to digital objects, change of setpoint, change of alarm limits, etc.)

l

Acknowledgment of alarms under ALM data

l

Login and logout information under User login/out

The Alarm List
When a user acknowledges an alarm, it is registered in the User field in the Alarm List.

The Event List
When a user logs in and out of the system, it can be registered in the Event List.
In the Tools menu of Supervise, choose Events and add the User login/logout event.

Chapter 4: Navigating the Configuration
4.1 Areas, diagrams and graphs
Areas
An IGSS configuration can be divided into a number of areas. The area is typically a logical section of the monitored process, for example, a sub process.
Open the Area menu to switch between the areas of the configuration. In all IGSS configurations, an area named Global will be available. The remaining areas can be named freely.

When the configuration is started, the initial diagram is shown. When you switch to another
area, the initial diagram for that area is shown. When you choose an area, all the diagrams and
graphs in that area become available. In other words, only one area can be active at a time.
Each area contains a number of diagrams (process pictures), graphs and objects (the actual process components).

Diagrams
The diagram is a graphical process picture showing a section of the monitored process. The Diagram menu shows the diagrams available in the active area. Some diagrams may not be visible in the menu. In that case, choose Open to browse for those areas.
Typically, an overview diagram will be the initial diagram of an area. From that diagram, buttons lead to the other diagrams in that area. Here's an example from the IGSS Demo Configuration.

On every subdiagram, the system designer will typically place buttons allowing the operator to
navigate to related diagrams. Another way of navigating is using the Home, Back and Forward
buttons or the next/previous buttons on your mouse (if included on your mouse).
When a diagram is open, there's a checkmark beside its name. Multiple diagrams can be open
simultaneously.

Graphs
A graph is a chart showing the process values of a number of objects. The lower part of the
Graph menu shows the predefined graphs available in the active area.
When a graph is open, there's a checkmark beside its name. Multiple graphs can be open simultaneously.

4.2 Panning
What is panning?

The pan function lets you view wide diagrams (panoramas) on a narrower screen for example if
you have a long production line represented on a single diagram in IGSS, but only one screen
to work with, the system integrator would then use the pan function to allow you to select which
section of the diagram you want to view.

Click here to view an example with pan

How to open the Pan window
Normally the pan window will automatically be displayed when a diagram, wider than the available screen(s), is opened. This means that if, for example the system integrator has created a
diagram which fits on 2 screens, the second screen must then be disabled in Windows before
IGSS will use the pan function.

The Pan window can also be manually opened (still only available when the above condition is
met):

1. Select the View tab.
2. Click Show Pan Control .

Right-click menu
If you right-click on the Pan window, the following menu will appear. click on any of the menu
items to view a description of its function.

4.3 Reusable diagrams
Same diagram – multiple sets of objects

As an operator you may come across reusable diagrams. This special type of diagram allows
the system designer to show multiple sets of objects on the same diagram. When you activate
a reusable diagram either from the Diagram menu or from a button, the Choose Objects to
Display dialogue appears.
Select the set of objects you want to show and click OK.

The title bar of the reusable diagram
When a specific set of objects has been selected, the diagram appears showing the name of the
set in the title bar.
To choose another set of objects, press F5 or choose the name of the diagram in the Diagram
menu.

Reference to reusable diagram

The system designer can choose to link directly to one of the sets of objects available. The operator will thus click a button with the name of the set and go straight to the reusable diagram
without seeing the Choose Objects to Display dialogue. The only indication that this is a
reusable diagram is the name of the set in the title bar.

4.4 Home, Back and Forward buttons
To use these buttons, activate the MRU Toolbar in the View menu.

The Home button
Press the Home button to go to the initial display of the IGSS configuration. The initial display
is set by the system designer and is typically an overview diagram.

The Back button
Press the Back button to return to the last diagram you viewed. Click the arrow to view the list
of previously viewed diagrams.

The Forward button
Press the Forward button to go to the diagram you last activated from the current diagram.
Click the arrow beside the button to view the list of diagrams previously activated from here.

Using the mouse
You can also use the next/previous buttons on your mouse (if included on the mouse) to navigate between the diagrams.

4.5 Most Recently Used toolbar
Activate the MRU Toolbar in the View menu.

It is used to navigate to the most recently used objects in the configuration. It shows the following:

l

The last five values / commands

l

The last five activated standard objects (analog, digital, string, table, counter)

l

The last five activated diagrams

l

The last five activated graphs

l

The last five activated areas

Note
When sending commands from the MRU Toolbar a confirmation dialog will appear, where the
command has to be confirmed, before it will be sent out. If the selected object is using Safe
Commands, the respective Safe Command dialog will appear when a command is sent from the
MRU Toolbar.

The confirmation dialog may be disabled by going to the Windows registry and setting the value
DefRun32 -> ConfirmMRUValues = 0.

4.6 Find an object using Open by Name
The Open by Name function
The Open by Name functionality in IGSS is very versatile. Use this function when you know
the name or part of the name of an object, but do not know which diagram it resides on. You can
also use it to view a list of objects with common properties, f.ex. all objects based on a specific
template, all objects sharing the same alarm number, etc.

1. Go to the Edit menu and select Open by Name or press CTRL + E.

The Object Browser
The Object Browser shows you a tree view on the left and a list of objects on the right. The
list of objects is filtered dependent on what you select in the tree view. When you open the
Object Browser, it shows all the objects in the configuration.

Examples
Here are some examples of use. We recommend that you start with the "Browse the tree view"
procedure and follow the instructions.

Standard functions
Browse the tree view
Browse the list of objects

Advanced functions
Filter the list with wildcards
Change the tree structure

4.7 Save View
You can save the current view of the Supervise module, saving all the position and placement
of all currently open diagrams and graphs.

You can restore the saved view at a later date and continue the process monitoring from where
you left off.

• To save the current view of the Supervisemodule, in the menu, click View > Save View
• To restore a previous view into the current Supervise module, in the menu click View >
Restore View

Object values

Object values are not saved with the diagrams. When the saved view is restored, object values
in the diagrams and graphs will be populated with the actual values retrieved from normal process monitoring.
If you want to view historical object values in the diagrams of the Supervise module, you can
click the Playback button to open and set up the IGSS Player.

The maximum number of open diagrams setting in the System Configuration form will
limit the number of open diagrams in the Supervisemodule, including open graphs.
Any diagrams and graphs that have been removed from the configuration after the view
has been saved will not be displayed by restoring the view.

See Also
"About IGSS Playback" on page 67

Chapter 5: Controlling Process Objects
5.1 Open a process diagram
1. In the menu bar, click the Diagram option.
2. You see a list of all process diagrams available for the selected area.
3. Click the diagram you wish to open.
4. This diagram is now the active one.

Note: Up to 4 process diagrams can be open simultaneously, but only one diagram is active at
any one time.

5.2 Find out the purpose of a process object
1. In the open and active process diagram, place the mouse pointer on a process component which can be
a digital process object such as a valve, or an analog process object , such as a temperature scale.
2. The object name and possibly a short description are displayed.

l

5.3 What happens when you click on a process object
Using the mouse, you have several possibilities to enquire about or send a signal to a process
component (object) displayed in the process window:

This fea- Allows you to …
ture…
Clicking … view the elements name and the available commands, if it is a digital element, and its possible charLEFT or acteristic values (actual and limit values), if it is an analog element. Provided that you have enabled
RIGHT …
View → Commandmenus in the Edit menu you are given direct access to all commands and values
associated with the selected object in a small selection box which opens up right next to the selected
object.

Result: (Click on the box entries to get more detailed information about their purpose.)

Provided that you have the right access authority , you can now operate the element: A mouse click on
the element’s name v17 or air in the command box takes you directly into the Object Properties dialogue.
Clicking
RIGHT…

… enquire about and modify the properties of the selected process object. The
button
appears. A right or left mouse click on this button takes you into the Object Properties dialogue:
Tip: For a more detailed explanation of the Object Properties dialogue, open the dialogue, click the
in the upper right hand corner of the dialogue and then - with the
mouse pointer - click the item you want information about.

symbol attached to the

Note: With View → Command menus switched off, a single left click on the object will have
no effect at all. A double click on the left mouse button will take you directly into the Object
Properties dialogue.

5.4 Give a command on a process object
1. In the menu bar, enable the option

View → Command menus.

2. In the active process diagram, left click on the process object you wish to operate.

Digital object:
A box appears giving you the possible commands. The currently valid command is
highlighted.

1. Click the new command.
2. The box closes automatically and the digital object adopts the new status.

Analog object:
A box appears giving you the characteristic values, such as
PV = process or actual value
HA = high alarm value

LA = low alarm value

1. Click on the value you wish to change.
2. A selection box opens.
3. Using the up and down buttons

, increase or decrease the value and confirm with

.

Tips
l

l

With View → Command menus switched off, a single left click on the object will have no effect at all. A
double click on the left mouse button will take you directly into the Object Properties dialogue which
allows you to change commands, settings and values for the selected object.
Giving a command on a process object requires that you have the access right for these actions as they will
most certainly cause changes in the plant or process.

5.5 Add an object note
5.6 Purpose
The object note is designed as a communications medium between operators. If an operator
needs to communicate an object-specific situation to the other operators, the object note is
ideal.
The object note is treated as an alarm and when the note is created, the alarm number 96
appears in the Active Alarms form. The other operators can see there is a note on the object
and can acknowledge and terminate the object note alarm from the object properties form in the
Supervise module.

Create the object note

1. Right-click the relevant object on the diagram and select Object Note.
2. On the Edit Object Note tab, type the object note in the Note group.
3. Click the OK button to create the object note.

Result: Alarm number 96 now appears in the Active alarms form and the symbol starts blinking on the diagram.
In this example, the operator writes "This pump must be serviced ASAP. I've contacted the service engineer and he will be here on Monday. If any other components need to be serviced,
please contact the service engineer.

Show picture
Alarm number 96
Every time an object note is created, alarm number 96 is associated with the object and
appears in the Active alarms form.

Show picture
By default, the alarm color is blue and the priority is 3. The object on the diagram will turn blue
and the symbol will blink. You can change the characteristics of the alarm number in the Definition module.
If you have selected the Use marks instead of alarms to indicate object note check box
in the System Configuration form > Supervise and Languages tab, an object note will be
indicated by a triangle icon in the upper right-hand corner of the object. The color of the triangle icon is the same color as defined for the alarm number 96.

Acknowledge the alarm

1. Right-click the relevant object on the diagram and select Object Note. Notice that there's a checkmark
indicating that an object note has been created.
2. Click the Acknowledge button to acknowledge the object note alarm.
3. Click the OK button to close the Object properties form.

Result: The alarm is now acknowledged and the symbol stops blinking on the diagram.
The alarm can also be acknowledged from the Active alarms form. If user administration is
enabled, the user name will be shown just above the note field.

Show picture
End the alarm

1. Right-click the relevant object on the diagram and select Object Note.
2. Click the Acknowledge button to acknowledge the object note alarm.
3. Click the OK button to close the Object properties form.

Result: The text in the note field is cleared and the alarm is ended. The alarm disappears from
the list of Active Alarms and moves to the Alarm Log.
Show picture

Notice that the acknowledgment time is shown to the left.

5.7 Start/stop data collection and logging on an object
Start / Stop logging
If logging is not enabled for a certain object, the operator can switch it on manually as follows.

1. Click the object symbol on the diagram.
2. In the command menu, select Properties.
3. Click the Data Collection & Logging tab.
4. Under Logging do the following:

l

Under In select Yes to start logging of incoming process values. All changes will be
logged.

l

Under Out select Yes to log outgoing commands.

l

Under Print select Yes to print log values directly.

5. Click OK to save the changes.

Start/stop data collection

1. Click the object symbol on the diagram.
2. In the command menu, select Properties.
3. Click the Data Collection & Logging tab.
4. Under Data collection, do the following:

l

Select Start to start the data collection

l

Select Stop to stop the data collection

5. Click OK to save the changes.

Note

If the data collection is stopped, the object becomes passive. The color of the object changes to
indicate that data collection has been stopped. This color is predefined by the system designer
in the Definition program.
In the View menu, select Passive Objects to view the list of passive objects in the configuration.
From this dialog box you can activate the data collection again.

5.8 Handle passive objects
A passive object is an object for which data collection has been stopped. The color of the object
changes to the passive color predefined by the system designer in the Definition program.
Passive objects can be re-activated as follows:

1. In the View menu, select Passive Objects.
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2. To re-activate the passive object(s), do the following:

l

To re-activate all passive objects, click the All button. The dialog box closes automatically.

l

To re-activate one object, select it and press the arrow button.

3. Click OK to save the changes.

Chapter 6: Handling Alarms
6.1 Recognise alarms
An alarm situation is indicated in three ways, depending on the definitions made by the system
designer:

1. The alarm icon is automatically incremented.
2. In the process diagram, the symbol representing the process object changes color and/or begins to
flash.
3. The diagram’s message line displays a message about the nature of the alarm.

To view the alarm, please…

1. Double click on the alarm icon

.

OR
2. Click

displayed in the taskbar at the bottom of the process diagram.

3. Left click of the flashing symbol in the process diagram. A selection box appears next to the symbol,

providing you with the options

, amongst others.

Notes
l

The first two actions take you directly into the Alarm List and the Alarm program with
all its alarm handling, alarm reporting and editing facilities.

l

Once you are in the Alarm program you have full access to the relevant help functions.

l

Action no. 3 allows you to acknowledge the alarm, to view the associated message
text and/or enter your own comments, but you stay in the Supervise program.

6.2 Acknowledge alarms
1. Double click the alarm icon.
2. You are directly taken into the Alarm List which displays all pending alarms - acknowledged and unacknowledged.
Unacknowledged alarms are usually shown in red.
3. In the list, select the alarm you wish to acknowledge.
4. In the menu bar, select Actions → Acknowledge.

Notes
l

This way of acknowledging an alarm takes you directly into the Alarm List and the
Alarm program with all its alarm handling, alarm reporting and editing facilities.

l

Once you are in the Alarm program you have full access to the relevant help functions.

6.3 View the alarm text
1. In the process diagram, click the object which is in the state of alarm.
2. In the menu bar, choose Edit → Alarm text.
3. The alarm text is displayed next to the faulty process object.

Tip:
For more detailed information on the alarm situation:

- press

in the taskbar or

- double click on the alarm icon

.

Both actions take you directly into the Alarm program with all its alarm handling,
alarm reporting and editing facilities.

Note: Once you are in the Alarm program you have full access to the relevant help functions.

6.4 Reading and editing Alarm notes
Alarm notes are created in the Alarm module and are attached to the individual alarm for the
specific object. You can read or edit any notes that have been created for the individual alarm
on the object in the Supervise module.

IGSS-based alarms
For IGSS-based alarms, only one alarm note will be displayed for the object because only one
alarm per object will be displayed for IGSS-based alarms. The alarm displayed will be the alarm
triggered by the highest or lowest value of the object, respectively.
For example, if the value of an analog object exceeds not only the High Limit, but the High
Alarm as well in one scanning pass of the object, then only the high alarm will be displayed on
the object.

Edit or read an alarm note

1. In the Supervise module, right-click the object in alarm and select Alarm Text to
open the Object Properties form.
2. In the Object Properties form, click the Edit Alarm Note tab.
3. On the Edit Alarm Note tab > Note group, you can read or edit the alarm note and
click the OK button to save any changes.

You can see details for the present alarm, such as alarm number, alarm start date and
time and alarm text in the All alarms on object group.

Digital (multiple) alarms
Digital alarms (alarms administered by PLC settings) enable simultaneous alarms to exist on
the object and you can therefore read and edit multiple alarm notes on the object by selecting
the desired alarm in the All Alarms on object group on the Edit Alarm note tab.
When an alarm is acknowledged and ended, the alarm note will stay attached to the alarm, but
will not be displayed for editing or reading on the object.

Edit or read multiple alarm notes

1. In the Supervise module, right-click the object in alarm and select Alarm Text to
open the Object Properties form.
2. In the Object Properties form, click the Edit Alarm Note tab.
3. On the Edit Alarm Note tab > All alarms on object group, select the alarm you
want to read or edit the alarm note for
4. In the Note group, you can read or edit the alarm note for the selected alarm and
click the OK button to save any changes.

You can see details for the present alarm, such as alarm number, alarm start date and
time and alarm text in the All alarms on object group.

6.5 Alarm indication on diagrams
When the alarm occurs
When an alarm occurs, the object's symbol will typically change color and start blinking. Also a
sound may be associated with the alarm. The system designer defines the alarm colors and
behavior in the Definition program.
On this picture the two objects, q1 and q3 are both in alarm.

When the alarm is acknowledged
The alarm can be acknowledged from the Alarm List or directly from the diagram by clicking
on the object and selecting Acknowledge Alarm in the command menu.
The object's symbol will typically change color and stop blinking. The acknowledge color is
defined by the system designer.

Alarm transparency
To provide the optimal overview for the operator, IGSS has a built-in feature called alarm transparency. It means that an alarm appearing on a diagram which is referenced by another diagram will be indicated in both places.

Example

The objects above, q1 and q3, are both located on the Dairy diagram. On the PlantTypes diagram there's a button referencing this diagram. When an object on the Dairy diagram goes in
alarm, the button will start blinking. By default, the alarm color will be blue and the alarm priority 3, but the system designer can change this in the Definition program. Alarm no. 1 is
used to achieve the alarm transparency effect. However, this alarm is for internal use and will
not be visible in the Alarm List.

6.6 Inhibit alarms
If a process component is being serviced or renders irrelevant alarms for other reasons, these
alarms can be temporarily inhibited. The operator can choose to inhibit all alarms for the object
or only specific ones.

Inhibit specific alarms
To inhibit specific alarms on an object, do the following:

1. Click the object on the diagram.
2. In the command menu, select Inhibit Alarms.
3. In the list select the check box beside the alarm(s) you want to inhibit.
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4. Click OK.

Result: Alarm no. 92 "Alarm Inhibit (specific alarms)" appears in the Alarm List.

Tip
To inhibit a specific alarm that is already active, right-click the alarm in the Alarm List and
select Inhibit Alarm.

Inhibit all alarms
To inhibit all alarms on an object, do the following:

1. Click the object on the diagram.
2. In the command menu, select Inhibit Alarms.
3. At the top, select the Inhibit All Alarms check box.
4. Click OK.

Result: Alarm no. 91 "Inhibit Alarms (all alarms)" appears in the Alarm List.

Tip
To inhibit all alarms, right-click in the Alarm List and select Inhibit All.

To reactivate inhibited alarms
In the Supervise program, do the following:

1. Click the object on the diagram.
2. In the command menu, select Inhibit Alarms.
3. Clear all check boxes. You can use Clear All button.
4. Click OK.

OR

In the Alarm program, do the following:

1. Right-click the relevant alarm (no. 91 or 92). A checkmark will be visible beside the Inhibit Alarms
menu item.
2. Select the Inhibit Alarms item.

6.7 Inhibit WinPager alarms
The IGSS Winpager module allows operators to receive plant alarms as SMS messages on
their mobile phones.
In some cases, you may want to inhibit the dialing out of these alarms.

Inhibit WinPager dialout from Supervise

1. Click the object on the diagram.
2. In the command menu, select Inhibit Alarms.
3. Select the Inhibit WinPager dialing check box.
4. Click OK.

Result: Alarm no. 93 "WinPager Inhibit" appears in the Alarm List.

Inhibit WinPager dialout from Alarm

1. Right-click the alarm in the Alarm List.
2. In the popup menu, select Inhibit WinPager.
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To reactivate WinPager-inhibited alarms

1. In the Alarm List, right-click alarm no. 93 and select Inhibit Winpager.

6.8 Change Alarm Priority
You can change the priority of an alarm in the Supervise module.

The highest alarm priority is 255 and the lowest priority you can assign an alarm priorities is 1.

In some installations, operator access to the Alarm Detail s form can be restricted
through user administration and internal security policies.

To change the alarm priority of an alarm

1. In the Supervise module, click Tools > Alarms to open the Alarm Details form.
2. In the Alarm Details form, select the alarm number you want to change the priority
for
3. Select the Edit button to open the Edit Alarm Description form.
4. In the Priority field, enter the new alarm priority and click the OK button to close
the Edit Alarm Description form.
5. In the Alarm Detail s from, click the Close button to save the new alarm priority.
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Chapter 7: Working with Graphs
7.1 Object types supported
A graphical plot shows the variations in states or values with respect to time and thus gives a quick overview of the characteristic behavior of a process component. A graph chart may contain the characteristics
of up to ten process components (IGSS objects).
Process components of the following types may be shown in the form of a graph:

analog
digital
table
counter

7.2 Open a predefined graph
There are several ways for you to call up a predefined graph.

1. In the menu bar, choose Edit → Open by Name
2. In the menu bar, open the Graph menu and choose one of the graphs listed in the lower section of the menu.

3. In the process diagram, double-click on the graph symbol

or the click-sensitive reference area.

Note: Methods 1 to 3 take you into the Define Graph Period dialogue.

7.3 Create your own graph
For any of the four types of IGSS objects that can be shown in the form of a graph (analog , digital , table
and counter ), you can display the characteristics of that object in the form of a graph.

1. In the menu bar, select Graph > Create Dynamic Graph.
2. The Object Selection for Dynamic Graph form appears in which you select the objects to be shown in a curve
chart.

See Also
"Change the graph display online" on page 42
Create a graph directly from the process diagram
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"Switching data source from LOG to BCL " on page 40
Define the graph period
"Edit the graph parameters" on page 37
Object selection for the display of dynamic graphs
"Object types supported" on page 36
"Open a predefined graph" on page 36
Open by Name
Rezoom
"Save graph data" on page 43
"The graph window" on page 41

7.4 Edit the graph parameters
Depending on the setup of your control system and the access rights given to you, practically all predefined graph parameters may be modified during the running of the plant or process. From the ten curves
that may be shown in one curve chart select the one you wish to edit.

The Define Graph Parameters dialogue

Tip: You can quickly open this dialogue from within a graph chart by selecting the curve you wish to edit
and then right-clicking on the mouse. In the selection box, select the command Edit Parameters…

Dialogue contents

Name Name of the selected curve. Usually defined by the system designer and not accessible to the operator.
Headline Descriptive heading of the selected curve. Usually defined by the system designer and not
accessible to the operator.
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Autostart If ON, curve tracing begins immediately when the graph window is opened during online supervision, without you having to define or select any parameters at all. It is the system designer who defines
whether Autostart is active or not. You have no access to it.
Start offset You may enter an offset with respect to the begin time selected in the Define Graph Period
dialogue, or with respect to the current date and time, if this has been selected as the starting point for
curve tracing.
Example: Start offset = 01:08:00 and the start time is set to the current date and time.
Result: curve tracing begins 1 day and 8 hours backdated from the current date and time.

Window period is usually defined in the Define Graph Period dialogue, where you also set the date and
time of day at which curve plotting is to begin and end. However, you can modify the window period in this
dialogue. It is the visible period of the traced graph data.
X divisions: Here you set the number of divisions for the x-axis (the time axis).

Source The source of information for the curve may be a LOG file or a BCL file . LOG files hold data that
goes back in time for a maximum amount of hours which can be defined in the System Configuration
form > Files tab. The maximum number of hours LOG data can be stored is 100,000 hours, roughly 11½
years. If you wish to see a curve that is more historic than that, you have to switch to BCL as the data
source.
Start precision Precision for the start date and time. The Start offset must be subtracted from the current date/time, and the Start precision added.
Examples: Starting point is the current date/time and the offset is set to 01:08:00 (1 day
and 8 hrs).
The graph is opened on January 15 at 10:25:17.
Start precision has been set to seconds
.
Result: Curve plotting will start exactly on January the 14th, exactly at 02:25:17.
Start precision has been set to hours
.
Result: Curve plotting will start on January, the 14th, exactly at 2 a.m., i.e. at 020:00:00.
Minutes and seconds are not taken into account in this case.
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Time resolution The selected time resolution, expressed in milliseconds, applies to the entire curve
chart, i.e. to all curves displayed in the chart. If it is set to automatic
, then the smallest scan
interval (LOG files) or the smallest base interval (BCL files) of the displayed curves apply.
l

The chart contains three separate curves with scan intervals of 2, 10 and 10 seconds respectively which are usually
defined by the system designer when he specifies the characteristics for data collection and logging. The curve chart
therefore has a resolution of 2 seconds, provided that you have selected

.

With Automatic being switched off, you can overrule the predefined scan interval by selecting one of the
available time resolutions for the curve chart.
l

The automatic time resolution has no meaning if data communication between the process and the process control system
is event controlled.

Show Details Here you choose whether the curve chart is to display a detailed description of each graph
at the top of the graph window. With
, you will see the following information about all the
curves contained in the chart: the range of the y-axis, a plain text designation of the graph, and the actual
value. With Show Details switched off, the top line just displays the current value and the names of the
objects whose response is represented by the curve.

Object Name indicates the name of the object whose characteristics are shown in the form of a graph.
This designation is predefined and cannot be changed.
Index Here you choose which of the object’s values shall be plotted by the curve.
Options for analog objects: HL High Limit
PV Process Value
SP SetPoint
LL Low Limit
LA Low Alarm
Options for table objects: whole number between 1 and 10, representing the number of the table
entry which is to be shown in the form of a curve
Options for digital objects: current status, preset and not accessible by the operator
Options for counter objects: current count value, preset and not accessible by the operator

Y-max, Y-min Maximum and minimum values for the y-axis.
Default: dynamic area defined for the object
Y-del . Number of indicated divisions on the y-axis.
Default: 10 divisions
Y-axis Here you can choose whether a particular y-axis is to be shown or not. This is useful if you have
several curves sharing the same y-range so that it might be superfluous to show all of them in the chart.
Select and deselect the display of y-axes as required.
Wide If enabled

, the corresponding graph will be shown with a thick line.

Smooth If enabled , the corresponding graph will be generated on the basis of the average values. Otherwise it traces the actual (process) values and connects them by short straight lines, which might produce a
rather unsmooth curve.
Bars
Patt. & Color Here you choose the color and filling pattern of the area covered by the curve.
Background Colors for the graph and window backgrounds.
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Tip: For direct guidance on each individual item, option or entry of the dialogue, use the What’s This?
Help facility: while you are in the dialogue, click the
in the upper right corner of the dialogue, then
click the item you want information about.

7.5 Switching data source from LOG to BCL
If the IGSS configuration is set up to store LOG data for any length of time, dynamic graphs that contain
start date and times which query objects containing log data may result in slow performance when rendering the graph as the IGSS system needs to traverse many old LOG files and display data. The slow performance will be worsened if the specified graph start date is far back from today's date. Changing the data
source to BCL data will improve graph performance.
You can specify when the data source for dynamic graphs will switch from LOG data to BCL data by defining
a threshold value in the Auto optimize dynamic graph field on the Supervise and Language tab in
the System Configuration form.
If the start date and time specified for a dynamic graph is older in hours than the value in the field and all
the selected objects in the dynamic graph contain BCL data, the data source for the dynamic graph will
switch from LOG to BCL data.
If the value in the field is 0, the dynamic graph will not switch from LOG to BCL data regardless of the specified start date of the dynamic graph.
Only one atom from an object will switch data source from LOG to BCL, the data source for all other atoms
in the graph will still be LOG data.
The atoms which can switch data source are:
l

Analog: The Process Value Atom

l

Digital: The State Atom

l

Counter Object: The Count Atom

l

Table Object: The Table atom (all index values of the table object)

Data reduction methods

BCL data only contains reduced values, generated by defined various data reduction methods set up on the
object atom. Only one reduced value will be displayed in the graph when switching data source to BCL. If
there are multiple data reduction methods defined for the object, the first defined data reduction method on
the prioritized list below will be used to display the value in the graph.

1. Actual
2. Average
3. Minimum
4. Maximum
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5. Sum
6. Change
7. Difference

Thus if an object contains the Average, Minimum and Difference data reduction methods, the Average
value will be displayed in the dynamic graph when switchng data source from LOG data to BCL data.

7.6 The graph window
Show Me
Use
You can use the graph window during supervision to evaluate the state of one or more process components
over time and to detect adverse trends at an early stage. IGSS is capable of combining current trends and
historical data in the same graphs. You can thus see at a glance what happened in the process just before
and immediately after an intervention.

Description
A graph can be predefined by the system designer or created on-the-fly by the operator during supervision.
A predefined graph belongs to an area and can be accessed from the Graph menu when the parent area is
active.
You may specify or modify the properties of a graph in the Define Graph Parameters dialogue. Click
here for details

Graph window elements
The graph window contains the following elements. Click the Show Me button at the top of this window to
see the location of each element.
The graph window contains the following elements.

Element

Description

Title bar

contains the following elements:

l

·
System menu box Click this button to access a menu from which you can
move, resize, minimize, maximize and close the current graph window or go to the
next graph window.

l

·

l

·

Minimize button Click this button to minimize the graph window.

l

·

Maximize button Click this button to maximize the graph window.

l

·

Close button Click this button to close the graph window.

Name and/or description of the graph, for example, Temperature_T1.

Graph area

shows the graph according to the properties specified in the Define Graph Parameters dialogue which is accessed by right-clicking on the graph.

Horizontal
scroll bar

allows you to scroll through graph data on the time scale. This means you can look backward
in time and display past time responses of the process object by moving the scroll bar to the
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left.
Graph
status bar

shows the current date and time and the numerical values of the y-variables displayed in the
curves of the chart.

7.7 Zoom in and out of graphs
The zoom function allows you to enlarge a particular section of the graph window in order to take a closer
look at the time response at a particular instant.

1. Place the cursor at the upper left corner of the area to be magnified, press the left mouse button.
2. Keeping the mouse button depressed, drag the mouse downward to the lower right until the area under investigation
is included in the frame.
3. Release the mouse button.
4. The marked area is now retraced with new scales for both the time and the y-axis.

To return to the original size…

1. Right-click and select Rezoom.

7.8 Look at another time period
1. The panning function allows you to display another time slice in the graph window. This is useful if you wish to see the
time response of a process object in a particular period in the past (historic data).
2. Move the scroll bar to the left as far as required.
3. The time axis now displays a different time slice somewhere in the past.
4. Repeat the procedure as often as you like in order to look at different periods of time.

7.9 Change the graph display online
1. You may change the appearance of the graph window during online operation. The following actions are possible:

l

Deactivate a graph

l

Fill in the area covered by a curve
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Note: For more changes of the chart parameters, please open the Define Graph Parameters dialogue.
In the menu bar, choose Graph → Edit Graph.

7.10 Show the graph values in the form of a list
1. Open the graph window you wish to investigate.
2. Click on the RIGHT mouse button.
3. In the popup menu, select Show Values List.

Result: The list Graph Values opens listing the plotted values in numerical form together with the time of
plotting.

Note
The graph values can be exported to a Comma Separated Values (.csv) file for further processing.

7.11 Save graph data
1. In the opened graph chart, select the curve you wish to save.
Click here to find out how to open a graph.
2. Click the RIGHT mouse button.
3. In the popup menu, select Save as Static Graph or Save as Dynamic Graph.

Note: A predefined graph can be saved as a static graph. A dynamic graph can be saved as both types.
The dynamic graph will be updated with new values, whereas the static graph is a snapshot.

4. A Save As… dialogue appears letting you choose where and under what name to save the
graph.

7.12 Export graph values
If you want to further analyze or make calculations with the graph values, they can be exported to a
Comma Separated Values (.csv) file.
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1. Open the graph you want to export.
2. Right-click inside the graph.
3. In the popup menu, select Show Values List.

Show picture

4. Click Export as CSV.
5. In the Save As dialog box, type the name of the .csv file. Use the same name as the graph for the sake of consistency.
Click Save.

Show picture

Note: By default, the file will be saved in the configuration root folder. However, in a multiuser environment we recommend that you save these files on a network drive so as to make the files available to the
other operators as well.

6. You can now open the .csv file in another program, for example, Microsoft Excel. The resulting
file will look like this.

Show picture

7.13 Email a graph
A graph can be sent as a JPEG file to a mail recipient. In order to send the file, a MAPI client such as
Microsoft Outlook must be installed and set up.

Note: This feature is not supported by Novell and other operating systems.

1. Open the graph you want to send.
2. Adjust the graph to show exactly what you want to send. IGSS takes a snapshot of the graph as displayed, so if you
need to scroll to another time period or zoom in or out, now's the time.
3. Right-click and select Email Graph.

Show picture

4. Do the following:

l

In the To field, type the email address of the recipient.

l

In the Subject field, type a descriptive title for the mail.
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l

In the text field, type a message just as you would in a normal email.

The Attachments field contains the filename as processed by IGSS. The filename cannot be changed.

5. Click the Send button to send the email.
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Chapter 8: Working with Reports
8.1 Form Help
The Report Formats form
Use this form to create Operator reports in the Supervise module.

Overview
The Report formats form is split into two panes. The left pane contains a tree-view of the existing Operator reports in the configuration. You can see the report headings in each report by
clicking the [+] button to expand the report.
The right pane of the Report Formats form contains an overview of the objects placed under a
report heading. To view the objects, expand the report headings in the left pane and select a
report heading. The right pant will display all objects under that heading as well as the area in
which the object is defined and the data reduction method.
Each report type is displayed with the following icons:
l

A blue report format is an alarm statistics report

l

A burgundy report format is a periodical report

l

A light red report format is a snapshot report

The default report format for each report type is clearly marked with a D.

You can right-click in the right pane to delete an object, reset the
object properties or open the Object Browser or Manual
Report Object form.
You can right-click in the left pane to add or edit reports and/or
report headings as well as delete reports and report headings. You
can also clean the report and set the report as a default.

Preconditions
The IGSS configuration must be started and the IGSS DataServer must be running in order to
create and subsequently run any Operator reports..

Where do I find it?
In the Supervise module, click Tools > Operator Reports format to open the form.

Field /button help
Field name

Field Group

Description

Create

Report
Format

Click this button to open the Report Format Properties form
to create a new report.

Edit

Clean

Report
Format

Report
Format

Click this button to open the Report Format Properties form
to edit an existing report.
You can change the name of the format and enable or disable
the Set as default option.
Click this button to remove all objects that are no longer
defined in the configuration from the selected report.
A confirmation message will appear.

Delete

Report
Format

Click this button to delete the selected report.
A confirmation message will appear.
Click this button to open the Report Heading Properties
form to create a new report heading in the selected report.

Create

Report heading
By default, the report headings are sorted alphabetically.
However, you can change this by dragging the report heading
to the desired position.

Edit

Report head- Click this button to open the Report Heading Properties
ing
form to edit an existing report heading in the selected report.

Delete

Click this button to delete the selected report heading and all
Report headits associated objects for the selected report. A confirmation
ing
message will appear.

Browse

Chosen
objects

Click this button to open the Object Browser form to locate
and add an IGSS object to the report heading of the selected
report. You can add an object to the report heading by selecting the object in the Object Browser form and dragging the
object into the right pane of the Report Formats form.
Note
You must select the report heading in the left pane of the
Report Format form before clicking this button.

Manual

Chosen

Click this button to open the Manual Report Object form to

Field name

Field Group

Description

locate and add a manual report object to the report heading of
the selected report.
You can add an object to the report heading by selecting the
object in the Manual Report Object form and dragging the
object into the right pane of the Report Formats form.
objects

Note
You must select the report heading in the left pane of the
Report Format form before clicking this button.
Manual report objects can only be created in the Definition
module.

Delete

Description

Chosen
objects

Properties
for selected
objects

Click this button to remove the selected object from the report
heading.
Displays the object description that will appear in the report
for the selected object. The description is defined for the
object in the configuration but you can replace this with your
own object description in this field if required.
Note
To reset the description used for the object in this report unit,
click the Reset Properties button.

Unit

Properties
for selected
objects

Displays the unit that will appear in the report for the selected
object. The unit is defined for the object in the configuration
but you can insert your own unit designation in this field if
required.
Note
To reset the unit designation used for the object in this report
unit, click the Reset Properties button.

Decimals

Properties
for selected
objects

Displays the number of decimals used for displaying the object
values in the report for the selected object. The number of
decimals is defined for the object in the configuration but you
can replace this with your own number of decimals in this field
if required.
Note

Field name

Field Group

Description

To reset the number of decimals used for the object in this
report unit, click the Reset Properties button.
Properties
Reset Propfor selected
erties
objects

Click this button to reset the description, unit and number of
decimals to the values defined for the selected object in the
configuration.
Select this check box to display the actual total report value or
idealized total report value in periodical reports for the selected object(s).

Total

Show values
If you only select this check box, you get the actual total value.
If you also select the Idealized total check box, you will get
the idealized total value.
Select this check box to display the idealized total report value
in periodical reports for the selected object(s).

Total idealized

Show values

This check box is only accessible if you have selected the
Total check box.
This option is only available for periodical reports.

Reduced

Show values

Select this check box to display the reduced report value in
periodical reports for the selected object(s). The reduced value
in the report will be calculated using the same data reduction
method which was included in the report.
This option is only available for periodical reports.

Std. Dev.

Show values

Select this check box to display the standard deviation report
value in periodical reports for the selected object(s).
This option is only available for periodical reports.

OK

Click this button to save your report and close the form.

Cancel

Click this button to close the form without saving any changes
made in this form.

See Also

"Create an Operator report" on page 58
"Create a report heading in an Operator report" on page 59

"Clean an Operator Report" on page 66
"Add an IGSS object to an Operator report" on page 59
"Add a manual report object to an Operator report" on page 60
"Delete an Operator Report" on page 65
"Delete a report heading in an Operator report" on page 65
"Delete an object in an Operator report" on page 66
"About Operator Reports" on page 54
"About Report Values" on page 56

The Report Format Properties form
Overview
Use this form to create or edit Operator report properties.
When you create an Operator report, you must select the report type. Once an Operator report
type has been selected, you will not be able to change the type afterwards.

Preconditions
The Report Formats form must be open in order to open this form.

Where do I find it?
You can access this form from the Report Formats form by clicking the Create or Edit buttons
in the Report Format group.

Field Help
Field name

Description

Format name

Type the name of the report format. This is the name that the
operator sees when choosing a report to print.

Set as default

Select this check box to set the selected report as the default
report for that report type (Periodical, Snapshot or Alarm Statistics).

Field name

Description

The default report format will be suggested automatically to the
operator when he opens the associated reporting program.

Periodical report

Select this check box to create a report format to be used for
periodical reports. A periodical report is a daily, weekly,
monthly, quarterly or yearly report.
You cannot change the report type of an already existing Operator report.

Snapshot report

Select this check box to create a report format to be used for
snapshot reports. A snapshot report contains the current process
values for the selected objects.
You cannot change the report type of an already existing Operator report.

Alarm Statistics report

Select this check box to create a report format to be used for
alarm statistics reports. This type of report can also be generated by choosing File, then Alarm Statistics in the Alarm program.
You cannot change the report type of an already existing Operator report.

OK

Click this button to save your report properties and close the
form and return to the Report Formats form..

Cancel

Click this button to close the form without saving any changes
made in this form and return to the Report Formats form.

See Also

Periodical report
Snapshot report
Alarm statistics report

The Report Heading Properties form
Overview

Use this form to create and edit a report heading.

Preconditions
The Report Formats form must be open in order to open this form. You must select a report in
the left pane of the Report Formats form before creating a new report heading and you must
select the report heading you want to edit if you are editing a report heading.

Where do I find it?
You can access this form from the Report Formats form by clicking the Create or Edit buttons in the Report Format group.

Field Help
Field name

Description

Heading text

Type the text you want to appear as a heading in the report. By
default, the report headings are sorted alphabetically, but you can
change the sequence in the Report Formats dialog box, if required.

Start on new page

Check this box to insert a page break before this report heading.

OK

Click this button to save your report heading properties and close
the form and return to the Report Formats form.

Cancel

Click this button to close the form without saving any changes made
in this form return to the Report Formats form.

Manual Report Object form
Overview
Use this form to select manual report objects to add to your Operator report.
The form lists all manual report objects that have been created for the configuration. Manual
Report Objects are created in the Definition module but are accessible in this form.

Preconditions
The Report Formats form must be open in order to open this form. You must select a report
heading in the left pane of the Report Formats form before adding manual report objects to
the report heading.

Where do I find it?

You can access this form from the Report Formats form by clicking the Manual buttons in the
Chosen object group.

Field Help
Field name

Description

Always on top

Select this check box to force this dialog box to stay on top of other
windows.

Close

Click this button to close this form

8.2 Use the reporting facilities
The IGSS Reporting System is a set of programs designed to help the system designers and
plant operators in defining the formats of the plant reports and viewing and printing different
types of reports about the plant situation.
The IGSS Reporting System consists of these three report formats:
l

Operator reports

l

Custom reports

l

Standard reports

Custom Reports
Custom reports are created, edited and maintained in Microsoft Excel 2007 or 2010 but are
saved in the Report folder defined for the configuration in the System Configuration form
> Configuration tab . Saved Custom reports are therefore also accessible to all operator stations that access the IGSS server configuration.
Custom reports contain less design restrictions than Standard and Operator reports and can be
designed to cover nearly any aspect of the IGSS configuration, even retrieving data values from
other IGSS configurations and foreign data sources.
MS-Excel is used to format and prepare report data and can be used to render the report, either
as a preview or a print.
For more information, click the Reports help in IGSS Master > Help navigation pane.

Standard and Operator Reports
Standard and Operator reports are nearly identical and the method of creation and editing a
Standard or Operator report is nearly identical. Both use the Report Formatsform to create
and edit the report and both report formats have clearly defined functionality. Both reports use
the Report parameters defined in the System Configuration form > Reports tab.
l

Standard reports are created and edited in the Definition module only. They allows a
System Designer to create system-wide reports that all operators can use but cannot
edit or delete by mistake.

l

Operator reports are created and edited in the Supervise module only. Operator
reports are accessible from the Supervise Module and all operators can create, edit
and delete any Operator report from the Supervise Module.

Standard and Operator reports must be one of the three report types listed below:
l

Periodical report

l

Snapshot report

l

Alarm statistics report

Additionally, you can add manual report objects to your Standard and Operator reports, expanding the reporting functionality to include objects that are not actively monitored or scanned by
IGSS. Data values from manual report objects must be entered manually.

8.3 About Operator Reports
Operator report functionality enables an operator to quickly create and run a variant of Standard reports from the Supervise Module in order to gain a better overview of the monitored process and the object values in the process.
Using Operator reports, the operator is given access to a report-creation system which enables
the creation and printing of reports on the fly as the need for reporting arises. Once the need for
the report is passed, the Operator report can be deleted. An Operator report can also be
retained for future use or converted to a Custom Report if required.
Any operator may create Operator reports as well as edit and delete existing Operator reports.

Location of Operator report formats
When you create an Operator report, the report format will be saved in the STD folder in the
IGSS Report folder defined in the System Configuration form > Configuration Tab. Like
other report formats, you can set up an alternative report folder for all your reports in the
System Configuration form.

The Operator reports will be accessible to all operator stations that access the Report folder of
the IGSS server they connect to.
The Operator report format is saved as a normal text file with a GUID name and.FMT extension.
Although you can open the file in an text editor, any edits to the Operator report must be made
through the Supervise module in IGSS.
In a Dualized-Server set-up, each report folder will be duplicated on the two servers and synchronized in the same procedure as Standard reports are synchronized.

Running an Operator report
Like all IGSS reports, you can run an Operator report from the IGSS Master > Reports Navigation pane, but since the IGSS DataServer is used to access all Operator reports, the IGSS
Dataserver application must be running for the Operator reports to be accessible in the Reports
Navigation pane. This means the IGSS configuration must be started in order to access any
reports in the configuration.
You can also run the Operator Report as a batch job or through the Job Scheduler. You can
apply the same command line parameters to the Operator Report as you can to a Standard
Report.

Differences between Standard and Operator reports
Standard and Operator reports are nearly identical and share the same report creation process
and forms, but there are differences between the two report types.
l

Standard reports are created in the Definition module and must be edited and deleted
from the Definition module. Standard reports cannot be edited or deleted from the
Supervise module. This allows a System Designer to create system-wide reports that
all operators can use but cannot edit or delete by mistake.

l

Operator reports are created in the Supervise module and can only be edited and
deleted from the Supervise module. Operator reports cannot be edited or deleted from
the Definition module. Because Operator reports are accessible from the Supervise
Module, operators can create, edit and delete any Operator report from the Supervise
Module.

Both report types display reduced object values (BCL data) in the Periodic report while the
snapshot report uses actual, real-time object values.

Operator Report types
There are three types of Operator reports:
l

Periodical report

l

Snapshot report

l

Alarm statistics report

Each report type is displayed with the following icons:
l

A blue report format is an alarm statistics report

l

A burgundy report format is a periodical report

l

A light red report format is a snapshot report

The default report format for each report type is clearly marked with a D.

8.4 About Manual Report Objects
A manual report object is an object that does not have a direct connection to a PLC and thus is
not monitored directly by IGSS.
Object values for Manual Report Objects are entered manually through the Manual Report
Editor form found in the IGSS Master > Home Tab > Manual Report Editor button.
A Manual Report Object can be included in any Standard or Operator periodical report once it
has been created.

8.5 About Report Values
In addition to the reduced object values, you can select to display four report values when creating a periodic Operator report:
l

Total: A simple sum of all hourly values

l

Total Idealized:The average of the hourly values multiplied by 24.

l

Reduced: Re-uses the data reduction method selected for the object.

l

Standard Deviation: The standard deviation based on the Actual values and the Average value for the object.

The report values refer to the Transfer to History settings for each object in the configuration
and use the reduced hourly object values that have been transferred to the HDM database.

8.6 Create Operator Reports
Any operator can create Operator reports from the Tools menu in the Supervise module but
the configuration must be started in order to create Operator reports.
Operator reports are saved in the Report folder specified for the IGSSS Server in the System
Configuration form and therefore available to all operator stations that connect to the IGSS
server.

When creating a new Operator report, you must define a name for each report and determine
the report type (Snapshot, Periodical or Alarm Statistics report). The report type will determine
what types of IGSS object data you can display in your Operator report.
To create a new Operator report, you must go through the following steps:
Create the report

Create a new Operator report format in the Report Formats form, defining a name and setting
the report type (Periodical, Alarm Statistics or Snapshot). You can also set the report as the
default report for the selected report type.
Create the Report headings

Once you have created the report, you must create at least one report heading to contain the
IGSS objects.
The Operator report format consists of a number of user-defined headings where you can place
the IGSSobjects you want displayed in the report. You can define any number of report headings in order to provide a better overview of a report, assigning IGSSobjects to each report
headings, but you must have at least one heading in order to add IGSSobjects to the report.
Add objects to the report

Add any IGSS objects or Manual Report Objects to your report using the Object Browser or
the Manual Report Objects forms.
Individual IGSS objects are added to the report by dragging the object from the Object
Browser form into the Report Formats form and individual manual report objects are added
to the report by dragging the object from the Manual Report Objects form into the Report
Formats form.
The item Current value or state can only be used in Snapshot or Alarm Statistics reports.
The data reduction method(s) can only be used in Periodical reports.
Adjust the object display settings

The key properties for the IGSS object (Description, Unit and Decimals) are automatically
imported into the report format, but can be changed, if necessary.
You can determine which report value(s) to display for each IGSS object in the report such as.
l

Total

l

Idealized total

l

Reduced value

l

Standard deviation

Save the report

Click the OK button in the Report Formats form to save the report. The report will be created
in the report folder specified for the IGSS server in the System Configuration form > Configuration tab and made available to all operator stations in the IGSS Master.

See Also
"About Manual Report Objects" on page 56
Periodical report
Snapshot report
Alarm statistics report
"About Report Values" on page 56

Create an Operator report
To create a new Operator report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form
2. In the Report Formats form > Report format group, click the Create button to
open the Report Format Properties form.
3. In the Format name field, enter the name of the report format. This is the name
that the operator will see when he runs the report from the IGSS Master.
4. Under Report type, select the relevant report type (Periodical, Snapshot or Alarm
statistics report)
5. Select the Set as default checkbox if you want the report format to be suggested
as the default format to the operator.
Only one report format can be set as default per report type. The default report
format will be clearly marked with a “D” in the Report Formats form.

6. Click the OK button to create the new Operator report and close the Report Format
Properties form. The The new report name appears in the left pane of the Report
Format form.

See Also

Periodical report
Snapshot report

Alarm statistics report

Create a report heading in an Operator report
To create a report heading in an Operator report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form
2. In the left pane of the Report Formats form, select the report you want to create a
report heading in.
3. Click the Create button in the Report Heading group to open the Report Heading Properties form.
4. In the Heading Text field in the Report Heading Properties form, enter the
name of the report heading.
Select the Start on new page check box if you want to insert a new page in the
report when the heading is encountered.

5. Click the OK button to create the report heading and close the Report Heading
Properties form.
6. Click the OK button in the Report Formats form to save the report and close the
form.

Add an IGSS object to an Operator report
An object can only be placed under a report heading in an Operator report. If your report does
not contain at least one report heading, you must create one prior to adding an object to the
report.
To add an IGSS object to an Operator report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form.
2. In the left pane of the Report Formats form, select the report you want to create
an IGSS object in.
3. Click the [+ ] button to expand the report headings in the report and select the heading you want to create the IGSS object in.

4. Click the Browse button in the Chosen objectsgroup to open the Object
Browser form.
5. In the Object Browser form, find the object you want to add to the report and drag
the object and it's data reduction method to the right pane of the Report Formats
form.
In the Properties for selected objects group, you can define which report values
(Total , Total Idealized, Reduced and/or Standard Deviation) to include in the
report as well as edit the object properties (Description, Unit and Decimals) for
each individual object data reduction method.
You can continue to drag objects from the Object Browser form to the Report
Formats form until you have added all the objects you want to the report.

6. Click the Close button to close the Object Browser form and return to the Report
Formats form.
7. Click the OK button in the Report Formats form to save the report and close the
form.

The current object value or state can only be used in Snapshot or Alarm Statistics reports.
The data reduction method(s) can only be used in Periodical reports.
See Also

Periodical report
Snapshot report
Alarm statistics report
"About Report Values" on page 56

Add a manual report object to an Operator report
An object can only be placed under a report heading in an Operator report. If your report does
not contain at least one report heading, you must create one prior to adding an object to the
report.
To add a manual report object to an Operator report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form.
2. In the left pane of the Report Formats form, select the report you want to create
an IGSS object in.
3. Click the [+ ] button to expand the report headings in the report and select the heading you want to create the IGSS object in.
4. Click the Maual button in the Chosen objectsgroup to open the Manual Report
Object form.
5. In the Manual Report Object form, find the object you want to add to the report
and drag the object and it's atom to the right pane of the Report Formats form.
You can define which report values (Total , Total Idealized, Reduced and/or
Standard Deviation) to include in the report as well as edit the object properties
(Description, Unit and Decimals) for each individual object atom in the Properties for selected objects group in the Report Formats form.
You can continue to drag objects from the Manual Report Object form to the
Report Formats form until you have added all the objects you want to the report.

6. Click the Close button to close the Manual Report Object form and return to the
Report Formats form.
7. Click the OK button in the Report Formats form to save the report and close the
form.

You cannot create manual report objects through the Supervise module, If you need to create
manual report objects, you must use open the Manual Report object form from the Report
formats form found in the Definition module > Edit > Report Formats.
See Also

"About Report Values" on page 56

8.7 Edit an Operator Report
Operator Reports can only be edited from the Supervise module. The configuration must be
started in order to edit an Operator Report.
To edit an existing report:
l

Open the Supervise module and click Tools > Operator Report formats to open
the Report Formats form.

l

In the right-hand pane of the Report Formats form, select the report you want to edit.

Edit the report format
l

Click Report Format group > Edit button to open the Report Format Properties
form and edit the name and default setting of the selected report.

Edit a report heading
l

In the right-hand pane of the Report Formats form, select the report you want to edit
click the [ + ] top expend the headings of the report.

l

Select the heading you want to edit and click the Report Heading group > Edit button
to open the Report Heading Properties form to edit the name of the report heading
and set the Start on new page check box if necessary.

l

To add a new report heading, click the Create button in the Report Heading group to
open the Report Heading Properties form.

l

To delete a report heading, click the Delete button in the Report heading group. If
you delete a report heading, all objects contained in the report heading will also be
removed from the report.

Edit an object in the report
l

In the right-hand pane of the Report Formats form, select the report you want to edit
click the [ + ] top expend the headings of the report.

l

Select the heading which contains the object you want to edit and select the object in
the right pane of the Report Formats form.

l

In the Properties for selected objects group, make the required changes to the
selected object properties.

l

To add a new IGSS object to the report heading, click the Browse button in the
Chosen Objects group to open the Object Browser form where you can locate the
new IGSS object. Drag the object into the report heading to add it to the report.

l

To add a new manual report object to the report heading, click the Manual button to
open the Manual Report Object form. Drag an existing manual report object into the
report heading to add it to the report. You can also create a new manual report object
and drag it into the report heading.

l

To delete an object, select the object and click the Delete button in the Chosen
Objects group.

Save the report
l

When you have completed your edits, click the OK button in the Report Formats form
to save the changes and close the form.

Edit an Operator Report
To edit an existing Operator Report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form
2. In the left pane of the Report Formats form, select the report you want to edit
3. Click the Edit button in the Report Format group to open the Report Format
Properties form.
4. In the Format name field, change the name of the report format. This is the name
that the operator will see when he runs the report from the IGSS Master.
Select the Set as default checkbox if you want the report format to be suggested
as the default format to the operator.
Only one report format can be set as default per report type. The default report
format will be clearly marked with a “D” in the Report Formats form.

5. Click the OK button to close the Report Format Properties form.
6. Click the OK button in the Report Format form to save the changes and close the
form.

Edit a report heading in an Operator report
To edit an existing report heading in an Operator report:

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form
2. In the left pane of the Report Formats form, select the report which contains the
report heading you want to edit.
3. Click the Edit button in the Report Heading group to open the Report Heading
Properties form.
4. In the Heading Text field in the Report Heading Properties form, you can
change the name of the report heading.
Select the Start on new page check box if you want to insert a new page in the
report when the heading is encountered.

5. Click the OK button to create the report heading and close the Report Heading
Properties form.
6. Click the OK button in the Report Formats form to save the changes and close the
form.

Edit an object in the Operator report
You can edit an object in the Operator report. the procedure is the same regardless of the object
type (IGSS object or manual report object)
To edit an object in an Operator report

1. In the Supervise module, click Tools > Operator Report Formats to open the
Report Formats form.
2. In the left pane of the Report Formats form, select the report you want to edit an
object in.
3. Click the [+ ] button to expand the report headings in the report and select the heading which contains the object you want to edit.
4. In the right pane of the Report Formats form, select the object you want to edit.
5. In the Properties for selected objects group, you can change the report values
(Total , Total Idealized, Reduced and/or Standard Deviation) as well as edit
the object properties (Description, Unit and Decimals) for each individual object
data reduction method.
6. Click the OK button in the Report Formats form to save the report and close the
form.

Change order of the objects

You can change the placement (sorting order) of the objects in a report heading by selecting
the object in the right pane of the Report Formats form and dragging it to a new position.
See Also

"About Report Values" on page 56

8.8 Delete an Operator Report
Operator Reports and their elements (headings and objects) can only deleted from the Supervise module.
The configuration must be started in order to delete an Operator Report.

Delete an Operator Report
Operator Reports can only deleted from the Supervise module. The configuration must be started in order to delete an Operator Report.
To delete an existing report:

1. Open the Supervise module and click Tools > Operator Report formats to open
the Report Formats form.
2. In the right-hand pane of the Report Formats form, select the report you want to
delete.
3. Click the Delete button to delete the selected report.
4. Click the OK button to confirm the delete and close the Report Formats form. The
Operator report format will be removed from the Reports Navigation pane in theIGSS
Master.

Delete a report heading in an Operator report

To delete a report heading

1. Open the Supervise module and click Tools > Operator Report formats to open
the Report Formats form.
2. In the left pane of the Report Formats form, select the report which contains the
heading you want to delete
3. Click the [+ ] button to expand the headings of the report.
4. In the left pane of the Report Formats form, select the heading you want to delete
and click the Delete button in the Report heading group. If you delete a report
heading, all objects contained in the report heading will also be removed from the
report.
5. Click the OK button in the Report Formats form to save the changes and close the
form.

Delete an object in an Operator report

To delete an object in the report

1. Open the Supervise module and click Tools > Operator Report formats to open
the Report Formats form.
2. In the left pane of the Report Formats form, select the report which contains the
object you want to delete.
3. Click the [+ ] button to expand the headings of the report.
4. In the left pane of the Report Formats form, select the heading which contains the
object you want to delete and select the object in the right pane of the Report
Formats form.
5. Click the Delete button in the Chosen Objects group.
6. Click the OK button in the Report Formats form to save the changes and close the
form.

8.9 Clean an Operator Report
You can remove all objects that are no longer in the associated configuration,cleaning the Operator Report that uses the removed objects.
To clean an existing report:

1. Open the Supervise module and click Tools > Operator Report formats to open
the Report Formats form.
2. In the right-hand pane of the Report Formats form, select the report you want to
clean.
3. Click Report Format group > Clean button to open the Clean Report Format dialog.
4. Click the Yes button to clean the report and close the Clean Report Format dialog.
5. Click the OK button in the Report Formats form to save the changes and close the
form.

Chapter 9: Viewing Object Data and Events
9.1 IGSS Playback
About IGSS Playback
IGSS Playback allows you to view the entire monitored process for a specific period of time in
the past (the Playback interval), effectively replaying the monitored process for all important
elements.
IGSS Playback uses historical data taken from LOG data as input for the objects in the diagrams, allowing you to observe how the entire system reacted to the log data changes as
opposed to data mining the log data to see how individual objects reacted. Objects that have
not been set up to save LOG data will not be displayed when using the IGSS Playback functionality. If you want to use the IGSS Playback functionality, you must make sure to save key
object values as LOG data.
IGSS Playback gives you a wider perspective and a larger picture to observe log process data,
the conditions prior to an event and the consequences after an event as displayed in the process diagrams.
You must define the start and end times to be replayed (the Playback interval), and you can
adjust the playback speed, pause the playback, skip forwards or backwards and redefine the
playback interval as you go.
IGSS Playback is a view-only option, displaying log data only. You cannot interact with the playback interval, for instance changing object values or states to model a different outcome.
The IGSS Playback functionality uses the IGSS Player form to define the playback interval
period and to manage the playback process.
Changes to IGSS when the IGSS Player is running

When the IGSS Player form is running the playback interval, the Active Alarm and Event list
forms will be displayed with a red background instead of the normal white background. All
alarms and events listed in the active Alarm and Event list forms will also be emptied. If you
need to access the active alarms during playback, you can set up the alarm module to display
real-time active alarms in the Active Alarm form during playback in the System Configuration form.
All diagrams in Supervise are displayed with a semi-transparent red mask and all object values
will be displayed with three question marks “????” which indicate that the object values are
unknown. Object values will be populated with the LOG data values they had at the start of the
playback interval when the IGSS Player form is started. Object values that cannot be loaded
from the log data will be displayed with three question marks “????” throughout the playback
interval.

All menus, toolbars and dialog boxes where commands to the system or to objects can be
entered or sent are disabled.
All widgets in the IGSS Dashboard will be closed and the Dashboard will indicate that IGSS is
running in Playback mode.
Graphs opened in the Supervise module will display LOG data values up to the start of the
playback interval but the graph data values and display will not be updated dynamically when
the IGSS Player form is running the playback interval.
Even though the IGSS Player form is running the playback interval, important and vital IGSS
functionality will not be impacted by the IGSS Player form. All applications (including 3rd
party applications and VBA applications) which have started normally on the IGSS Server will
continue to run after the IGSS Player form is started.
IGSS Servers and single-user stations will continue to collect data and perform calculations
even when the IGSS Player form is running and IGSS operator stations will still be connected
to the IGSS Server.
All external interfaces of IGSS (such as Maintenance, Notifier, Alarm Management) are not
affected when IGSS Player form is running the playback interval. The external interfaces can
still access online data, including alarms triggered by online data. Alarms are still registered in
IGSS and will be displayed in the Active Alarm form when playback stops.
Disturbing the IGSS Player form

When the IGSS Player form is running the playback interval, be aware that certain actions will
cause the form to stop the playback.
l

If the IGSS station is stopped and closed down, the IGSS Player form will also stop
and close.

l

If data collection in IGSS is stopped, the IGSS Player form will stop. Once data collection is restarted, the form not resume playback and must be restarted.

l

If you update (edit, submit changes to) the IGSS configuration when the IGSS Player
form is running, the form will stop playback of the playback interval. When the update is
finished, the IGSS Player form will not resume playback and must be restarted.

l

If the IGSS Player form is running a playback interval on an operator station and the
connection to the IGSS server is lost, the form will stop running. When the connection
to the IGSS server is restored, the the form will not resume playback and must be restarted.

l

If the IGSS Player form is running a playback interval on an operator station and a
new connection to another IGSS server is set up, the form will stop running. When the
new

l

connection to the IGSS server is enabled, the form will not resume playback and must
be restarted.

See Also

"Display alarms in the Active Alarm form during playback" on page 75

IGSS Playback forms
The IGSS Player form
Use the Player form to display historical IGSS data in the Supervise process diagrams, gaining
an overview of the system values and displays during the playback interval.

Overview
You can define the period which you want to replay critical events and adjust the playback
speed to closely monitor the controls and objects in the diagrams or you can speed up the
replay speed to see the entire process unfold rapidly.
When the IGSS Player form is started, log data is loaded sequentially, starting from the
defined start date and start time. Log data is loaded in one hour chunks at a time and the progress of the entire playback interval is displayed in the Period slider bar in the middle of the
form.
When you use the IGSS Player form to display log data in the process diagrams of Supervise,
IGSS will enter Playback mode. When IGSS is in Playback mode, the process diagrams in Supervise will change appearance and display the log data, but data will still be collected from the
online monitored process.
Closing the IGSS Player form will bring IGSS back into the mode the application was in when
the IGSS Player form was opened, either Runtime or Design mode.

IGSS Player status
IGSS Player form status is displayed in the left-hand bottom of the form. There are the following IGSS Player status:
l

Ready

l

Stopping

l

Reading LOG values

l

Loading Configuration

l

Awaiting IGSS Start

Using the IGSS Player form and Multimedia keyboards
If you have a multimedia keyboard, you can use the multimedia buttons in addition to the normal keyboard shortcut keys described below.

Preconditions
None

Where do I find it?
Click the IGSS Master > Home tab> Player Button to open the IGSS Player form.

Field Help
Field name

Description

Click this button to change the status of the IGSS Player.The
button color displays the current IGSS Player status.
There are three status levels:
l

Status Button
l

l

Select Period

Off /Offline (Gray): IGSS is not presently running.
IGSS Playback functionality is not available and the
IGSS Player form is dimmed.
On/Online (Green): IGSS is running in normal mode
(runtime or Design mode). IGSS Playback functionality is available and the IGSS Player form can be
used. The IGSS Player is not running.
Replay/Running/Playback (Red): IGSS is running in
Playback mode and the IGSS Player is running, displaying the log data in the diagrams in Supervise.

Click this button to open the Select Period form to select the
period you want the IGSS Player to display.
Click the plus [ + ] button to increase the playback speed by
one speed level and click the minus [ – ] button to decrease
the playback speed by one speed level. You can also press the
+ or – keys to increase or decrease the playback speed.

Player speed

The available playback speeds are displayed in the drop-down
field in the middle of the button area. You can select any playback speed by opening the drop down box in the button area
and selecting the playback speed.
Playback Speed examples:
l

1/10: Ten minutes are used to replay one minute of
LOG data. Ten minutes are used to display one minute
of LOG data.

Field name

Description
l

l

l

l

½: The playback speed is half as fast as the log data
was registered. Two minutes are used to display one
minute of LOG data.
1: The playback interval is displayed at the same
speed as the log data was registered.
2: The playback speed is twice as fast as the log data
was registered. 30 seconds are used to display one
minute of log data.
10: The playback speed is ten times as fast as the log
data was registered. 6 seconds are used to display one
minute of log data.

The last used playback interval is automatically loaded when
the IGSS Player form is opened.
On Top Check Box

Select his check box to always display the IGSS Player form
on top of all other forms.

Present time

The present time of the playback interval is displayed in the
middle of the form.
Click and drag the slider to display the values and objects in
the diagrams for the selected time. The slider bar also displays the status of the data being loaded into the IGSS Player.
Keyboard short cut keys :
l

l

l

Period Slider bar

Press the left/right keys or page up / page down keys
to move the slider left or right.
Press the Home key to move the slider to the beginning of the slider bar.
Press the End key to move the slider to the end of the
slider bar.

Slider bar colors:
l

l

If the slider or part of the slider is green, the required
log data has been loaded and the IGSS Player can display that part of the playback interval.
If the slider or part of the slider is yellow, the log data
is still loading. The IGSS Player cannot display that
part of the playback interval yet.
When an hour’s worth of log data is in the process of

Field name

Description

being loaded, this is represented by a yellow color on
the Period slider bar. Once the hour data is loaded and
ready for playback, the color will change to green, permitting playback.
l

l

Stop

If the slider or part of the slider is red, the log data
has not yet been loading and the IGSS Player cannot
display that part of the playback interval.
If the slider is gray, IGSS is running in Runtime or
Design mode and the IGSS Player is not available.

Click this button to stop the IGSS Player and return the slider
in the Period Slider bar to the start of the playback interval.
Click this button to jump 2.5% backwards in the playback
interval.

Jump Backward

Keyboard Shortcut key: Press the F2 key to jump backwards.
The entire playback interval is divided into 200 equal parts.
Each time you click the Jump Backward button, the playback
slider is moved backwards by one part (out of the 200).
Click this button to skip backwards to the previous value in the
log data of the playback interval.

Skip backward

The playback time stamp is set to the time stamp of the log
data and the object values are sent to the process diagrams
for display.
Keyboard Shortcut key:Press the F3 key to play the playback interval skip forward in the playback interval.
Click this button to reverse the playback interval at the speed
defined in the Player Speed field.

Reverse
Keyboard Shortcut key:Press the F4 key to play the playback interval in reverse.
Click this button to pause the playback interval. The present
time slider will remain where it is.
Pause

You can resume the playback interval by clicking the Pause
button again. You can also resume the playback by clicking
the following buttons:

Field name

Description
l

Jump Backward

l

Skip Backward

l

Skip Forward

l

Fast Forward

Keyboard Shortcut key: Press the F5 key to pause or
resume the playback interval.
Click this button to fast forward the playback interval at the
speed defined in the Player Speed field.
Fast Forward
Keyboard Shortcut key:Press the F6 key to play the playback interval in reverse.
Click this button to skip forward to the next value in the log
data of the playback interval.

Skip Forward

The playback time stamp is set to the time stamp of the log
data and the object values are sent to the process diagrams
for display.
Keyboard Shortcut key:Press the F7 key to play the playback interval skip forward in the playback interval.
Click this button to jump 2.5% backwards in the playback
interval.

Jump Forward

Keyboard Shortcut key:Press the F8 key to jump backwards.
The entire playback interval is divided into 200 equal parts.
Each time you click the Jump Forward button, the playback
slider is moved forwards by one part (out of the 200).

Setup time interval to analyze button

Click this button to open the Define playback interval form
where you can set up the start and end date and times for the
IGSS Player form.

See Also
"The Define Playback Interval form" on page 74

The Define Playback Interval form
Use this form to specify the playback interval the IGSS Player form. You must select the start
date and time as well as the end date and time of the playback interval.

Overview
Once you have selected the playback interval, log data will be loaded for the IGSS Player
form.
Please note that selecting a very long playback interval, for example many days or weeks, will
affect system memory usage, slowing system performance and a longer loaded time for the
IGSS Player form will result. If at all possible, select as narrow an interval as possible.
If you have selected a playback interval that is too long, you can change the playback interval
duration by selecting new start and end dates and times, automatically pausing the playback
and inserting the new playback interval.
The last used playback interval is automatically loaded when the IGSS Player is opened.

Preconditions
The IGSS Player form must be opened in order to access the Define Playback Interval
form..

Where do I find it?
Click the Setup time interval to analyze button in the IGSS Player form to open the
Define Playback Interval form .

Field Help
Field name

Description

Start Date

Select the start date of the playback interval from the calendar in the field or enter the date directly in the field.

Start Time

Enter the start time of the playback interval.

End Date

Select the end date of the playback interval from the calendar
in the field or enter the date directly in the field.

End Time

Enter the end time of the playback interval.

See Also
"The IGSS Player form" on page 69

Configuring the IGSS Player
You can configure the appearance of the Supervise module when the IGSS Playback functionality is running.
By default, the Alarm list and Supervise diagrams are shaded in a semi-transparent red mask to
indicate the IGSS Playback functionality is enabled. You can change the color of the IGSS Playback mask for both the Alarm List and the diagrams in the Supervise module.

Note
IGSS uses an eight character hexadecimal color code to represent colors in the
IGSS application.
The eight character hexadecimal color codes consists of 4 pairs of two-character combinations
and looks like this: ##BBGGRR
An eight character hexadecimal color code consists of the following:
l

The first pair (first two characters ##) is always 00.

l

The next pair (characters 3 and 4, BB) defines the blue values of the background color
and must be within the hexadecimal values 00 and ff

l

The next pair (characters 5and 6, GG) defines the green values of the background color
and must be within the hexadecimal values 00 and ff

l

The next pair (characters 7 and 8 RR) defines the red values of the background color
and must be within the hexadecimal values 00 and ff

The hexadecimal code refers to the 00-ff values for the Red, Green and Blue parts of the color.
See Also

"Configuring the Alarm List playback background color" on page 76
"Configuring the Supervise playback background color" on page 77
Display alarms in the Active Alarm form during playback
By default, the Active Alarm and Event list forms will also be emptied and be displayed with
a red background during playback. Alarms and event will still be registered in the Active
Alarm during playback and will be displayed when playback ends.
If you need to access the active alarms during playback, you can set up the alarm module to
display real-time active alarms in the Active Alarm form during playback in the System Configuration form. The Active Alarm form will not be displayed with an overlay mask during playback if you set up the alarm module to display real-time active alarms during playback.

To display real-time active alarms in the Active Alarm form during playback

1. In the IGSS Master > Design and Setup tab, click the System Configuration
button to open the System Configuration form.
2. In the System Configuration form. > Alarm tab > Alarm Settings group, select
the Show real alarms in playback mode check box
3. Close the System Configuration form and save the new configuration settings.

The configuration must be restarted after saving new system configuration settings.

Configuring the Alarm List playback background color
The background color of the Alarm list form is overlaid with a semi-transparent red mask
when the IGSS Playback functionality is in use (the IGSS Player form is running)
You can change the default appearance of the semi-transparent red layer by defining a new
indicator color.
You can change the indicator color of the Alarm list form layer list to another color in two
ways:
l

In the Registry settings of the local machine

l

In the System Configuration form

Using the System Configuration form
Make sure you are running in Design Mode in the IGSS Master.

1. In the IGSS Master, click Design and Setup tab > System Configuration button to open the System Configuration form.
2. Select the IGSS server in the left hand pane of the System Configuration form
(Right-click the server name in the tree and select This PC).
3. In the System Configuration form, click the Alarm tab > Playback mode field
and select the new color you want to display in the Active Alarms form Supervise
when the IGSS Player is playing IGSS data.

4. In the System Configuration form, click File > Save Project and exit the System Configuration form. The IGSS configuration will re-start and deploy your
changes.

Using the Registry settings
You can change the background color of the Alarm list form to another color by defining a new
eight character hexadecimal value for the background color in the registry settings for IGSS on
the local machine.
The default value is 00d0d0ff.

1. Open the Registry Editor form on the local machine. Click Start and type "Regedit.exe" in the search field of the Windows Start menu.
2. In the Settings folder in HKEY_CURRENT_USER\Software\Schneider Electric\IGSS32\V11.00.00 \ Player, right-click on the Alarm List Background Colour
registry key and select Modify.
3. In the Value Data field of the Edit String form, enter the new eight character hexadecimal value of the background color and click the OK button to save.
4. Click File > Exit to exit the Registry Editor form and save the registry values.

See Also

"Configuring the Supervise playback background color" on page 77
"Configuring the indicator mask for the Data Playback function" on page 79
Configuring the Supervise playback background color
The background color of the diagrams in Supervise are overlaid with a semi-transparent red
layer when the IGSS Playback functionality is in use (the IGSS Player form is running).
The layer consists of an indicator color, which is used to indicate when IGSS Playback functionality is in use and an indicator mask, which is used to define the form and transparency of
the indicator color.
You can change the default appearance of the semi-transparent red layer by defining a new
indicator color and a new indicator mask.
You can change the indicator color of the Supervise layer list to another color in two ways:

l

In the Registry settings of the local machine

l

In the System Configuration form

Using System Configuration form
Make sure you are running in Design Mode in the IGSS Master.

1. In the IGSS Master, click Design and Setup tab > System Configuration button to open the System Configuration form.
2. Select the IGSS server in the left hand pane of the System Configuration form
(Right-click the server name in the tree and select This PC).
3. In the System Configuration form, click the Supervise and Language tab
> Setup indicator mask button to open the Setup Indication Mask form.
4. In the Player Mode indicator color field, select the new color you want to display
in Supervise when the IGSS Player is playing IGSS data.
5. In the System Configuration form, click File > Save Project and exit the System Configuration form. The IGSS configuration will re-start and deploy your
changes.

Using the Registry settings
If you use the registry editor to change the indicator color of the Supervise layer list to another
color, you must define a new 8 character hexadecimal value for the background color in the
registry settings for IGSS on the local machine.
The default value is 00d0d0ff.

To change the background color of the diagrams in Supervise:

1. Open the Registry Editor form on the local machine. Click Start and type "Regedit.exe" in the search field of the Windows Start menu.
2. In the Settings folder in HKEY_CURRENT_USER\Software\Schneider Electric\IGSS32\V11.00.00 \ Player, right-click on the SupverviseMaskColor registry
key and select Modify.
3. In the Value Data field of the Edit String form, enter the new 8 character hexadecimal value of the background color and click the OK button to save.
4. Click File > Exit to exit the Registry Editor form and save the registry values.

See Also

"Configuring the indicator mask for the Data Playback function" on page 79

Configuring the Alarm List playback background color

Configuring the indicator mask for the Data Playback function
The background color of the diagrams in Supervise are overlaid with a semi-transparent red
layer when the IGSS Playback functionality is in use (the IGSS Player form is running).
The layer consists of an indicator color, which is used to indicate when IGSS Playback functionality is in use and an indicator mask, which is used to define the form and transparency of
the indicator color.
You can change the default appearance of the semi-transparent red layer by defining a new
indicator color and a new indicator mask.

To change the indicator mask for IGSS Playback functionality
Make sure you are running in Design Mode in the IGSS Master.

1. In the IGSS Master, click Design and Setup tab > System Configuration button to open the System Configuration form
2. In the System Configuration form, click the Supervise and Language tab
> Setup indicator mask button to open the Setup Indication Mask form.
3. In the Indication Mask group, click the pixels to toggle the transparency on or off.
If a pixel is toggled to black, the selected indicator color will be displayed in the
pixel.
If a pixel is toggled to white, the original background of the Supervise module will be
displayed in the pixel.

4. You can see how the selected combinations and concentrations of pixels will look in
the Sample field.

You can increase of decrease the degree of transparency by
increasing or decreasing the concentration of black vs. white
pixels in the Indication Mask pixel. If you fill the entire area with
black pixels, this will correspond to 100% transparency while an
all-white area will correspond to 0% transparency.
See Also

"Configuring the Supervise playback background color" on page 77

Run a playback interval in the Supervisemodule
If you want to run a playback interval in the Supervise module's diagrams, you must do the following:

1. Ensure the IGSS Master is started and running.
2. Locate and open the IGSS Player form from the IGSS Master.
3. Open the Define Playback Interval form and define the playback interval
4. Start the playback and monitor the diagrams during the playback sequence
5. Once the playback is ended, close the IGSS Player form and return IGSS to normal
running mode.

You can also start IGSS Playback from the Tools menu in the
Supervise module.
See Also

"The IGSS Player form" on page 69
"Define the playback interval" on page 80
"Set playback speed in the IGSS Player" on page 81

Define the playback interval
To define the playback interval for the IGSS Player form:

1. Open the IGSS Player form from the IGSS Master
2. In the IGSS Player form, click the Setup time interval to analyze button to
open the Define Playback Interval form
3. In the Define Playback Interval form:
1. In the Start Date and Start Time fields, enter the Start date and start
time of the playback interval.

2. In the End Date and End Time fields, enter the end data and end time of
the playback interval.
4. Click the OK button to close the form and save the settings.

See Also

"The Define Playback Interval form" on page 74
"Run a playback interval in the Supervisemodule" on page 80
"Set playback speed in the IGSS Player" on page 81

Set playback speed in the IGSS Player
You can increase the playback speed of the IGSS Player form to run through the playback
interval or slow the speed down for more in-depth analysis of the monitored process.
The playback speed in IGSS Player form is set in pre-defined speeds compared to a standard
one second playback.
l

If you set the playback speed to "1/10", this will result in a slower playback speed. Ten
minutes will be used to replay one full minute of LOG data in the monitored process.

l

If you set the playback speed to "2", this will result in a faster playback speed. One
minute will be used to replay two full minutes of LOG data in the monitored process.

The available playback speeds are displayed in the drop-down field in the middle of the button
area. You can select any playback speed by opening the drop down box in the button area and
selecting the playback speed.
To change the playback speed:

In the IGSS Player form, click the plus [ + ] button to increase the playback speed by one
speed level and click the minus [ – ] button to decrease the playback speed by one speed
level.
You can also press the + or – keys to increase or decrease the playback speed.
See Also

"The IGSS Player form" on page 69
"Run a playback interval in the Supervisemodule" on page 80
"Define the playback interval" on page 80

9.2 Object Historian
What is the Object Historian ?
Definition
The Object Historian allows the operator to view past events in the monitored process. The operator can view four different event types in the Object Historian:
l

Log data

l

Alarm data

l

BCL data

l

User login/logout

Use
The Object Historian is a supplement to the traditional tools available to the operator. LOG and
BCL data can also be viewed in a graph, alarm data can be seen in the Alarm List.
But the Object Historian binds all these data types together and provides a full chronological
picture of the events in the process, including information about which user was logged in at the
time in question.

Using the Object Historian
Introduction
This topic serves to give you an overview of the Object Historian functionality. For step-by-step
procedures, click here and choose the relevant one.

Example
The functionality is best illustrated with an example. The dialogue below shows the LOG data
for 24 hours for the selected objects.

Select objects for inspection
The first step is to choose the objects you want to inspect. This can be done in two ways:
l

Lasso the objects on a process diagram, then select Edit → Object Historian.

l

Select Edit → Object Historian, then browse through the configuration to find the objects.

The selected objects appear in the list with the text "Will be checked for events".

Define the time period
By default, the Object Historian goes back one hour but you can choose any start and end
time in the Time interval area.
But remember that you must have the corresponding data files in the configuration's report
folder. The lifetime of the different data files may be limited as defined in the System Configuration program on the Files tab. As an example, the lifetime for .log files is set to 24 hours
by default. So if you don't get any data in the list, this may be the reason.

Choosing the event types
You can now choose between four different event types: LOG, BCL, Alarm data or user login/logout information. Any combination of the four types is valid.
Once the relevant types are selected, simply click the Query data button.

Printing or exporting data
Once the data is displayed in the list, you can print the data or export it to a .csv file for further
processing.

What's This? Help
When you work with the Object Historian, you can always click the
corner of the dialogue, then click the item you want information about.

in the upper right

View LOG data in Object Historian

1. Choose the objects for inspection as follows:

l

l

Lasso the objects on the process diagram, then select Edit → Object Historian.
Select Edit → Object Historian and click Browse to find the relevant objects. To add
multiple objects simultaneously, select them in the Object Browser and drag them
onto the Object Historian dialogue.

Result: The selected objects appear in the list with the text "Will be checked for events".

2. Under Time interval, define the relevant start and end time. IGSS goes back one hour by default.
3. Under Event types, select the Log check box.
4. Click Query data to view the data in the list.

Tip: For details on the individual columns in the list, click the
list.

Show picture

button, then click inside the

If you don't get any data in the list, you may not have the necessary .log files in the
report folder. The lifetime of the data files can be limited by the settings on the Files
tab in the System Configuration form.

View alarm data in Object Historian

1. Choose the objects for inspection as follows:

l

l

Lasso the objects on the process diagram, then select Edit → Object Historian.
Select Edit → Object Historian and click Browse to find the relevant objects. To add
multiple objects simultaneously, select them in the Object Browser and drag them
onto the Object Historian dialogue.

The selected objects appear in the list with the text "Will be checked for events".

1. Under Time interval, define the relevant start and end time. IGSS goes back one hour by default.
2. Under Event types, select the Alarm check box.
3. Click Query data to view the data in the list.
4. For details on the individual columns in the list, click the

button, then click inside the list.

Show picture

If you don't get any data in the list, you may not have the necessary .alm files in the
report folder. The lifetime of the data files can be limited by the settings on the Files
tab in the System Configuration form.

View BCL data in Object Historian

1. Choose the objects for inspection as follows:

l

l

Lasso the objects on the process diagram, then select Edit → Object Historian.
Select Edit → Object Historian and click Browse to find the relevant objects. To add
multiple objects simultaneously, select them in the Object Browser and drag them
onto the Object Historian dialogue.

The selected objects appear in the list with the text "Will be checked for events".

2. Under Time interval , define the relevant start and end time. IGSS goes back one
hour by default.
3. Under Event types, select the BCLcheck box.
4. Click Query data to view the data in the list.
5. For details on the individual columns in the list, click the

button, then click inside the list.

Show picture
Note
If you don't get any data in the list, you may not have the necessary .bcl files in the report
folder. The lifetime of the data files can be limited by the settings on the Files tab in the System Configuration program.

Export data from Object Historian

1. Once the required data is displayed in the list, click the Export as CSV button.
2. In the Save As dialogue, give the .csv file a name. IGSS defaults to the report folder for the configuration, but you can choose another folder, if required.

The .csv file can be opened in another program for further processing, for example, in Microsoft
Excel.

Print data from Object Historian

1. Once the required data is displayed in the list, choose what to print as follows:

l

To print all items in the list, go to step 2.

l

To print only selected items, select the relevant items in the list.

2. Click the Print button.

9.3 Object Watch
What is Object Watch?
The Object Watch is a small separate window in IGSS where the operators can add specific
object atoms. These object atoms in the Object Watch window will be displayed on top of any
present diagram.
Use

The Object Watch is used when certain atoms has to be monitored more frequently, for example
if there are two critical flow meters that must be monitored extra carefully these might be
placed in the Object Watch. Then the operator would still be able to monitor the normal process
in the background diagram and also keep an extra eye on the flow meters in the Object Watch
window (If multi monitor is enabled the Object Watch could also be placed on a separate
screen).

Click here to view an example of the Object Watch function)

Add object atoms to Object Watch
Types of objects

All types of object atoms can be added to the Object Watch, that is for the objects:
l

Analog

l

Digital

l

Table

l

Counter

l

String

Add atom(s) to the Object Watch window

1. In the process diagram, right-click the object you want to add to the Object Watch
window and select Watch Object.
2. In the Atoms to show in object watch window form, select which atoms from
the object you want to display in the Object Watch window and click the
OK button.
3. The Object Watch window will open with the selected atoms added. You can adjust
the order of the object atoms and create graphs or historical data overviews from the
objects displayed in the Object Watch window.

If the command menu does not open when you right-click an object, you must enable command
menus in the Edit > View Command Menus and check the settings on the Supervise and
Language tab in the System Configuration form in the IGSS Master.
Remove atoms from the Object Watch Window

To remove an atom from the Object Watch, select the atom and click Delete or go to the Edit
tab and click Remove. You can also clear the whole list from the Edit tab by clicking Clear
List (or Ctrl+Delete)
See Also

"What happens when you click on a process object" on page 21

View Object Watch
How to open the Object Watch window

To open the Object Watch, select the View tab and click Watch Window.

The View tab

Change Object Watch location

To change the location of the Object Watch window, select the Window tab and select on any
of the four listed places where you want the Object Watch to be located.
You can also manually resize the Object Watch window and place it anywhere on the screen.
Note:
By default the Object Watch is set to always be on top of any other window, which is the recommended setting.
Change list order

To change the Object Watch list order, select an atom, go to the Edit tab and click Move Up
or Move Down. You can also use the hot keys Ctrl+Up or Ctrl+Down.

Additional features with Object Watch
Find Object from Object Watch

You can locate any of the objects that are currently in the Object Watch Window in the Supervise module..

1. In the Object Watch Window, select the object you want to locate in the Supervise
module.
2. Click Edit tab > Find (or click Ctrl+F) to open the diagram in the Supervise module
which contains the object. If the object resides on multiple diagrams, you must
select which diagram to open.

Save process data from Object Watch

The process data collected from the objects shown in the Object Watch list can be exported to a
.csv file.

1. In the Object Watch window and select the object you want to export process data
from .
2. Click File > Capture to File to open the Save As form and select the location of
the datga file.
3. In the Save As form, select a destination and a file name for the .csv file and finish
by clicking Save. The .csv file is now continuously updated when any object atom
changes.
4. When you do not want to register any further changes in the .csv file go to the File
tab and click Stop Capture.

(Click here to view an .csv file example

View Object Historian from Object Watch

You can access the Object Historianform from the objects listed in the Object Watch Window, viewing historical object data for the selected objects..

1. In the Object Watch Window Select the object or objects you wish to view the
object data.
2. Click Edit > Show History (or click Ctrl+H) to open the Object Historian form and
enter the required parameters.

View graphs from Object Watch

You can generate dynamic graphs for any of the objects listed in the Object Watch.

1. In the Object Watch Window, select the object or objects you wish to create a
dynamic graph for.
2. Click Edit> Show Graph (or click Ctrl+H) to open the Define Graph Period form
and enter the graph parameters.

See Also

"Using the Object Historian" on page 82
"Create your own graph" on page 36

Chapter 9: Broadcasting a message
9.4 Send message to all stations
You can send a short message to all stations that are connected to the IGSS server. A message
window will be displayed in the Supervise module of all operator stations.
You can prevent operators from closing the message window and you can define when the message window will automatically close.

1. In the Supervise module > click Tools > Broadcast Message button to open the
Broadcast Message form .
2. Enter the message you want to send to all stations in the Text message to display on all stations field. You can only enter 400 characters in the message.
1. If you want to prevent operators from closing the message window on
their stations, select the Operators cannot close this message check
box.
2. If you want to define when the message window will automatically close,
select the Remove message after check box and enter the number of
hours the message window is to be displayed. The minimum value is 1
hour and the maximum value is 100 hours.
3. Click the Broadcast Message button to send the message to all connected stations.

You can also send messages to all stations from the Home ribbon in the IGSS Master.

See Also
"The Broadcast Message form" on page 92

9.5 The Broadcast Message form
Use the Broadcast Message form to define and send a message to all online IGSS stations.

Overview
You can define a message which you can send to all online IGSS stations. The IGSS Broadcast Viewer form will be displayed on all receiving IGSS stations.
The message dialog on the receiving IGSS stations will display the following information:

l

the text message.

l

the station from which the message was sent.

l

the date and time the message was received.

IGSS stations that are offline but connect after the message is sent later will not receive the
message but once the message has been received, it can remain visible even if the IGSS station disconnects from the IGSS server.
You can define parameters which can prevent an operator from closing the message dialog and
you can also set how long the message dialog will be displayed on the IGSS stations.
You can only send a message that consists of 400 characters or less but you can send multiple
messages and an IGSS station can receive multiple messages from many other stations.

Preconditions
The Supervise module must be opened and IGSS must be running.
The receiving IGSS Player stations must be online and connected to the IGSS station sending
the message.

Where do I find it?
To open the Broadcast Message form:
l

In the Supervise module, click Tools > Broadcast message.

l

In the IGSS Master , click Home tab> Broadcast Message.

Field Help
Name

Description

Enter the message to be sent to all IGSS stations.
Text message to display on all stations

You can only send a message that consists of 400 characters
or less.
Select this check box to prevent operators from closing the
IGSS Broadcast Viewer form.

Operators cannot close
message

Remove message after

If you select this checkbox, the Close button on theIGSS
Broadcast Viewer form will be disabled for all IGSS stations, including the station that sent the message.
Select this check box to automatically close the IGSS Broadcast Viewer form on all IGSS stations after it has been dis-

Name

Description

played for a number of hours.
You must define the actual number of hours, setting a minimum of one hour and a maximum of 100 hours.

Button Help
Button Name

Description

Broadcast Message

Click this button to send he message to all connected IGSS stations. An empty message cannot be sent.

Cancel

Click this button to close the Broadcast Message form
without sending the message.

See Also
"Send message to all stations" on page 92

Chapter 10: Printing Process Information
10.1 What can you print?
IGSS allows you to print out current process information in different ways:
You may print out …
l

the complete contents of a process diagram

l

the current values of the objects displayed on a process diagram

l

a graph

l

a plant and operations report

l

the contents of the alarm list / alarm log

l

all process alarms as they occur, on a special message printer reserved for continuous message logging

10.2 Print out a process diagram
To take a screen dump of the currently active process diagram, follow the below procedure:

1. In the menu bar, select File → Print → Window.
2. In the Print dialogue select the relevant printer, its properties and specify the print range and the number of copies you wish to have printed.

Note
l

l

l

With File → Page Setup and File → Print Preview you can change the paper format
and page margins, and view the print page before you actually send it to the printer.
It is always the top process window, that is to say, the currently active one, whose contents is printed out.
The command File → Print → Screen prints out the entire contents of the screen,
incl. the title bar, menu bar, etc.

10.3 Print the current values of a process diagram
1. Do one of the following:

l
l

To print all process values from the active diagram, select Edit → Select All Objects.
To print the process values of specific objects, select them one by one while holding
down the SHIFT button. The selected objects will be indicated by a frame around them.

2. In the File menu, select Print Values.
3. The Save As dialogue appears asking you to save the values in an .lst file. Save the data.

Result: The WordPad text editor is automatically opened. You may now edit and print the data
in the form of a list.

Note
With File → Page Setup you can change the paper format and page margins before you actually send the information to the printer.

10.4 Print a complete graph window
1. Open the graph window whose contents you wish to print out.
2. In the menu bar, select File → Print → Window.

Result: A screen dump is taken of the graph window and sent to the printer.

Note:
With File → Page Setup you can change the paper format and page margins before you actually send the information to the printer.

10.5 Print graph values in the form of a list
1. Open the relevant graph window.
2. Click on the right mouse button.
3. In the popup menu, select Show Values List.

Result: The list Graph Values opens, listing the plotted values in numerical form together
with the time of plotting.

4. Press

.

Result: The values of the curves displayed in the graph chart are printed out in the form of a
list.

10.6 Print a report
All reporting facilities included by the system designer can be accessed in the User Programs
menu.

Note: Once you are in the selected report program you have full access to the relevant help
functions.

10.7 Print the alarm list/alarm log
To print out the Alarm List or Alarm Log follow the procedure below:

1. If you are not in the Alarm program, but on a normal process diagram in the Supervise program, select
in the taskbar at the bottom of the screen,
2. In the menu bar of the Alarm program, select File → Print.
3. Make your selections in the Print dialog box.
4. Confirm with OK.

Cut to Paper Width
If this function is selected, the contents of the displayed Alarm List or Log is cut
off if it exceeds the right margin of the printing paper.
If this function is not selected and the contents of the list exceeds the width of
one print page, printing is continued on a second page. In this way you may join
two printed pages to see the entire contents of the list on paper.

Tip
Once you are in the Alarm program you have full access to the relevant help functions.

10.8 Direct message printing
The function of continuous alarm logging on a message printer is enabled or disabled in the System Configuration program by the system designer. The operator has no access to this function. However, if you are given the authority by the system designer, you may decide on the
format of message logging using the command File → Save Format for Alarm Printer in
the Alarm program.

Note
Pressing
in the taskbar at the bottom of the process diagram automatically
takes you into the Alarm program where you have access to all online explanations and help
functions associated with alarm handling.

Chapter 11: Exporting and E-mailing Process Information
11.1 Export functions
Export data from Object Historian

1. Once the required data is displayed in the list, click the Export as CSV button.
2. In the Save As dialogue, give the .csv file a name. IGSS defaults to the report folder for the configuration, but you can choose another folder, if required.

The .csv file can be opened in another program for further processing, for example, in Microsoft
Excel.

Export graph values
If you want to further analyze or make calculations with the graph values, they can be exported
to a Comma Separated Values (.csv) file.

1. Open the graph you want to export.
2. Right-click inside the graph.
3. In the popup menu, select Show Values List.

Show picture

4. Click Export as CSV.
5. In the Save As dialog box, type the name of the .csv file. Use the same name as the graph for the sake
of consistency. Click Save.

Show picture

Note: By default, the file will be saved in the configuration root folder. However, in a multiuser
environment we recommend that you save these files on a network drive so as to make the files
available to the other operators as well.

6. You can now open the .csv file in another program, for example, Microsoft Excel. The
resulting file will look like this.

Show picture

11.2 E-mail functions
Email a diagram
A diagram can be sent as a JPEG file to a mail recipient. In order to send the file, a so-called
MAPI client such as Microsoft Outlook must be installed and set up.

This feature is not supported by Novell and other operating systems.

1. Open the diagram you want to send.

Note: Before you email the diagram, make sure that no other windows lie on top of the diagram.

2. Right-click and select Email Diagram.

Show picture

3. Do the following:

l

In the To field, type the email address of the recipient.

l

In the Subject field, type a descriptive title for the mail.

l

In the text field, type a message just as you would in a normal email.

The Attachments field contains the filename as processed by IGSS. The filename cannot
be changed.

4. Click the Send button to send the email.

Email a graph
A graph can be sent as a JPEG file to a mail recipient. In order to send the file, a MAPI client
such as Microsoft Outlook must be installed and set up.

Note: This feature is not supported by Novell and other operating systems.

1. Open the graph you want to send.
2. Adjust the graph to show exactly what you want to send. IGSS takes a snapshot of the graph as displayed, so if you need to scroll to another time period or zoom in or out, now's the time.
3. Right-click and select Email Graph.

Show picture

4. Do the following:

l

In the To field, type the email address of the recipient.

l

In the Subject field, type a descriptive title for the mail.

l

In the text field, type a message just as you would in a normal email.

The Attachments field contains the filename as processed by IGSS. The filename cannot be
changed.

5. Click the Send button to send the email.

Chapter 12: Command Line Interface
12.1 Supervise: Command line interface
Purpose
You can use a command line interface parameters to generate and print graphs from the Supervise module. This is typically done by using the Job Scheduler module, but can also be done
from a command prompt.

Procedure
Click here
to learn how to use the command line interface either with the Job Scheduler module or the Windows command prompt.

Syntax conventions
The following symbols are used:

Symbol

Description

<parameter>

Placeholder for a variable parameter.

[parameter]

Optional parameter.

Syntax
The following parameters and syntax are used:

Def -r -g <graph name> [-ds] [-ts] [-de] [-te] –f <filename>
If you want to print graphs automatically without user intervention, you must enable the
option in the dialog box for the particular graph in the Definition module.

Name & function

Activate command
line interface

Parameter

Def –r

Description

Activates the Supervise command line interface.

* Used only when
executing in a command prompt.
Open graph

-g <graph name>

Opens the specified graph.

Start date

-ds

Specify a date or a date offset. Specify the
date as yyyy/mm/dd.

Name & function

Parameter

Description

A space must separate the parameter and the
date or date offset.

Note: You can also use the $ symbol to specify an offset from the current date. For
example if you type $-2 the start date is set
to two days before the current date.
Start time

-ts

Specify the start time as hh:mm:ss.
A space must separate the parameter and the
time.

Note: The time is specified in UTC1 time.
End date

-de

You can specify a date or a date offset. Specify the date as yyyy/mm/dd.
A space must separate the parameter and the
date or date offset.

Note: You can also use the $ symbol to specify an offset from the current date. For
example if you type $-2, the end date is set
to two days before the current date.
End time

-te

Specify the time as hh:mm:ss.
A space must separate the parameter and the
time.

Note: The time is specified in UTC time.
Save graph as picture -f <filename>

Saves the graph as a jpeg file with the specified filename. The –f <filename> parameter
is dependant on the above parameters.
Omitting the -f parameter will send the selec-

1 Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating

time in most parts of the world. IGSS uses this time format internally in the database. You can
switch between UTC and local time by enabling or disabling the "UTC" field in various dialog
boxes in the system.

Name & function

Parameter

Description

ted graph to the default printer for print.

Job Scheduler example
This example prints the graph Temperature. The start date is set to 2 days before the current
date and the end date is set to 1 day before and the -f parameter is not used.

Program path:

[IGSS InstallPath]\gss\Def.exe
Parameters:

-r -g Temperature -ds $(date-2) -ts 12:00:00
-de $(date-1) -te 12:00:00
Working folder:
Not used.

Run Style:
Make sure that Normal is selected here otherwise automatic graph printing will not function.

If you are using Job Scheduler, you may want to use the $(date) parameter to specify a
date offset. If Job Scheduler for some reason has postponed say three daily graph printouts, this ensures that you get a graph for each day. Using the simple $ parameter will
set the time to now and thus result in three identical graphs. For example, to specify an
offset of one day, type $(date-1).

Command prompt examples
In the example below, we want to print the Temperature graph covering the previous day.
The $-1 parameter sets the time to midnight by default.

Def -r -g Temperature -ds $-1 -de $
In the second example, we set the start and end time to precisely 7 a.m.

Def -r -g Temperature -ds $-1 -ts 07:00:00 -de $ -te 07:00:00

Chapter 13: Reference and Lookup
13.1 Conventions in this Manual
The following typographical conventions are used:

Convention

Description

User interface element

When referring to labels and names
in the user interface.

User input

When the user has to type specific
data in IGSS

Example

The Data Management tab.

Type the following description:

Incoming flow in Tank 2

Module
name

When referring to a module in IGSS

Note

A note emphasizes or supplements
important points of the main text. A
note provides information that may
apply only in special cases.

By default, the timestamp is in
universal time format, UTC1.
This can be changed in the
Driver Log Filters dialog box.

Tip

A tip suggests alternative methods
that may not be obvious in the user
interface. A tip also helps the user in
working more effectively with IGSS.
A tip is not essential to the basic
understanding of the text.

Alternative to this
simple find function, you can also
filter on text in the
messages in Driver
Log Filters dialog
box.

Warning

A warning is an important note that is
essential for the completion of a
task. In some cases, disregarding a
warning may result in undesirable
functionality or loss of data.

If you disregard the
System alarm, you
may risk loss of
data in the LOG
and BCL files.

Open the Definition module.

1 Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating

time in most parts of the world. IGSS uses this time format internally in the database. You can
switch between UTC and local time by enabling or disabling the "UTC" field in various dialog
boxes in the system.

13.2 Getting Help in IGSS
IGSS comes with a comprehensive help system designed to help both system designers and
operators to get started with IGSS as quickly as possible.

Documentation overview
The IGSS documentation includes the following items:

Documentation item

Description

Getting Started

An introduction to IGSS and its most fundamental terms and
features. Getting Started is intended to get you up and running
as fast as possible. The manual provides a system and architecture overview followed by a number of real-life use cases
you can go through before building your first real IGSS project.
The manual is available in Adobe Acrobat format (.pdf).
For each module there is a help file with the same name as the
module itself, for example, Def.chm for the Definition module.

Module help

The help file is invoked by clicking the
in the upper right
corner of the module. The Table of Contents will then allow you
to browse through the topics.
For each Form or dialog there is a help topic with the following
standard information:

Form and Dialog help̓

l

Overview

l

Preconditions

l

Where do I find it?

l

Field help

Form help is invoked by clicking the help button
in the
upper right hand corner of the dialog box or located in the
Table of Contents of the individual help file.

Thematic help

IGSS also provides thematic help. When there is a special
theme that requires special attention from the user, a dedicated help file is provided. Examples include "Driver-Specific
Help" and "Database Administration Help".

Where are the help files located?

The IGSS help files are located in the appropriate language folder in the installation path of
IGSS, by default C:\Program Files\Schneider Electric\IGSS32\V11.0. The help files are available in English at release time.
The paths to the help files are:

Language

Path

English

[IGSS InstallPath]\ENG

Danish

[IGSS InstallPath]\DAN

German

[IGSS InstallPath]\DEU

Translated help files
Selected help files have been translated into Danish and German. If you require help files in
your language, please contact Schneider Electric.

Help updates
The help files are continuously updated and improved. Check regularly with the IGSS Update in
the IGSS Master.

13.3 Version Information (IGSS Help System)
© Schneider Electric, IGSS Version 11.0
The IGSS help files are based on software build number 10305 (initial release)

English help files
To update the help files, click the Update IGSS Software button on the Information and
Support tab in the IGSS Master. There must be a connection from the PC to the Internet.
Every time IGSS Update is run, IGSS help files as well as IGSS system files will automatically
be updated on the PC from the web server at Schneider Electric.
You select the languages you want to update in the Tools menu of the IGSS Update form.
If you are not able to update the IGSS system directly via the Internet, the alternative is to
download the updates from the Schneider Electric website as zip files. These can then be transferred onto a CD or USB memory stick, which is then the medium used to update on site.

After updating your IGSS installation , the build numbers in various IGSS modules may
change to a higher number. This signifies that the module in question has been updated
with newer files. Build numbers consist of four digits, where the first digit represents the

year and the last three represent the day number in the year in question. The build number can be seen in the About dialog box which can be activated from the Help menu.
An example:

Build number = 10305
13 = the year 2013
305 = The 305th day of the year

Chapter 14: Glossary
A
Action Pane
The left pane of the main window in the Master module. Contains shortcuts to IGSS
modules and allows you to define your own shortcuts to other applications used with
IGSS.
Application menu
The Application menu is the first ribbon in the IGSS Master module. Click the icon to
drop down the menu. The menu contains items that were typically found in the File
menu in previous versions of IGSS. In most modules, an "Options" item allows the
user to define global module settings. The Application menu was introduced in the
Microsoft Office 2010 package. It replaces the Application button (nicknamed Doughnut) which was introduced in IGSS V7 and V8.

D
descriptor
A descriptor is the graphical display of an object. IGSS includes many types of
descriptors including: - Built-in standard symbols - Animated symbols (Symbol Factory library) - Graphics and animation - Drawing symbols - Windows controls - ActiveX
controls An IGSS object can be represented with different descriptors on different diagrams.

R
Ribbon
The Ribbon is a new term/element in the Microsoft universe. The Ribbon replaces the
well-known toolbars in applications. The Ribbon provides quick access to the most
commonly used functions in the application. The Ribbon is divided into logical groups
(the tabs) and each tab is divided into sections (the blocks in the tab). The Ribbon is
context-sensitive which means that only relevant functions are accessible dependent
on the current user action.

S
SCADA
Supervisory Control & Data Acquisition

U
UTC
Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for
calculating time in most parts of the world. IGSS uses this time format internally in
the database. You can switch between UTC and local time by enabling or disabling the
"UTC" field in various dialog boxes in the system.

W
Windows Shell
The Master module can be set as the Windows shell application. This will mean that
the operator cannot access normal Windows functions. Only functions accessible
through the IGSS .NET will be available.

